summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-05-11 13:19:33 +0200
committerMichel Zou2018-05-11 13:19:33 +0200
commit9d19c9e988f0bc73f335b06756df94d6c709b028 (patch)
tree384d2cea487fba21e78864e0436475c94f54e8ad
parent60bc288b6770c189e39b501d0a0e05b05fdb40f9 (diff)
downloadaur-9d19c9e988f0bc73f335b06756df94d6c709b028.tar.gz
split wine package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--mingw-wine.sh26
3 files changed, 9 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 246d526cb1d8..2e68d9d1bd12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
# Generated by mksrcinfo v8
-# Thu May 3 19:34:06 UTC 2018
+# Fri May 11 11:19:33 UTC 2018
pkgbase = mingw-w64-cmake
pkgdesc = CMake wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 21
+ pkgrel = 22
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
depends = cmake
depends = mingw-w64-gcc
depends = mingw-w64-pkg-config
- optdepends = wine: runtime support
+ optdepends = mingw-w64-wine: runtime support
source = mingw-cmake.sh
source = toolchain-mingw.cmake
- source = mingw-wine.sh
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mingw-w64-cmake
diff --git a/PKGBUILD b/PKGBUILD
index 84c77cc56435..934c91a8975e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
pkgname=mingw-w64-cmake
pkgver=1
-pkgrel=21
+pkgrel=22
arch=('any')
pkgdesc="CMake wrapper for MinGW (mingw-w64)"
depends=('cmake' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
-optdepends=('wine: runtime support')
+optdepends=('mingw-w64-wine: runtime support')
license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("mingw-cmake.sh"
- "toolchain-mingw.cmake"
- "mingw-wine.sh")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+ "toolchain-mingw.cmake")
+sha256sums=('SKIP' 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
for _arch in ${_architectures}; do
sed "s|@TRIPLE@|${_arch}|g;s|@PROCESSOR@|${_arch::-12}|g" toolchain-mingw.cmake > toolchain-${_arch}.cmake
sed "s|@TRIPLE@|${_arch}|g" mingw-cmake.sh > ${_arch}-cmake
- sed "s|@TRIPLE@|${_arch}|g" mingw-wine.sh > ${_arch}-wine
done
}
@@ -28,7 +26,6 @@ package() {
for _arch in ${_architectures}; do
install -m 644 toolchain-${_arch}.cmake "${pkgdir}"/usr/share/mingw/
install -m 755 ${_arch}-cmake "${pkgdir}"/usr/bin/
- install -m 755 ${_arch}-wine "${pkgdir}"/usr/bin/
done
}
diff --git a/mingw-wine.sh b/mingw-wine.sh
deleted file mode 100644
index d3cebe1b9dff..000000000000
--- a/mingw-wine.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-set -e
-
-mingw_prefix=/usr/@TRIPLE@
-
-# run it in a custom WINEPREFIX to not mess with default ~/.wine
-# also default prefix might be a 32 bits prefix, which will fail to run x86_64 exes
-export WINEPREFIX=~/.wine-@TRIPLE@
-
-# WINEPATH is used to find dlls, otherwise they should lie next to the exe
-if test -z "${WINEPATH}"
-then
- export WINEPATH=${mingw_prefix}/bin
-fi
-
-
-if test "@TRIPLE@" = "x86_64-w64-mingw32"
-then
- export WINEARCH=win64
-else
- export WINEARCH=win32
-fi
-
-wine "$@"
-