summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-08 16:40:36 +0200
committerMichel Zou2020-04-08 16:40:36 +0200
commit4a3316f4fe0b5630307f5f9496447360ddf09d58 (patch)
treeda5a2c9d3a13dceefe5fb2d26b8fe7dee5c69f7b
parent443b6be012a5918b3861753116cb2bb6cba29982 (diff)
downloadaur-4a3316f4fe0b5630307f5f9496447360ddf09d58.tar.gz
tgz
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90f64d61362..9c3c77021b03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,9 @@ pkgbase = mingw-w64-coin-or-asl
options = !strip
options = staticlibs
source = https://github.com/coin-or-tools/ThirdParty-ASL/archive/releases/1.4.3.tar.gz
+ source = https://coin-or-tools.github.io/ThirdParty-ASL/solvers-64919f75f.tgz
sha256sums = 0a4cfa7c6c5df72d8e1c4c3ce74633421f807115a679e85cb5569c41df9a9aaf
+ sha256sums = e212926d1d797701adc901ef18eaab6b15edd13f9281dd8c9266e3cdaf8c2dd3
pkgname = mingw-w64-coin-or-asl
diff --git a/PKGBUILD b/PKGBUILD
index 27345fa5551e..3c3b0d41b4c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,16 @@ groups=('mingw-w64-coin-or')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-configure' 'mingw-w64-wine' 'wget')
options=('!buildflags' '!strip' 'staticlibs')
-source=("https://github.com/coin-or-tools/ThirdParty-ASL/archive/releases/$pkgver.tar.gz")
-sha256sums=('0a4cfa7c6c5df72d8e1c4c3ce74633421f807115a679e85cb5569c41df9a9aaf')
+source=("https://github.com/coin-or-tools/ThirdParty-ASL/archive/releases/$pkgver.tar.gz"
+ https://coin-or-tools.github.io/ThirdParty-ASL/solvers-64919f75f.tgz)
+sha256sums=('0a4cfa7c6c5df72d8e1c4c3ce74633421f807115a679e85cb5569c41df9a9aaf'
+ 'e212926d1d797701adc901ef18eaab6b15edd13f9281dd8c9266e3cdaf8c2dd3')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "ThirdParty-ASL-releases-$pkgver"
- ./get.ASL
-
+ ln -s ../solvers .
# run configuration exe through wine
sed -i "s|./a.out >arith.h|\$(MINGW_TARGET)-wine ./a.exe >arith.h|g" solvers/makefile.u
}