summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-09-06 10:51:52 +0200
committerMichel Zou2019-09-06 10:51:52 +0200
commit294b19ce341d3baec7c1f68ecc86fd39a35e594d (patch)
treef3d252c27bc386879a103da1174ceea9299e0aec
parent97fe35d6637b7ead938a8254cca68c6facfa1b56 (diff)
downloadaur-294b19ce341d3baec7c1f68ecc86fd39a35e594d.tar.gz
pass_all
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a5e709315fd..affb32f52de9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = mingw-w64-coin-or-bcp
pkgrel = 1
url = https://projects.coin-or.org/Bcp
arch = any
- groups = coin-or
+ groups = mingw-w64-coin-or
license = EPL
makedepends = mingw-w64-configure
depends = mingw-w64-coin-or-vol
diff --git a/PKGBUILD b/PKGBUILD
index 5ea07aa6c490..cc8b8c08379c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="COIN-OR parallel branch-cut-price algorithms for mixed-integer linear p
arch=('any')
url="https://projects.coin-or.org/Bcp"
license=('EPL')
-groups=('coin-or')
+groups=('mingw-w64-coin-or')
depends=('mingw-w64-coin-or-vol' 'mingw-w64-coin-or-cgl')
makedepends=('mingw-w64-configure')
options=('staticlibs' '!buildflags' '!strip')
@@ -19,18 +19,18 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
COIN_SKIP_PROJECTS="Sample" \
- ${_arch}-configure --disable-shared \
- --with-osi-lib="$(${_arch}-pkg-config --libs osi)" \
- --with-osi-incdir="/usr/${_arch}/include/coin/" \
- --with-clp-lib="$(${_arch}-pkg-config --libs clp)" \
- --with-clp-incdir="/usr/${_arch}/include/coin/" \
- --with-cgl-lib="$(${_arch}-pkg-config --libs cgl)" \
- --with-cgl-incdir="/usr/${_arch}/include/coin/" \
- --with-vol-lib="$(${_arch}-pkg-config --libs vol)" \
- --with-vol-incdir="/usr/${_arch}/include/coin/" \
- --with-coinutils-lib="$(${_arch}-pkg-config --libs coinutils)" \
- --with-coinutils-incdir="/usr/${_arch}/include/coin/" \
- ..
+ ${_arch}-configure \
+ --with-osi-lib="$(${_arch}-pkg-config --libs osi)" \
+ --with-osi-incdir="/usr/${_arch}/include/coin/" \
+ --with-clp-lib="$(${_arch}-pkg-config --libs clp)" \
+ --with-clp-incdir="/usr/${_arch}/include/coin/" \
+ --with-cgl-lib="$(${_arch}-pkg-config --libs cgl)" \
+ --with-cgl-incdir="/usr/${_arch}/include/coin/" \
+ --with-vol-lib="$(${_arch}-pkg-config --libs vol)" \
+ --with-vol-incdir="/usr/${_arch}/include/coin/" \
+ --with-coinutils-lib="$(${_arch}-pkg-config --libs coinutils)" \
+ --with-coinutils-incdir="/usr/${_arch}/include/coin/" \
+ lt_cv_deplibs_check_method=pass_all ..
make
popd
done
@@ -43,7 +43,7 @@ package() {
make DESTDIR="$pkgdir"/ install
rm -r "$pkgdir"/usr/${_arch}/share
#rm "$pkgdir"/usr/${_arch}/bin/*.exe
- #${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}