summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-28 19:31:37 +0100
committerMichel Zou2019-11-28 19:31:37 +0100
commitfc91ae13c58ed9a49af6bd1e94a55ad86d539908 (patch)
treea7dbbe64c88fafd565e15d3c12f0c40ab102b19e
parentfecb273246c85e0a355f9be24ea0062002442163 (diff)
downloadaur-fc91ae13c58ed9a49af6bd1e94a55ad86d539908.tar.gz
3.13.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94bbb494ba5d..adde2d47f208 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-coin-or-ipopt
pkgdesc = Interior Point OPTimizer (mingw-w64)
- pkgver = 3.12.13
+ pkgver = 3.13.0
pkgrel = 1
url = https://projects.coin-or.org/Ipopt
arch = any
@@ -10,11 +10,13 @@ pkgbase = mingw-w64-coin-or-ipopt
makedepends = mingw-w64-wine
makedepends = wget
depends = mingw-w64-lapack
+ depends = mingw-w64-coin-or-coinasl
+ depends = mingw-w64-coin-or-coinmumps
options = staticlibs
options = !buildflags
options = !strip
- source = http://www.coin-or.org/download/source/Ipopt/Ipopt-3.12.13.tgz
- sha256sums = aac9bb4d8a257fdfacc54ff3f1cbfdf6e2d61fb0cf395749e3b0c0664d3e7e96
+ source = http://www.coin-or.org/download/source/Ipopt/Ipopt-3.13.0.tgz
+ sha256sums = dc392396be28c4a0d49bfab399320cb3f70db5b8f090028a883d826a47744ecf
pkgname = mingw-w64-coin-or-ipopt
diff --git a/PKGBUILD b/PKGBUILD
index 30808bd15633..a07fc07c237a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,46 @@
pkgname=mingw-w64-coin-or-ipopt
-pkgver=3.12.13
+pkgver=3.13.0
pkgrel=1
pkgdesc="Interior Point OPTimizer (mingw-w64)"
arch=('any')
url="https://projects.coin-or.org/Ipopt"
license=('EPL')
groups=('mingw-w64-coin-or')
-depends=('mingw-w64-lapack')
+depends=('mingw-w64-lapack' 'mingw-w64-coin-or-coinasl' 'mingw-w64-coin-or-coinmumps')
makedepends=('mingw-w64-configure' 'mingw-w64-wine' 'wget')
options=('staticlibs' '!buildflags' '!strip')
source=("http://www.coin-or.org/download/source/Ipopt/Ipopt-$pkgver.tgz")
-sha256sums=('aac9bb4d8a257fdfacc54ff3f1cbfdf6e2d61fb0cf395749e3b0c0664d3e7e96')
+sha256sums=('dc392396be28c4a0d49bfab399320cb3f70db5b8f090028a883d826a47744ecf')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
- cd "$srcdir/Ipopt-$pkgver"
- pushd ThirdParty/ASL && ./get.ASL && popd
- pushd ThirdParty/Metis && ./get.Metis && popd
- pushd ThirdParty/Mumps && ./get.Mumps && popd
-
- # see mingw-w64-coin-or-pkg-config
- sed -i "s|export PKG_CONFIG_PATH|export PKG_CONFIG_PATH_CUSTOM|g" Ipopt/configure
- sed -i "s| PKG_CONFIG_PATH=| PKG_CONFIG_PATH_CUSTOM=|g" Ipopt/configure
-
- # run ASL configuration exe through wine
- sed -i "s|./a.out >arith.h|\$(MINGW_TARGET)-wine ./a.exe >arith.h|g" ThirdParty/ASL/solvers/makefile.u
+ cd "$srcdir/Ipopt-releases-$pkgver"
}
build() {
- cd "$srcdir/Ipopt-$pkgver"
+ cd "$srcdir/Ipopt-releases-$pkgver"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
--with-blas-incdir=/usr/${_arch}/include --with-blas-lib="-lblas" \
--with-lapack-incdir=/usr/${_arch}/include --with-lapack-lib="-llapack" \
- lt_cv_deplibs_check_method=pass_all ..
- make MINGW_TARGET=${_arch}
+ lt_cv_deplibs_check_method=pass_all --without-hsl --disable-java ..
+ make
popd
done
}
package() {
for _arch in ${_architectures}; do
- cd "$srcdir"/Ipopt-$pkgver/build-${_arch}
- PKG_CONFIG_PATH_CUSTOM="$pkgdir"/usr/${_arch}/lib/pkgconfig/ \
+ cd "$srcdir"/Ipopt-releases-$pkgver/build-${_arch}
make DESTDIR="$pkgdir"/ install
rm -r "$pkgdir"/usr/${_arch}/share
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ # for compatibility
+ install -d "$pkgdir"/usr/${_arch}/include/coin
+ cp -r "$pkgdir"/usr/${_arch}/include/coin-or/* "$pkgdir"/usr/${_arch}/include/coin
done
}