summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-02-04 21:03:28 +0100
committerMichel Zou2019-02-04 21:03:28 +0100
commitb70fa9d4ae588e7f513bcfef634f5863e83d6f45 (patch)
tree0732e96248e70a0fea8aaeda11e5463d949f5bfe
downloadaur-b70fa9d4ae588e7f513bcfef634f5863e83d6f45.tar.gz
1.8.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20de836aaad0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-coin-or-mp
+ pkgdesc = C-API library that supports most of the functionality of CLP (Coin LP), CBC (Coin Branch-and-Cut), and CGL (Cut Generation Library) projects (mingw-w64)
+ pkgver = 1.8.3
+ pkgrel = 1
+ url = https://projects.coin-or.org/CoinMP
+ arch = any
+ groups = coin-or
+ license = EPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-coin-or-cbc
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = https://www.coin-or.org/download/source/CoinMP/CoinMP-1.8.3.tgz
+ sha256sums = a1a665db36c7fd69c1e53fffbd108cae1bf22f08acf81c394cd454b8168f22f7
+
+pkgname = mingw-w64-coin-or-mp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b7e91c5995
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+
+pkgname=mingw-w64-coin-or-mp
+pkgver=1.8.3
+pkgrel=1
+pkgdesc="C-API library that supports most of the functionality of CLP (Coin LP), CBC (Coin Branch-and-Cut), and CGL (Cut Generation Library) projects (mingw-w64)"
+arch=(any)
+url="https://projects.coin-or.org/CoinMP"
+license=(EPL)
+groups=(coin-or)
+depends=(mingw-w64-coin-or-cbc)
+makedepends=('mingw-w64-configure')
+options=('staticlibs' '!buildflags' '!strip')
+source=(https://www.coin-or.org/download/source/CoinMP/CoinMP-$pkgver.tgz)
+sha256sums=('a1a665db36c7fd69c1e53fffbd108cae1bf22f08acf81c394cd454b8168f22f7')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd CoinMP-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ COIN_SKIP_PROJECTS="Sample" \
+ ${_arch}-configure \
+ --with-osi-lib="$(${_arch}-pkg-config --libs osi)" \
+ --with-osi-incdir="/usr/${_arch}/include/coin/" \
+ --with-clp-lib="$(${_arch}-pkg-config --libs clp)" \
+ --with-clp-incdir="/usr/${_arch}/include/coin/" \
+ --with-cgl-lib="$(${_arch}-pkg-config --libs cgl)" \
+ --with-cgl-incdir="/usr/${_arch}/include/coin/" \
+ --with-cbc-lib="$(${_arch}-pkg-config --libs cbc)" \
+ --with-cbc-incdir="/usr/${_arch}/include/coin/" \
+ --with-coinutils-lib="$(${_arch}-pkg-config --libs coinutils)" \
+ --with-coinutils-incdir="/usr/${_arch}/include/coin/" \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/CoinMP-$pkgver/build-${_arch}
+ PKG_CONFIG_PATH_CUSTOM="$pkgdir"/usr/${_arch}/lib/pkgconfig/ \
+ make DESTDIR="$pkgdir"/ install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ rm -r "$pkgdir"/home
+# rm "$pkgdir"/usr/${_arch}/lib/pkgconfig/coindatanetlib.pc
+# rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ #${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}