summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 22:43:53 +0200
committerxantares2015-06-08 22:43:53 +0200
commit6c1142691ceeb27efa980afaf347157bddb0be50 (patch)
tree2b16bdfbd90c277006d18b7aea8d2869228cf82f
downloadaur-6c1142691ceeb27efa980afaf347157bddb0be50.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b32a2a28d622
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-coin-or-vol
+ pkgdesc = COIN-OR Volume Algorithm (mingw-w64)
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://projects.coin-or.org/Vol
+ arch = any
+ groups = coin-or
+ license = EPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-coin-or-osi
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = http://www.coin-or.org/download/source/Vol/Vol-1.5.0.tgz
+ sha1sums = e53dd21eb28fb5a60ed39492d054cceafeb39ddf
+
+pkgname = mingw-w64-coin-or-vol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14cd65f2f53a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: spider-mario <spidermario@free.fr>
+# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
+
+pkgname=mingw-w64-coin-or-vol
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="COIN-OR Volume Algorithm (mingw-w64)"
+arch=('any')
+url="https://projects.coin-or.org/Vol"
+license=('EPL')
+groups=('coin-or')
+depends=('mingw-w64-coin-or-osi')
+makedepends=('mingw-w64-configure')
+options=('staticlibs' '!buildflags' '!strip')
+source=("http://www.coin-or.org/download/source/Vol/Vol-${pkgver}.tgz")
+sha1sums=('e53dd21eb28fb5a60ed39492d054cceafeb39ddf')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd Vol-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ COIN_SKIP_PROJECTS="Sample" \
+ ${_arch}-configure \
+ --with-osi-lib="$(${_arch}-pkg-config --libs osi)" \
+ --with-osi-incdir="/usr/${_arch}/include/coin/" \
+ --with-coinutils-lib="$(${_arch}-pkg-config --libs coinutils)" \
+ --with-coinutils-incdir="/usr/${_arch}/include/coin/"
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/Vol-$pkgver/build-${_arch}
+ PKG_CONFIG_PATH_CUSTOM="$pkgdir"/usr/${_arch}/lib/pkgconfig/ \
+ make DESTDIR="$pkgdir"/ install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ #rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ #${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}