summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-12-02 21:50:27 +0100
committerMichel Zou2019-12-02 21:50:27 +0100
commit86b1e0bb0d04aefec15bf3a15e9edbbd87530ad1 (patch)
treee6ec7350356749b70d0360e5e458a9e33a0f65b6
parent608472efb42789e9342dcaf9d703e51c7aa2cb81 (diff)
downloadaur-86b1e0bb0d04aefec15bf3a15e9edbbd87530ad1.tar.gz
mingw-w64-environment
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--mingw-configure.sh11
3 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b62e9748fc7..56df9b001abe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = mingw-w64-configure
pkgdesc = configure wrapper for MinGW (mingw-w64)
pkgver = 0.1.1
- pkgrel = 8
+ pkgrel = 9
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
depends = mingw-w64-gcc
depends = mingw-w64-pkg-config
+ depends = mingw-w64-environment
source = mingw-configure.sh
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 864cfbc293ff..2d16428edef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=mingw-w64-configure
pkgver=0.1.1
-pkgrel=8
-arch=(any)
+pkgrel=9
+arch=('any')
pkgdesc="configure wrapper for MinGW (mingw-w64)"
-depends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+depends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-environment')
license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("mingw-configure.sh")
@@ -24,4 +24,3 @@ package() {
install -m 755 ${_arch}-configure "${pkgdir}"/usr/bin/
done
}
-
diff --git a/mingw-configure.sh b/mingw-configure.sh
index 5f89c4316c29..ca5abf9f5425 100644
--- a/mingw-configure.sh
+++ b/mingw-configure.sh
@@ -1,5 +1,7 @@
#!/bin/sh
+source mingw-env @TRIPLE@
+
# check if last arg is a path to configure, else use parent
for last; do true; done
if test -x "${last}/configure"; then
@@ -8,15 +10,6 @@ else
config_path=".."
fi
-default_mingw_pp_flags="-D_FORTIFY_SOURCE=2"
-default_mingw_compiler_flags="-O2 -pipe -fno-plt -fexceptions --param=ssp-buffer-size=4"
-default_mingw_linker_flags="-Wl,-O1,--sort-common,--as-needed -fstack-protector"
-
-export CPPFLAGS="${MINGW_CPPFLAGS:-$default_mingw_pp_flags $CPPFLAGS}"
-export CFLAGS="${MINGW_CFLAGS:-$default_mingw_compiler_flags $CFLAGS}"
-export CXXFLAGS="${MINGW_CXXFLAGS:-$default_mingw_compiler_flags $CXXFLAGS}"
-export LDFLAGS="${MINGW_LDFLAGS:-$default_mingw_linker_flags $LDFLAGS}"
-
${config_path}/configure \
--host=@TRIPLE@ --target=@TRIPLE@ --build="$CHOST" \
--prefix=/usr/@TRIPLE@ --libdir=/usr/@TRIPLE@/lib --includedir=/usr/@TRIPLE@/include \