summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-05-18 14:41:44 +0200
committerMartchus2022-05-18 14:41:44 +0200
commit1d79b977e2bc7d9f235d679f387146fddc654124 (patch)
treeb7263957f56c1059fce7d6c0083235fac399a8eb
parent8ef2a0bb2cff93ff604fa8d1c959c7e9742bee6d (diff)
downloadaur-mingw-w64-cppunit.tar.gz
Update to 1.15.1
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Don-t-redefine-NOMINMAX.patch49
-rw-r--r--PKGBUILD4
3 files changed, 54 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7149781f21..1bbdbca2dcfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-cppunit
pkgdesc = A C++ unit testing framework (mingw-w64)
- pkgver = 1.15.0
+ pkgver = 1.15.1
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/cppunit
arch = any
@@ -13,8 +13,7 @@ pkgbase = mingw-w64-cppunit
options = !libtool
options = staticlibs
options = !emptydirs
- source = https://dev-www.libreoffice.org/src/cppunit-1.15.0.tar.gz
- sha256sums = 1c61dfdb430e04ebb411e4b80fbd49fe7e63a1be0209a76d7c07501f02834922
+ source = https://dev-www.libreoffice.org/src/cppunit-1.15.1.tar.gz
+ sha256sums = 89c5c6665337f56fd2db36bc3805a5619709d51fb136e51937072f63fcc717a7
pkgname = mingw-w64-cppunit
-
diff --git a/0001-Don-t-redefine-NOMINMAX.patch b/0001-Don-t-redefine-NOMINMAX.patch
new file mode 100644
index 000000000000..c0c55ba2f74b
--- /dev/null
+++ b/0001-Don-t-redefine-NOMINMAX.patch
@@ -0,0 +1,49 @@
+From 8ff5b7fbc0a2e1e97c3812602d449b0e547962c0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Mon, 11 Jun 2018 20:14:42 +0200
+Subject: [PATCH] Don't redefine NOMINMAX
+
+In file included from ../../../src/cppunit/PlugInManager.cpp:8:
+../../../include/cppunit/plugin/TestPlugIn.h:149: error: "NOMINMAX" redefined [-Werror]
+ #define NOMINMAX
+
+In file included from /usr/i686-w64-mingw32/include/c++/8.1.0/i686-w64-mingw32/bits/c++config.h:508,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/bits/stl_algobase.h:59,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/bits/stl_tree.h:63,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/set:60,
+ from ../../../include/cppunit/extensions/TestFactoryRegistry.h:11,
+ from ../../../src/cppunit/PlugInManager.cpp:6:
+/usr/i686-w64-mingw32/include/c++/8.1.0/i686-w64-mingw32/bits/os_defines.h:45: note: this is the location of the previous definition
+ #define NOMINMAX 1
+---
+ include/cppunit/plugin/TestPlugIn.h | 1 -
+ src/cppunit/Win32DynamicLibraryManager.cpp | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/include/cppunit/plugin/TestPlugIn.h b/include/cppunit/plugin/TestPlugIn.h
+index 52b5b35..ab00c5c 100644
+--- a/include/cppunit/plugin/TestPlugIn.h
++++ b/include/cppunit/plugin/TestPlugIn.h
+@@ -146,7 +146,6 @@ typedef CppUnitTestPlugIn *(*TestPlugInSignature)();
+ #define NOUSER
+ #define NOKERNEL
+ #define NOSOUND
+-#define NOMINMAX
+ #define BLENDFUNCTION void // for mingw & gcc
+ #include <windows.h>
+ #endif
+diff --git a/src/cppunit/Win32DynamicLibraryManager.cpp b/src/cppunit/Win32DynamicLibraryManager.cpp
+index acadf46..f8009c0 100644
+--- a/src/cppunit/Win32DynamicLibraryManager.cpp
++++ b/src/cppunit/Win32DynamicLibraryManager.cpp
+@@ -8,7 +8,6 @@
+ #define NOUSER
+ #define NOKERNEL
+ #define NOSOUND
+-#define NOMINMAX
+ #define BLENDFUNCTION void // for mingw & gcc
+ #include <windows.h>
+
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 5bcf3dbce7b0..d41f8ef05489 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_name=cppunit
pkgname=mingw-w64-cppunit
-pkgver=1.15.0
+pkgver=1.15.1
pkgrel=1
pkgdesc="A C++ unit testing framework (mingw-w64)"
arch=('any')
@@ -17,7 +17,7 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
options=(!strip !buildflags !libtool staticlibs !emptydirs)
source=("https://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz")
-sha256sums=('1c61dfdb430e04ebb411e4b80fbd49fe7e63a1be0209a76d7c07501f02834922')
+sha256sums=('89c5c6665337f56fd2db36bc3805a5619709d51fb136e51937072f63fcc717a7')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"