summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-06-11 20:27:38 +0200
committerMartchus2018-06-11 20:27:38 +0200
commit8820dec5cbfa54e35f6a99fff87a1e7458d2983a (patch)
treeca75c08b46f4299289d517c65e690a64f2a4009b
parent04d2741f5088c19c342d78681289cc019f31b1d5 (diff)
downloadaur-8820dec5cbfa54e35f6a99fff87a1e7458d2983a.tar.gz
Update to 1.14.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Don-t-redefine-NOMINMAX.patch49
-rw-r--r--PKGBUILD21
3 files changed, 70 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fb12862e71d..444f4a21b542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Jul 12 00:54:19 UTC 2016
pkgbase = mingw-w64-cppunit
pkgdesc = A C++ unit testing framework (mingw-w64)
- pkgver = 1.13.2
+ pkgver = 1.14.0
pkgrel = 1
url = http://www.freedesktop.org/wiki/Software/cppunit
arch = any
@@ -15,8 +13,10 @@ pkgbase = mingw-w64-cppunit
options = !libtool
options = staticlibs
options = !emptydirs
- source = http://dev-www.libreoffice.org/src/cppunit-1.13.2.tar.gz
- md5sums = d1c6bdd5a76c66d2c38331e2d287bc01
+ source = https://dev-www.libreoffice.org/src/cppunit-1.14.0.tar.gz
+ source = 0001-Don-t-redefine-NOMINMAX.patch
+ sha256sums = 3d569869d27b48860210c758c4f313082103a5e58219a7669b52bfd29d674780
+ sha256sums = 68ae7a200a6bea8669268665c9a2b80c96a90fbf07273749184ce7a7f190cd40
pkgname = mingw-w64-cppunit
diff --git a/0001-Don-t-redefine-NOMINMAX.patch b/0001-Don-t-redefine-NOMINMAX.patch
new file mode 100644
index 000000000000..c0c55ba2f74b
--- /dev/null
+++ b/0001-Don-t-redefine-NOMINMAX.patch
@@ -0,0 +1,49 @@
+From 8ff5b7fbc0a2e1e97c3812602d449b0e547962c0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Mon, 11 Jun 2018 20:14:42 +0200
+Subject: [PATCH] Don't redefine NOMINMAX
+
+In file included from ../../../src/cppunit/PlugInManager.cpp:8:
+../../../include/cppunit/plugin/TestPlugIn.h:149: error: "NOMINMAX" redefined [-Werror]
+ #define NOMINMAX
+
+In file included from /usr/i686-w64-mingw32/include/c++/8.1.0/i686-w64-mingw32/bits/c++config.h:508,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/bits/stl_algobase.h:59,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/bits/stl_tree.h:63,
+ from /usr/i686-w64-mingw32/include/c++/8.1.0/set:60,
+ from ../../../include/cppunit/extensions/TestFactoryRegistry.h:11,
+ from ../../../src/cppunit/PlugInManager.cpp:6:
+/usr/i686-w64-mingw32/include/c++/8.1.0/i686-w64-mingw32/bits/os_defines.h:45: note: this is the location of the previous definition
+ #define NOMINMAX 1
+---
+ include/cppunit/plugin/TestPlugIn.h | 1 -
+ src/cppunit/Win32DynamicLibraryManager.cpp | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/include/cppunit/plugin/TestPlugIn.h b/include/cppunit/plugin/TestPlugIn.h
+index 52b5b35..ab00c5c 100644
+--- a/include/cppunit/plugin/TestPlugIn.h
++++ b/include/cppunit/plugin/TestPlugIn.h
+@@ -146,7 +146,6 @@ typedef CppUnitTestPlugIn *(*TestPlugInSignature)();
+ #define NOUSER
+ #define NOKERNEL
+ #define NOSOUND
+-#define NOMINMAX
+ #define BLENDFUNCTION void // for mingw & gcc
+ #include <windows.h>
+ #endif
+diff --git a/src/cppunit/Win32DynamicLibraryManager.cpp b/src/cppunit/Win32DynamicLibraryManager.cpp
+index acadf46..f8009c0 100644
+--- a/src/cppunit/Win32DynamicLibraryManager.cpp
++++ b/src/cppunit/Win32DynamicLibraryManager.cpp
+@@ -8,7 +8,6 @@
+ #define NOUSER
+ #define NOKERNEL
+ #define NOSOUND
+-#define NOMINMAX
+ #define BLENDFUNCTION void // for mingw & gcc
+ #include <windows.h>
+
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index b3f2c0674825..146042e75e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_name=cppunit
pkgname=mingw-w64-cppunit
-pkgver=1.13.2
+pkgver=1.14.0
pkgrel=1
pkgdesc="A C++ unit testing framework (mingw-w64)"
arch=('any')
@@ -16,11 +16,21 @@ license=('LGPL')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
options=(!strip !buildflags !libtool staticlibs !emptydirs)
-source=("http://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz")
-md5sums=('d1c6bdd5a76c66d2c38331e2d287bc01')
+source=("https://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz"
+ 0001-Don-t-redefine-NOMINMAX.patch)
+sha256sums=('3d569869d27b48860210c758c4f313082103a5e58219a7669b52bfd29d674780'
+ '68ae7a200a6bea8669268665c9a2b80c96a90fbf07273749184ce7a7f190cd40')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}"
@@ -36,7 +46,8 @@ package() {
cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}/usr/${_arch}/share/"
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -exec ${_arch}-strip -g {} \;
done
}