summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-05-31 10:46:13 +0800
committerpingplug2018-05-31 10:46:13 +0800
commit55399a68960cf8f0e801363c6ae47b4359e6690b (patch)
tree974c875391900c377f868db01134d292b6a70ee5
parent05d749a2a081295fce3fe5a497baab0e61e9af6f (diff)
downloadaur-55399a68960cf8f0e801363c6ae47b4359e6690b.tar.gz
bump version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5036b27b50cd..f580f7ca5578 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-crt-git
- pkgdesc = MinGW-w64 CRT for Windows(git version)
- pkgver = 5.0.3.20180212
+ pkgdesc = MinGW-w64 CRT for Windows (git version)
+ pkgver = 5.0.3.20180524
pkgrel = 1
url = https://mingw-w64.org/doku.php
arch = any
@@ -10,14 +10,12 @@ pkgbase = mingw-w64-crt-git
makedepends = git
makedepends = mingw-w64-gcc-base
makedepends = mingw-w64-binutils
- makedepends = mingw-w64-headers-git>=5.0.3.20180212
- provides = mingw-w64-crt=5.0.3.20180212
+ makedepends = mingw-w64-headers-git>=5.0.3.20180524
+ provides = mingw-w64-crt=5.0.3.20180524
conflicts = mingw-w64-crt
- replaces = mingw-w64-crt
options = !strip
- options = !buildflags
options = staticlibs
- options = !emptydirs
+ options = !buildflags
source = git+https://git.code.sf.net/p/mingw-w64/mingw-w64
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ebc2c8e568f3..280fa9fc767e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,25 @@
# Contributor: rubenvb vanboxem <dottie> ruben <attie> gmail <dottie> com
# Contributor: rkitover <rkitover@gmail.com>
+_pkgver=5.0.3
_targets="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-crt-git
-pkgver=5.0.3.20180212
-_pkgver=5.0.3
+pkgver=5.0.3.20180524
pkgrel=1
-pkgdesc='MinGW-w64 CRT for Windows(git version)'
+pkgdesc="MinGW-w64 CRT for Windows (git version)"
arch=('any')
-url='https://mingw-w64.org/doku.php'
+url="https://mingw-w64.org/doku.php"
license=('custom')
groups=('mingw-w64-toolchain' 'mingw-w64')
-makedepends=('git' 'mingw-w64-gcc-base' 'mingw-w64-binutils' "mingw-w64-headers-git>=$pkgver")
-provides=("mingw-w64-crt=$pkgver")
+makedepends=('git'
+ 'mingw-w64-gcc-base'
+ 'mingw-w64-binutils'
+ "mingw-w64-headers-git>=${pkgver}")
+provides=("mingw-w64-crt=${pkgver}")
conflicts=('mingw-w64-crt')
-replaces=('mingw-w64-crt')
-options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
-source=('git+https://git.code.sf.net/p/mingw-w64/mingw-w64')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("git+https://git.code.sf.net/p/mingw-w64/mingw-w64")
sha256sums=('SKIP')
pkgver() {
@@ -39,16 +41,16 @@ build() {
for _target in ${_targets}; do
msg "Building ${_target} CRT"
if [ ${_target} == "i686-w64-mingw32" ]; then
- _crt_configure_args="--disable-lib64 --enable-lib32"
+ _crt_configure_args="--disable-lib64 --enable-lib32"
elif [ ${_target} == "x86_64-w64-mingw32" ]; then
- _crt_configure_args="--disable-lib32 --enable-lib64"
+ _crt_configure_args="--disable-lib32 --enable-lib64"
fi
mkdir -p "crt-${_target}" && pushd "crt-${_target}"
../mingw-w64/mingw-w64-crt/configure \
- --prefix=/usr/${_target} \
- --host=${_target} \
- --enable-wildcard \
- ${_crt_configure_args}
+ --prefix=/usr/${_target} \
+ --host=${_target} \
+ --enable-wildcard \
+ ${_crt_configure_args}
make
popd
done
@@ -63,3 +65,5 @@ package() {
popd
done
}
+
+# vim:set ts=2 sw=2 et: