summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-04-25 17:49:11 -0400
committerAndrew Sun2019-04-25 17:49:11 -0400
commit5d5319a4dd4d593c0db1d7b1b31375eaa00e80af (patch)
tree2039c3208df47190e4232b3ee1e3811a016afe6f
parent370f05125d1c425d749520e57bb7950ed054e640 (diff)
downloadaur-5d5319a4dd4d593c0db1d7b1b31375eaa00e80af.tar.gz
mingw-w64-crypto++: update to 8.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--cryptopp-5.6.5-cmake.patch13
-rw-r--r--fix-test-linking.patch18
-rw-r--r--libcrypto++.pc6
5 files changed, 29 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af538fa74f6..96999ecd8249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-crypto++
pkgdesc = A free C++ class library of cryptographic schemes (mingw-w64)
- pkgver = 7.0.0
+ pkgver = 8.1.0
pkgrel = 1
url = https://www.cryptopp.com/
arch = any
@@ -9,18 +9,16 @@ pkgbase = mingw-w64-crypto++
makedepends = unzip
makedepends = dos2unix
depends = mingw-w64-crt
- noextract = cryptopp700.zip
+ noextract = cryptopp810.zip
options = !strip
options = !buildflags
options = staticlibs
- source = https://www.cryptopp.com/cryptopp700.zip
+ source = https://www.cryptopp.com/cryptopp810.zip
source = libcrypto++.pc
source = cryptopp-5.6.5-cmake.patch
- source = fix-test-linking.patch
- sha256sums = a4bc939910edd3d29fb819a6fc0dfdc293f686fa62326f61c56d72d0a366ceb0
- sha256sums = baea2372d9f490fa79d0431cd4f8eea515501b5553c6b4ed4a1cbbf3879ca5f3
- sha256sums = 0486178005a7fe8a0659f59d3c4fafafa39d870f6e9f812bcf9131ce4758c914
- sha256sums = 99e5bb3ba211c6155a19a170b7e498b904bf821f7d2aa46be06d08a87846fa17
+ sha256sums = f609b453e42abbab7163191dfe060964121f04da212e2e4f2f0ebe94b7e806ae
+ sha256sums = 5d1ad79b050553cc1b2d5e2a9a4946e24afa4f4ced8d57aed74eadfdfb97d671
+ sha256sums = 2c588cb085749b76adc28be5075b4978c8822f1e0327ccc06d823a1d436f56e9
pkgname = mingw-w64-crypto++
diff --git a/PKGBUILD b/PKGBUILD
index 247cd009a6f4..03ac0d80d5d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-crypto++
_pkgname=crypto++
-pkgver=7.0.0
+pkgver=8.1.0
_srcver=${pkgver//./}
pkgrel=1
pkgdesc="A free C++ class library of cryptographic schemes (mingw-w64)"
@@ -14,34 +14,32 @@ makedepends=('mingw-w64-cmake' 'unzip' 'dos2unix')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://www.cryptopp.com/cryptopp${pkgver//./}.zip"
libcrypto++.pc
- cryptopp-5.6.5-cmake.patch
- fix-test-linking.patch)
-sha256sums=('a4bc939910edd3d29fb819a6fc0dfdc293f686fa62326f61c56d72d0a366ceb0'
- 'baea2372d9f490fa79d0431cd4f8eea515501b5553c6b4ed4a1cbbf3879ca5f3'
- '0486178005a7fe8a0659f59d3c4fafafa39d870f6e9f812bcf9131ce4758c914'
- '99e5bb3ba211c6155a19a170b7e498b904bf821f7d2aa46be06d08a87846fa17')
+ cryptopp-5.6.5-cmake.patch)
+sha256sums=('f609b453e42abbab7163191dfe060964121f04da212e2e4f2f0ebe94b7e806ae'
+ '5d1ad79b050553cc1b2d5e2a9a4946e24afa4f4ced8d57aed74eadfdfb97d671'
+ '2c588cb085749b76adc28be5075b4978c8822f1e0327ccc06d823a1d436f56e9')
noextract=(cryptopp${pkgver//./}.zip)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd ${srcdir}
- unzip cryptopp${pkgver//./}.zip -d ${_pkgname}
+ [[ -d ${srcdir}/cryptopp ]] && rm -rf ${srcdir}/cryptopp
+ unzip ${srcdir}/cryptopp${pkgver//./}.zip -d ${srcdir}/cryptopp
- cd ${_pkgname}
+ cd ${srcdir}/cryptopp
find . -type f -exec dos2unix {} \;
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
patch -p1 -i ${srcdir}/cryptopp-5.6.5-cmake.patch
- patch -p1 -i ${srcdir}/fix-test-linking.patch
}
build() {
- cd "${srcdir}/${_pkgname}/"
+ cd "${srcdir}/cryptopp"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
-DDISABLE_SSSE3=ON \
+ -DDISABLE_ASM=ON \
..
make
popd
@@ -50,14 +48,15 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/${_pkgname}/build-${_arch}"
+ cd "${srcdir}/cryptopp/build-${_arch}"
make DESTDIR="${pkgdir}" install
# pkgconfig file
mkdir -p "${pkgdir}/usr/${_arch}/lib/pkgconfig"
install -m644 "${srcdir}/libcrypto++.pc" "${pkgdir}/usr/${_arch}/lib/pkgconfig/libcrypto++.pc"
- sed -s "s|/usr|/usr/${_arch}|g" -i "${pkgdir}/usr/${_arch}/lib/pkgconfig/libcrypto++.pc"
-
+ sed -s "s|@PREFIX@|/usr/${_arch}|g" -i "${pkgdir}/usr/${_arch}/lib/pkgconfig/libcrypto++.pc"
+ sed -s "s|@VERSION@|${pkgver}|g" -i "${pkgdir}/usr/${_arch}/lib/pkgconfig/libcrypto++.pc"
+
# Remove cryptest.exe and test files, only needed for check() and bloats the package
# because cryptest.exe is linked statically.
rm "${pkgdir}/usr/${_arch}/bin/cryptest.exe"
diff --git a/cryptopp-5.6.5-cmake.patch b/cryptopp-5.6.5-cmake.patch
index 178499d18b6f..d6d7d4493a30 100644
--- a/cryptopp-5.6.5-cmake.patch
+++ b/cryptopp-5.6.5-cmake.patch
@@ -1,6 +1,6 @@
--- /dev/null 2017-01-31 14:21:37.000000000 +0300
+++ b/CMakeLists.txt 2017-01-31 14:20:54.392223500 +0300
-@@ -0,0 +1,438 @@
+@@ -0,0 +1,437 @@
+# Please ensure your changes or patch meets minimum requirements.
+# The minimum requirements are 2.8.5. They roughly equate to Ubuntu 12.04 LTS
+# Please do not check in something for 2.8.12 or 3.5.0. To test your changes,
@@ -47,6 +47,7 @@
+
+option(DISABLE_ASM "Disable ASM" OFF)
+option(DISABLE_SSSE3 "Disable SSSE3" OFF)
++option(DISABLE_SSSE4 "Disable SSSE4" OFF)
+option(DISABLE_AESNI "Disable AES-NI" OFF)
+option(DISABLE_CXXFLAGS_OPTIMIZATIONS "Disable CXXFLAGS optimizations" OFF)
+set(CRYPTOPP_DATA_DIR "" CACHE PATH "Crypto++ test data directory")
@@ -89,6 +90,9 @@
+if(DISABLE_SSSE3)
+ add_definitions(-DCRYPTOPP_DISABLE_SSSE3)
+endif()
++if(DISABLE_SSSE4)
++ add_definitions(-DCRYPTOPP_DISABLE_SSSE4)
++endif()
+if(DISABLE_AESNI)
+ add_definitions(-DCRYPTOPP_DISABLE_AESNI)
+endif()
@@ -192,7 +196,7 @@
+file(GLOB cryptopp_HEADERS *.h)
+
+# Test sources. You can use the GNUmakefile to generate the list: `make sources`.
-+file(GLOB cryptopp_SOURCES_TEST test.cpp bench1.cpp bench2.cpp validat0.cpp validat1.cpp validat2.cpp validat3.cpp validat4.cpp adhoc.cpp datatest.cpp regtest.cpp fipsalgt.cpp dlltest.cpp fipstest.cpp)
++file(GLOB cryptopp_SOURCES_TEST test.cpp bench1.cpp bench2.cpp bench3.cpp validat0.cpp validat1.cpp validat2.cpp validat3.cpp validat4.cpp validat5.cpp validat6.cpp validat7.cpp validat8.cpp validat9.cpp validat10.cpp adhoc.cpp datatest.cpp regtest.cpp fipsalgt.cpp dlltest.cpp fipstest.cpp)
+
+# Library sources. You can use the GNUmakefile to generate the list: `make sources`.
+file(GLOB cryptopp_SOURCES *.cpp)
@@ -202,7 +206,6 @@
+ ${CMAKE_CURRENT_SOURCE_DIR}/integer.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/pch.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/simple.cpp
-+ ${CMAKE_CURRENT_SOURCE_DIR}/winpipes.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/cryptlib_bds.cpp
+ ${cryptopp_SOURCES_TEST}
+ )
@@ -213,10 +216,6 @@
+ ${cryptopp_SOURCES}
+ )
+
-+if(MINGW OR WIN32)
-+ list(APPEND cryptopp_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/winpipes.cpp)
-+endif()
-+
+if(MSVC AND NOT DISABLE_ASM)
+ if(${CMAKE_GENERATOR} MATCHES ".*ARM")
+ message(STATUS "Disabling ASM because ARM is specified as target platform.")
diff --git a/fix-test-linking.patch b/fix-test-linking.patch
deleted file mode 100644
index d854978efceb..000000000000
--- a/fix-test-linking.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/winpipes.h 2015-07-24 12:17:47.681944900 +0300
-+++ b/winpipes.h 2015-07-24 12:17:58.280460900 +0300
-@@ -116,7 +116,6 @@
- NetworkSource::GetWaitObjects;
-
- private:
-- HANDLE GetHandle() const {return WindowsHandle::GetHandle();}
- NetworkReceiver & AccessReceiver() {return *this;}
- };
-
-@@ -131,7 +130,6 @@
- NetworkSink::GetWaitObjects;
-
- private:
-- HANDLE GetHandle() const {return WindowsHandle::GetHandle();}
- NetworkSender & AccessSender() {return *this;}
- };
-
diff --git a/libcrypto++.pc b/libcrypto++.pc
index de20f88115e7..a7d7fd1719aa 100644
--- a/libcrypto++.pc
+++ b/libcrypto++.pc
@@ -1,12 +1,12 @@
# Written by Alexander Rødseth <rodseth@gmail.com>
-prefix=/usr
+prefix=@PREFIX@
libdir=${prefix}/lib
includedir=${prefix}/include
Name: libcrypto++
Description: Description: Crypto++ cryptographic library
URL: https://cryptopp.com/
-Version: 7.0.0
+Version: @VERSION@
Libs: -L${libdir} -lcryptopp
-Cflags: -I${includedir} \ No newline at end of file
+Cflags: -I${includedir}