summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaks Verver2025-01-07 00:12:44 +0100
committerMaks Verver2025-01-07 00:12:44 +0100
commit43048d50b8f87b69298ba0ea10b4c7d089fa1d10 (patch)
tree0bfd0d832341d8a2545f917946fc9f8ba5cd1e2e
parentf3ebbce6a267b27b17df65c62f754d2c4f988a75 (diff)
downloadaur-43048d50b8f87b69298ba0ea10b4c7d089fa1d10.tar.gz
Update to version 8.11.1.
-rw-r--r--.SRCINFO10
-rw-r--r--0002-nghttp2-static.patch13
-rw-r--r--0004-more-static-fixes.patch7
-rw-r--r--PKGBUILD11
4 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b83791f44d4d..5f4bf1589a50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-curl
pkgdesc = An URL retrival utility and library (mingw-w64)
- pkgver = 8.9.1
+ pkgver = 8.11.1
pkgrel = 1
url = https://curl.haxx.se
arch = any
@@ -18,11 +18,9 @@ pkgbase = mingw-w64-curl
options = staticlibs
options = !strip
options = !buildflags
- source = https://curl.haxx.se/download/curl-8.9.1.tar.xz
+ source = https://curl.haxx.se/download/curl-8.11.1.tar.xz
source = 0002-nghttp2-static.patch
- source = 0004-more-static-fixes.patch
- sha256sums = f292f6cc051d5bbabf725ef85d432dfeacc8711dd717ea97612ae590643801e5
- sha256sums = 9da305e320ea306d0ca634edd73092b404b96d91f5cac681304bb6a9ae49e5ef
- sha256sums = 22dcdfd89a1d847ab6bbe1078c6a8ac198cc6c11eb86b00580583492848fd1b1
+ sha256sums = c7ca7db48b0909743eaef34250da02c19bc61d4f1dcedd6603f109409536ab56
+ sha256sums = 5be61f52e5d225d000bd9bd6899013240755afde96826b7857166c86ce1f0648
pkgname = mingw-w64-curl
diff --git a/0002-nghttp2-static.patch b/0002-nghttp2-static.patch
index fe5ba5bc507e..696092d1a91d 100644
--- a/0002-nghttp2-static.patch
+++ b/0002-nghttp2-static.patch
@@ -1,6 +1,7 @@
---- curl-8.9.1/lib/Makefile.am.orig 2024-07-31 08:51:53.000000000 +0200
-+++ curl-8.9.1/lib/Makefile.am 2024-09-03 02:10:49.995635263 +0200
-@@ -95,7 +95,8 @@
+--- curl-8.11.1/lib/Makefile.am.orig 2024-12-11 07:08:12.000000000 +0000
++++ curl-8.11.1/lib/Makefile.am 2025-01-06 21:35:08.151176417 +0000
+
+@@ -118,7 +118,8 @@
endif
if USE_CPPFLAG_CURL_STATICLIB
@@ -10,13 +11,13 @@
else
if HAVE_WINDRES
libcurl_la_SOURCES += $(LIB_RCFILES)
-@@ -112,9 +113,9 @@
- libcurl_la_LDFLAGS = $(AM_LDFLAGS) $(libcurl_la_LDFLAGS_EXTRA) $(CURL_LDFLAGS_LIB) $(LIBCURL_LIBS)
+@@ -135,9 +136,9 @@
+ libcurl_la_LDFLAGS = $(AM_LDFLAGS) $(libcurl_la_LDFLAGS_EXTRA) $(CURL_LDFLAGS_LIB) $(LIBCURL_PC_LIBS_PRIVATE)
libcurl_la_CFLAGS = $(AM_CFLAGS) $(libcurl_la_CFLAGS_EXTRA)
-libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DUNITTESTS
+libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DNGHTTP2_STATICLIB -DUNITTESTS
- libcurlu_la_LDFLAGS = $(AM_LDFLAGS) -static $(LIBCURL_LIBS)
+ libcurlu_la_LDFLAGS = $(AM_LDFLAGS) -static $(LIBCURL_PC_LIBS_PRIVATE)
-libcurlu_la_CFLAGS = $(AM_CFLAGS)
+libcurlu_la_CFLAGS = $(AM_CFLAGS) -DNGHTTP2_STATICLIB
diff --git a/0004-more-static-fixes.patch b/0004-more-static-fixes.patch
deleted file mode 100644
index 34519e3a4d49..000000000000
--- a/0004-more-static-fixes.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- curl-8.9.1/libcurl.pc.in.orig 2024-09-03 02:03:54.401140994 +0200
-+++ curl-8.9.1/libcurl.pc.in 2024-09-03 02:06:17.099363534 +0200
-@@ -38,3 +38,4 @@
- Libs: -L${libdir} -lcurl @LIBCURL_NO_SHARED@
- Libs.private: @LIBCURL_LIBS@
- Cflags: -I${includedir} @CPPFLAG_CURL_STATICLIB@
-+Cflags.private: -DCURL_STATICLIB
diff --git a/PKGBUILD b/PKGBUILD
index 098bc9523b2f..d1d4e5c66328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: ant32 <antreimer at gmail dot com>
pkgname=mingw-w64-curl
-pkgver=8.9.1
+pkgver=8.11.1
pkgrel=1
pkgdesc="An URL retrival utility and library (mingw-w64)"
arch=('any')
@@ -22,18 +22,15 @@ depends=('mingw-w64-crt'
makedepends=('mingw-w64-configure')
options=('staticlibs' '!strip' '!buildflags')
source=("${url}/download/curl-${pkgver}.tar.xz"
- "0002-nghttp2-static.patch"
- "0004-more-static-fixes.patch")
-sha256sums=('f292f6cc051d5bbabf725ef85d432dfeacc8711dd717ea97612ae590643801e5'
- '9da305e320ea306d0ca634edd73092b404b96d91f5cac681304bb6a9ae49e5ef'
- '22dcdfd89a1d847ab6bbe1078c6a8ac198cc6c11eb86b00580583492848fd1b1')
+ "0002-nghttp2-static.patch")
+sha256sums=('c7ca7db48b0909743eaef34250da02c19bc61d4f1dcedd6603f109409536ab56'
+ '5be61f52e5d225d000bd9bd6899013240755afde96826b7857166c86ce1f0648')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}
patch -Np1 -i "${srcdir}/0002-nghttp2-static.patch"
- patch -Np1 -i "${srcdir}/0004-more-static-fixes.patch"
autoreconf -vfi
}