summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr. Edscott Wilson Garcia2016-05-20 14:53:42 -0500
committerDr. Edscott Wilson Garcia2016-05-20 14:53:42 -0500
commit39837d9405c873e1468ad003525dcd00da65c8c9 (patch)
tree2d95406a06b10aef9ebb6aa0bee00f2381465dbe
downloadaur-39837d9405c873e1468ad003525dcd00da65c8c9.tar.gz
Initial commit of release 5.0.20
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd4ff1dca8aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-dbh
+ pkgdesc = GNU DBH database library (mingw-w64)
+ pkgver = 5.0.20
+ pkgrel = 2
+ url = http://www.gnu.org/software/libdbh/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-gettext
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = https://sourceforge.net/projects/dbh/files/dbh/5.0.20/libdbh2-5.0.20.tar.gz/download
+ md5sums = b06b504b694e5182f855d642e7dd31af
+
+pkgname = mingw-w64-dbh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b232886faa0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer:
+# Contributor:
+
+pkgname=mingw-w64-dbh
+pkgver=5.0.20
+pkgrel=2
+pkgdesc="GNU DBH database library (mingw-w64)"
+url="http://www.gnu.org/software/libdbh/"
+license=('GPL')
+arch=('any')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'mingw-w64-gettext')
+source=("https://sourceforge.net/projects/dbh/files/dbh/${pkgver}/libdbh2-${pkgver}.tar.gz/download")
+options=('staticlibs' '!buildflags' '!strip')
+md5sums=('b06b504b694e5182f855d642e7dd31af')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/libdbh2-${pkgver}"
+
+ autoreconf -vfi
+}
+
+build() {
+ cd "${srcdir}/libdbh2-${pkgver}"
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p "build-${_arch}" && pushd "build-${_arch}"
+
+ ../configure \
+ --prefix=/usr/${_arch} \
+ --host=${_arch}
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libdbh2-${pkgver}/build-$_arch"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+
+ done
+}