summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr. Edscott Wilson Garcia2017-02-10 14:29:30 -0600
committerDr. Edscott Wilson Garcia2017-02-10 14:29:30 -0600
commit3b9b0f2ca4c4930fc947dd9b87d8fc702f4d24a0 (patch)
treea526c7127bfc90ec40ed9f4a53e4f12ff5e8c21f
parent39837d9405c873e1468ad003525dcd00da65c8c9 (diff)
downloadaur-3b9b0f2ca4c4930fc947dd9b87d8fc702f4d24a0.tar.gz
added patch to remove -lrt in pc file
-rw-r--r--0001-remove-lrt.patch9
-rw-r--r--PKGBUILD9
2 files changed, 15 insertions, 3 deletions
diff --git a/0001-remove-lrt.patch b/0001-remove-lrt.patch
new file mode 100644
index 000000000000..3b6212ed40f6
--- /dev/null
+++ b/0001-remove-lrt.patch
@@ -0,0 +1,9 @@
+--- dbh2.pc.in 2014-08-06 12:31:27.000000000 -0500
++++ dbh2.pc.in.new 2017-02-10 13:49:58.000000000 -0600
+@@ -7,5 +7,5 @@
+ Description: Diskbased Hashtables
+ Requires: @GLIB_DEPENDS@
+ Version: @VERSION@
+-Libs: -ldbh -lm @PTHREAD_LIBS@ -lrt
++Libs: -ldbh -lm @PTHREAD_LIBS@
+ Cflags: -I${includedir} @PTHREAD_CFLAGS@
diff --git a/PKGBUILD b/PKGBUILD
index b232886faa0e..320aeba71d2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: edscott@imp.mx
# Contributor:
pkgname=mingw-w64-dbh
@@ -10,14 +10,17 @@ license=('GPL')
arch=('any')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-gettext')
-source=("https://sourceforge.net/projects/dbh/files/dbh/${pkgver}/libdbh2-${pkgver}.tar.gz/download")
+source=("https://sourceforge.net/projects/dbh/files/dbh/${pkgver}/libdbh2-${pkgver}.tar.gz/download"
+ 0001-remove-lrt.patch)
options=('staticlibs' '!buildflags' '!strip')
-md5sums=('b06b504b694e5182f855d642e7dd31af')
+md5sums=('b06b504b694e5182f855d642e7dd31af'
+ '71f85b3c840b9714366283dd6a87be64')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/libdbh2-${pkgver}"
+ patch -N -i ../0001-remove-lrt.patch
autoreconf -vfi
}