summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2017-08-31 22:27:47 +0800
committerpingplug2017-08-31 22:27:47 +0800
commit0446d20352ac3da81a42ee96aa56303995e83752 (patch)
treebfb6ce91aa8d35925da202a2d46c9b459bfa02e6
parent421228329f5ca2643b4e558464c8444ae422b453 (diff)
downloadaur-0446d20352ac3da81a42ee96aa56303995e83752.tar.gz
Updated to 19.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--dlib.patch14
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37463c94ed4c..41d7aace0a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 15 08:48:18 UTC 2017
+# Thu Aug 31 14:27:13 UTC 2017
pkgbase = mingw-w64-dlib
pkgdesc = Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)
- pkgver = 19.4
+ pkgver = 19.6
pkgrel = 1
url = http://www.dlib.net/
arch = any
@@ -16,10 +16,10 @@ pkgbase = mingw-w64-dlib
options = !buildflags
options = !strip
options = staticlibs
- source = https://downloads.sourceforge.net/project/dclib/dlib/v19.4/dlib-19.4.tar.bz2
+ source = https://downloads.sourceforge.net/project/dclib/dlib/v19.6/dlib-19.6.tar.bz2
source = dlib.patch
- sha256sums = 003f0508fe605cf397ad678c6976e5ec7db8472faabf06508d16ead205571372
- sha256sums = 23b06cdcdec7907d063925f461ec7f5034deba3a7989cc5381df67194838b621
+ sha256sums = 40292a4343499b18b881f69b26a56c1ecfe95cb9b9f964f37c1064c6fc415e2c
+ sha256sums = eb57f93c738efe96488204ed093c46e73fb8788a9e50519a9aca93eec1b6f280
pkgname = mingw-w64-dlib
diff --git a/PKGBUILD b/PKGBUILD
index fc553376baca..f4daa9100ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-dlib
_pkgname=dlib
-pkgver=19.4
+pkgver=19.6
pkgrel=1
pkgdesc="Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)"
arch=('any')
@@ -17,8 +17,8 @@ optdepends=('mingw-w64-lapack: for BLAS and LAPACK support'
options=('!buildflags' '!strip' 'staticlibs')
source=(https://downloads.sourceforge.net/project/dclib/${_pkgname}/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2
dlib.patch)
-sha256sums=('003f0508fe605cf397ad678c6976e5ec7db8472faabf06508d16ead205571372'
- '23b06cdcdec7907d063925f461ec7f5034deba3a7989cc5381df67194838b621')
+sha256sums=('40292a4343499b18b881f69b26a56c1ecfe95cb9b9f964f37c1064c6fc415e2c'
+ 'eb57f93c738efe96488204ed093c46e73fb8788a9e50519a9aca93eec1b6f280')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/dlib.patch b/dlib.patch
index be5e2ea5f7cc..b8ca82af25e0 100644
--- a/dlib.patch
+++ b/dlib.patch
@@ -1,7 +1,7 @@
-diff -ruN dlib-19.4/dlib/CMakeLists.txt dlib-19.4-patched/dlib/CMakeLists.txt
---- dlib-19.4/dlib/CMakeLists.txt 2017-03-08 06:19:46.000000000 +0800
-+++ dlib-19.4-patched/dlib/CMakeLists.txt 2017-03-15 16:44:32.883719060 +0800
-@@ -138,7 +138,7 @@
+diff -ruN dlib-19.6/dlib/CMakeLists.txt dlib-19.6-patched/dlib/CMakeLists.txt
+--- dlib-19.6/dlib/CMakeLists.txt 2017-08-29 06:18:45.000000000 +0800
++++ dlib-19.6-patched/dlib/CMakeLists.txt 2017-08-31 22:17:53.862233903 +0800
+@@ -146,7 +146,7 @@
option(DLIB_LINK_WITH_SQLITE3 ${DLIB_LINK_WITH_SQLITE3_STR} ON)
option(DLIB_USE_BLAS ${DLIB_USE_BLAS_STR} ON)
option(DLIB_USE_LAPACK ${DLIB_USE_LAPACK_STR} ON)
@@ -10,11 +10,11 @@ diff -ruN dlib-19.4/dlib/CMakeLists.txt dlib-19.4-patched/dlib/CMakeLists.txt
option(DLIB_PNG_SUPPORT ${DLIB_PNG_SUPPORT_STR} ON)
option(DLIB_GIF_SUPPORT ${DLIB_GIF_SUPPORT_STR} ON)
#option(DLIB_USE_FFTW ${DLIB_USE_FFTW_STR} ON)
-@@ -340,6 +340,7 @@
+@@ -349,6 +349,7 @@
if (PNG_FOUND AND LIBPNG_IS_GOOD)
include_directories(${PNG_INCLUDE_DIR})
- set (dlib_needed_libraries ${dlib_needed_libraries} ${PNG_LIBRARY})
-+ set (dlib_needed_libraries ${dlib_needed_libraries} ${ZLIB_LIBRARY})
+ set (dlib_needed_libraries ${dlib_needed_libraries} ${PNG_LIBRARIES})
++ set (dlib_needed_libraries ${dlib_needed_libraries} ${ZLIB_LIBRARIES})
set(REQUIRES_LIBS " libpng")
else()
# If we can't find libpng then statically compile it in.