summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2016-06-27 12:44:28 +0800
committerpingplug2016-06-27 12:44:28 +0800
commit0982e4a0bbf67d47b6d02c959c264e646590be7a (patch)
tree98b9f43b9521a6bf3fd82874d637b1f0a5a24975
parentb349cceffba3367ee4b952b08d77e565ff2beef6 (diff)
downloadaur-0982e4a0bbf67d47b6d02c959c264e646590be7a.tar.gz
Updated to 19.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--dlib-19.0.patch (renamed from dlib-18.18.patch)57
3 files changed, 52 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c427c5dc3757..f4a54c8af112 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Jun 27 04:41:40 UTC 2016
pkgbase = mingw-w64-dlib
pkgdesc = Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)
- pkgver = 18.18
+ pkgver = 19.0
pkgrel = 2
url = http://www.dlib.net/
arch = any
@@ -13,10 +15,10 @@ pkgbase = mingw-w64-dlib
options = !buildflags
options = !strip
options = staticlibs
- source = http://downloads.sourceforge.net/project/dclib/dlib/v18.18/dlib-18.18.tar.bz2
- source = dlib-18.18.patch
- md5sums = 288d609c13b1c3c1957c6a12d0052e98
- md5sums = 566e1a79a6336c764253a95bce2a3775
+ source = http://downloads.sourceforge.net/project/dclib/dlib/v19.0/dlib-19.0.tar.bz2
+ source = dlib-19.0.patch
+ md5sums = da930a35c2aa88612dd2ebf893f48f60
+ md5sums = 787c62b9c4b9f0b4e2060f2df605501a
pkgname = mingw-w64-dlib
diff --git a/PKGBUILD b/PKGBUILD
index 7e94cabcde73..3d2e23dfe06e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-dlib
_pkgname=dlib
-pkgver=18.18
+pkgver=19.0
pkgrel=2
pkgdesc="Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)"
arch=('any')
@@ -16,8 +16,8 @@ optdepends=('mingw-w64-lapack: for BLAS and LAPACK support'
options=('!buildflags' '!strip' 'staticlibs')
source=(http://downloads.sourceforge.net/project/dclib/${_pkgname}/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2
dlib-${pkgver}.patch)
-md5sums=('288d609c13b1c3c1957c6a12d0052e98'
- '566e1a79a6336c764253a95bce2a3775')
+md5sums=('da930a35c2aa88612dd2ebf893f48f60'
+ '787c62b9c4b9f0b4e2060f2df605501a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/dlib-18.18.patch b/dlib-19.0.patch
index 2ab48388b68c..a3148d441e34 100644
--- a/dlib-18.18.patch
+++ b/dlib-19.0.patch
@@ -1,7 +1,7 @@
-diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find_blas.txt
---- dlib-18.18/dlib/cmake_find_blas.txt 2015-10-29 08:27:41.000000000 +0800
-+++ dlib-18.18-patched/dlib/cmake_find_blas.txt 2015-10-29 13:03:20.968515000 +0800
-@@ -273,6 +273,89 @@
+diff -ruN dlib-19.0/dlib/cmake_find_blas.txt dlib-19.0-patched/dlib/cmake_find_blas.txt
+--- dlib-19.0/dlib/cmake_find_blas.txt 2016-06-26 03:05:41.000000000 +0800
++++ dlib-19.0-patched/dlib/cmake_find_blas.txt 2016-06-27 13:03:20.968515000 +0800
+@@ -310,6 +310,116 @@
endif()
@@ -15,10 +15,35 @@ diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find
+ /usr/i686-w64-mingw32/lib/atlas-sse3
+ /usr/i686-w64-mingw32/lib/atlas-sse2
+ /usr/i686-w64-mingw32/lib/atlas
++ /usr/i686-w64-mingw32/lib/openblas-base
+ /usr/x86_64-w64-mingw32/lib
+ /usr/x86_64-w64-mingw32/lib/atlas-sse3
+ /usr/x86_64-w64-mingw32/lib/atlas-sse2
++ /usr/x86_64-w64-mingw32/lib/openblas-base
+ /usr/x86_64-w64-mingw32/lib/atlas)
++ )
++
++ INCLUDE (CheckFunctionExists)
++
++ if (NOT blas_found)
++ find_library(cblas_lib openblas PATHS ${extra_paths})
++ if (cblas_lib)
++ set(blas_libraries ${cblas_lib})
++ set(blas_found 1)
++ message(STATUS "Found OpenBLAS library")
++ set(CMAKE_REQUIRED_LIBRARIES ${blas_libraries})
++ # If you compiled OpenBLAS with LAPACK in it then it should have the
++ # sgetrf_single function in it. So if we find that function in
++ # OpenBLAS then just use OpenBLAS's LAPACK.
++ CHECK_FUNCTION_EXISTS(sgetrf_single OPENBLAS_HAS_LAPACK)
++ if (OPENBLAS_HAS_LAPACK)
++ message(STATUS "Using OpenBLAS's built in LAPACK")
++ # set(lapack_libraries gfortran)
++ set(lapack_found 1)
++ endif()
++ endif()
++ mark_as_advanced( cblas_lib)
++ endif()
+
+ if (NOT lapack_found)
+ find_library(lapack_lib NAMES lapack lapack-3 PATHS ${extra_paths})
@@ -30,8 +55,7 @@ diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find
+ mark_as_advanced( lapack_lib)
+ endif()
+
-+ # try to find some other BLAS libraries if we didn't find the MKL
-+
++ # try to find BLAS libraries while cross compiling
+ if (NOT blas_found)
+ find_library(atlas_lib atlas PATHS ${extra_paths})
+ find_library(cblas_lib cblas PATHS ${extra_paths})
@@ -52,7 +76,7 @@ diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find
+ endif()
+ mark_as_advanced( cblas_lib)
+ endif()
-+
++
+ if (NOT blas_found)
+ find_library(generic_blas blas PATHS ${extra_paths})
+ if (generic_blas)
@@ -69,7 +93,6 @@ diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find
+ # we found the Intel MKL since for some reason CHECK_FUNCTION_EXISTS doesn't work
+ # with it. But it's fine since the MKL should always have cblas.
+ if (blas_found AND NOT found_intel_mkl)
-+ INCLUDE (CheckFunctionExists)
+ set(CMAKE_REQUIRED_LIBRARIES ${blas_libraries})
+ CHECK_FUNCTION_EXISTS(cblas_ddot HAVE_CBLAS)
+ if (NOT HAVE_CBLAS)
@@ -82,23 +105,27 @@ diff -ruN dlib-18.18/dlib/cmake_find_blas.txt dlib-18.18-patched/dlib/cmake_find
+ if (NOT blas_found)
+ message(" *****************************************************************************")
+ message(" *** No BLAS library found so using dlib's built in BLAS. However, if you ***")
-+ message(" *** install an optimized BLAS such as openblas or the Intel MKL your code ***")
-+ message(" *** will run faster. On Ubuntu you can install openblas by executing: ***")
++ message(" *** install an optimized BLAS such as OpenBLAS or the Intel MKL your code ***")
++ message(" *** will run faster. On Ubuntu you can install OpenBLAS by executing: ***")
+ message(" *** sudo apt-get install libopenblas-dev liblapack-dev ***")
++ message(" *** Or you can easily install OpenBLAS from source by downloading the ***")
++ message(" *** source tar file from http://www.openblas.net, extracting it, and ***")
++ message(" *** running: ***")
++ message(" *** make; sudo make install ***")
+ message(" *****************************************************************************")
+ endif()
+
endif()
-diff -ruN dlib-18.18/dlib/CMakeLists.txt dlib-18.18-patched/dlib/CMakeLists.txt
---- dlib-18.18/dlib/CMakeLists.txt 2015-10-29 08:27:41.000000000 +0800
-+++ dlib-18.18-patched/dlib/CMakeLists.txt 2015-10-29 13:03:20.968515000 +0800
-@@ -234,6 +234,7 @@
+diff -ruN dlib-19.0/dlib/CMakeLists.txt dlib-19.0-patched/dlib/CMakeLists.txt
+--- dlib-19.0/dlib/CMakeLists.txt 2016-06-26 03:05:41.000000000 +0800
++++ dlib-19.0-patched/dlib/CMakeLists.txt 2016-06-27 13:03:20.968515000 +0800
+@@ -308,6 +308,7 @@
if (PNG_FOUND AND LIBPNG_IS_GOOD)
include_directories(${PNG_INCLUDE_DIR})
set (dlib_needed_libraries ${dlib_needed_libraries} ${PNG_LIBRARY})
+ set (dlib_needed_libraries ${dlib_needed_libraries} ${ZLIB_LIBRARY})
+ set(REQUIRES_LIBS " libpng")
else()
# If we can't find libpng then statically compile it in.
- include_directories(external/libpng external/zlib)