summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2016-10-30 10:42:26 +0800
committerpingplug2016-10-30 10:42:26 +0800
commit45bd7f03007a1f135d1e0434d700518de1560acb (patch)
treee522adaae33d014e06c9f8975744c3f6c734584e
parentfd53396392fe5da60b2fcc65cf387b683aad4afb (diff)
downloadaur-45bd7f03007a1f135d1e0434d700518de1560acb.tar.gz
Updated to 19.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--dlib-19.2.patch (renamed from dlib-19.1.patch)28
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62afb72cd191..bc1d26be1c9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 28 02:07:00 UTC 2016
+# Sun Oct 30 02:41:18 UTC 2016
pkgbase = mingw-w64-dlib
pkgdesc = Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)
- pkgver = 19.1
+ pkgver = 19.2
pkgrel = 1
url = http://www.dlib.net/
arch = any
@@ -15,10 +15,10 @@ pkgbase = mingw-w64-dlib
options = !buildflags
options = !strip
options = staticlibs
- source = http://downloads.sourceforge.net/project/dclib/dlib/v19.1/dlib-19.1.tar.bz2
- source = dlib-19.1.patch
- md5sums = 8201f9b74602aebd5a68c261ff97e00c
- md5sums = 646ce527c1ff21d80298087b399f662d
+ source = http://downloads.sourceforge.net/project/dclib/dlib/v19.2/dlib-19.2.tar.bz2
+ source = dlib-19.2.patch
+ md5sums = 12786b3765cc98193c404ccf3c88c900
+ md5sums = a8842c48f1eb5d7e3460e004e1a97d38
pkgname = mingw-w64-dlib
diff --git a/PKGBUILD b/PKGBUILD
index e7065f0eb757..0bb684d6392e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-dlib
_pkgname=dlib
-pkgver=19.1
+pkgver=19.2
pkgrel=1
pkgdesc="Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)"
arch=('any')
@@ -16,8 +16,8 @@ optdepends=('mingw-w64-lapack: for BLAS and LAPACK support'
options=('!buildflags' '!strip' 'staticlibs')
source=(http://downloads.sourceforge.net/project/dclib/${_pkgname}/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2
dlib-${pkgver}.patch)
-md5sums=('8201f9b74602aebd5a68c261ff97e00c'
- '646ce527c1ff21d80298087b399f662d')
+md5sums=('12786b3765cc98193c404ccf3c88c900'
+ 'a8842c48f1eb5d7e3460e004e1a97d38')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/dlib-19.1.patch b/dlib-19.2.patch
index 301206c7a3f6..6fe15d24808e 100644
--- a/dlib-19.1.patch
+++ b/dlib-19.2.patch
@@ -1,6 +1,17 @@
-diff -ruN dlib-19.1/dlib/cmake_utils/cmake_find_blas.txt dlib-19.1-patched/dlib/cmake_find_blas.txt
---- dlib-19.1/dlib/cmake_utils/cmake_find_blas.txt 2016-06-26 03:05:41.000000000 +0800
-+++ dlib-19.1-patched/dlib/cmake_utils/cmake_find_blas.txt 2016-06-27 13:03:20.968515000 +0800
+diff -ruN dlib-19.2/dlib/CMakeLists.txt dlib-19.2-patched/dlib/CMakeLists.txt
+--- dlib-19.2/dlib/CMakeLists.txt 2016-10-11 07:36:19.000000000 +0800
++++ dlib-19.2-patched/dlib/CMakeLists.txt 2016-10-30 10:36:04.000000000 +0800
+@@ -308,6 +308,7 @@
+ if (PNG_FOUND AND LIBPNG_IS_GOOD)
+ include_directories(${PNG_INCLUDE_DIR})
+ set (dlib_needed_libraries ${dlib_needed_libraries} ${PNG_LIBRARY})
++ set (dlib_needed_libraries ${dlib_needed_libraries} ${ZLIB_LIBRARY})
+ set(REQUIRES_LIBS " libpng")
+ else()
+ # If we can't find libpng then statically compile it in.
+diff -ruN dlib-19.2/dlib/cmake_utils/cmake_find_blas.txt dlib-19.2-patched/dlib/cmake_utils/cmake_find_blas.txt
+--- dlib-19.2/dlib/cmake_utils/cmake_find_blas.txt 2016-10-11 07:36:19.000000000 +0800
++++ dlib-19.2-patched/dlib/cmake_utils/cmake_find_blas.txt 2016-10-30 10:36:04.000000000 +0800
@@ -314,6 +314,116 @@
endif()
@@ -118,14 +129,3 @@ diff -ruN dlib-19.1/dlib/cmake_utils/cmake_find_blas.txt dlib-19.1-patched/dlib/
endif()
-diff -ruN dlib-19.1/dlib/CMakeLists.txt dlib-19.1-patched/dlib/CMakeLists.txt
---- dlib-19.1/dlib/CMakeLists.txt 2016-06-26 03:05:41.000000000 +0800
-+++ dlib-19.1-patched/dlib/CMakeLists.txt 2016-06-27 13:03:20.968515000 +0800
-@@ -309,6 +309,7 @@
- if (PNG_FOUND AND LIBPNG_IS_GOOD)
- include_directories(${PNG_INCLUDE_DIR})
- set (dlib_needed_libraries ${dlib_needed_libraries} ${PNG_LIBRARY})
-+ set (dlib_needed_libraries ${dlib_needed_libraries} ${ZLIB_LIBRARY})
- set(REQUIRES_LIBS " libpng")
- else()
- # If we can't find libpng then statically compile it in.