summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2015-08-19 16:28:30 +0800
committerpingplug2015-08-19 16:28:30 +0800
commit994bbd52528eb7ed0607b4c7f4f5b7200cf4a6e7 (patch)
tree901db588e24762678ad50324b6926e8843838f43
parent34a59175186fcfa60af7f51592a1bd9e88934c3d (diff)
downloadaur-994bbd52528eb7ed0607b4c7f4f5b7200cf4a6e7.tar.gz
Update to 18.17
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--dlib-18.17.patch (renamed from dlib-18.16.patch)24
3 files changed, 14 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 918fece535f5..c0fa40037081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-dlib
pkgdesc = Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)
- pkgver = 18.16
+ pkgver = 18.17
pkgrel = 1
url = http://www.dlib.net/
arch = any
@@ -14,10 +14,10 @@ pkgbase = mingw-w64-dlib
options = !buildflags
options = !strip
options = staticlibs
- source = http://downloads.sourceforge.net/project/dclib/dlib/v18.16/dlib-18.16.tar.bz2
- source = dlib-18.16.patch
- md5sums = e9e5449bc25370afce2d254327afac99
- md5sums = 87d1e10b4dc52960a4508264ce842602
+ source = http://downloads.sourceforge.net/project/dclib/dlib/v18.17/dlib-18.17.tar.bz2
+ source = dlib-18.17.patch
+ md5sums = 249164604423590c3f1682ab1af66ca0
+ md5sums = ecf412f6ba7382b436cd30f344fcc6dd
pkgname = mingw-w64-dlib
diff --git a/PKGBUILD b/PKGBUILD
index 293308efd4c2..33bf85a515d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-dlib
_pkgname=dlib
-pkgver=18.16
+pkgver=18.17
pkgrel=1
pkgdesc="Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques. (mingw-w64)"
arch=('any')
@@ -17,15 +17,14 @@ optdepends=('mingw-w64-cblas: for BLAS support'
options=('!buildflags' '!strip' 'staticlibs')
source=(http://downloads.sourceforge.net/project/dclib/${_pkgname}/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2
dlib-${pkgver}.patch)
-md5sums=('e9e5449bc25370afce2d254327afac99'
- '87d1e10b4dc52960a4508264ce842602')
+md5sums=('249164604423590c3f1682ab1af66ca0'
+ 'ecf412f6ba7382b436cd30f344fcc6dd')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd ${srcdir}
- # fix the windres flag
# fix can't find blas and lapack
# fix a linking error while build a static binary with libpng
patch -Np0 -i dlib-${pkgver}.patch
diff --git a/dlib-18.16.patch b/dlib-18.17.patch
index 4e9d99191e59..8b35ab3d96d1 100644
--- a/dlib-18.16.patch
+++ b/dlib-18.17.patch
@@ -1,18 +1,6 @@
-diff -ruN dlib-18.16/dlib/cmake dlib-18.16-fixed/dlib/cmake
---- dlib-18.16/dlib/cmake 2015-06-04 08:15:45.000000000 +0800
-+++ dlib-18.16-fixed/dlib/cmake 2015-06-12 09:59:41.793632173 +0800
-@@ -16,7 +16,7 @@
- # By default, g++ won't warn or error if you forget to return a value in a
- # function which requires you to do so. This option makes it give a warning
- # for doing this.
-- add_definitions("-Wreturn-type")
-+ set(${CMAKE_CXX_FLAGS} "${CMAKE_CXX_FLAGS} -Wreturn-type")
- endif()
-
- # Setup some options to allow a user to enable SSE and AVX instruction use.
-diff -ruN dlib-18.16/dlib/cmake_find_blas.txt dlib-18.16-fixed/dlib/cmake_find_blas.txt
---- dlib-18.16/dlib/cmake_find_blas.txt 2015-06-04 08:15:45.000000000 +0800
-+++ dlib-18.16-fixed/dlib/cmake_find_blas.txt 2015-06-12 09:59:41.793632173 +0800
+diff -ruN dlib-18.17/dlib/cmake_find_blas.txt dlib-18.17-fixed/dlib/cmake_find_blas.txt
+--- dlib-18.17/dlib/cmake_find_blas.txt 2015-08-16 10:26:10.000000000 +0800
++++ dlib-18.17-fixed/dlib/cmake_find_blas.txt 2015-08-19 16:23:12.199042876 +0800
@@ -261,6 +261,89 @@
endif()
@@ -103,9 +91,9 @@ diff -ruN dlib-18.16/dlib/cmake_find_blas.txt dlib-18.16-fixed/dlib/cmake_find_b
endif()
-diff -ruN dlib-18.16/dlib/CMakeLists.txt dlib-18.16-fixed/dlib/CMakeLists.txt
---- dlib-18.16/dlib/CMakeLists.txt 2015-06-04 08:15:45.000000000 +0800
-+++ dlib-18.16-fixed/dlib/CMakeLists.txt 2015-06-12 09:59:41.793632173 +0800
+diff -ruN dlib-18.17/dlib/CMakeLists.txt dlib-18.17-fixed/dlib/CMakeLists.txt
+--- dlib-18.17/dlib/CMakeLists.txt 2015-08-16 10:26:10.000000000 +0800
++++ dlib-18.17-fixed/dlib/CMakeLists.txt 2015-08-19 16:23:12.202376276 +0800
@@ -227,6 +227,7 @@
if (PNG_FOUND AND LIBPNG_IS_GOOD)
include_directories(${PNG_INCLUDE_DIR})