summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-03-30 22:03:01 +0200
committerMichel Zou2016-03-30 22:03:01 +0200
commit21425f80890cbece0e33f67f510b1d3f9f50952d (patch)
tree441c8b18aa1942de6538282a9f3def1406d0fa81
parent683b2ba172cf9b7e1ad6abd7f802f7462480e4e3 (diff)
downloadaur-21425f80890cbece0e33f67f510b1d3f9f50952d.tar.gz
3.2.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--TryRunResults.cmake31
3 files changed, 11 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab117ca5ed4b..c5b5be662eb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Mar 30 20:03:01 UTC 2016
pkgbase = mingw-w64-eigen
pkgdesc = Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra. (mingw-w64)
- pkgver = 3.2.7
+ pkgver = 3.2.8
pkgrel = 1
url = http://eigen.tuxfamily.org
arch = any
license = MPL2
makedepends = mingw-w64-cmake
- makedepends = mingw-w64-pkg-config
provides = mingw-w64-eigen3
options = !strip
options = !buildflags
options = staticlibs
- source = http://bitbucket.org/eigen/eigen/get/3.2.7.tar.bz2
+ source = http://bitbucket.org/eigen/eigen/get/3.2.8.tar.bz2
source = eigen-3.1.2_osversion.patch
source = eigen-3.2_gcc58087.patch
- source = TryRunResults.cmake
- sha1sums = 6e22013ada087bc8ac07bcc0805c3dbb55f8e544
+ sha1sums = 64f4aef8012a424c7e079eaf0be71793ab9bc6e0
sha1sums = 498f6f9889962e51c92b03970dc483103dc6590c
sha1sums = 1930d287bf60afb8d2900dbab2e21d7e1dd9f0f7
- sha1sums = 9af853e136f36ec364dd814942a542ea5cbdcd39
pkgname = mingw-w64-eigen
diff --git a/PKGBUILD b/PKGBUILD
index 3fa65c3b69c6..3e6aedd0b56f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Contributor: jellysheep <max.mail@dameweb.de>
pkgname=mingw-w64-eigen
-pkgver=3.2.7
+pkgver=3.2.8
pkgrel=1
pkgdesc="Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra. (mingw-w64)"
arch=('any')
url='http://eigen.tuxfamily.org'
license=('MPL2')
-makedepends=('mingw-w64-cmake' 'mingw-w64-pkg-config')
+makedepends=('mingw-w64-cmake')
options=('!strip' '!buildflags' 'staticlibs')
source=("http://bitbucket.org/eigen/eigen/get/${pkgver}.tar.bz2"
'eigen-3.1.2_osversion.patch'
- 'eigen-3.2_gcc58087.patch'
- 'TryRunResults.cmake')
-sha1sums=('6e22013ada087bc8ac07bcc0805c3dbb55f8e544'
+ 'eigen-3.2_gcc58087.patch')
+sha1sums=('64f4aef8012a424c7e079eaf0be71793ab9bc6e0'
'498f6f9889962e51c92b03970dc483103dc6590c'
- '1930d287bf60afb8d2900dbab2e21d7e1dd9f0f7'
- '9af853e136f36ec364dd814942a542ea5cbdcd39')
+ '1930d287bf60afb8d2900dbab2e21d7e1dd9f0f7')
provides=('mingw-w64-eigen3')
@@ -32,7 +30,7 @@ build() {
cd "$srcdir"/eigen-eigen-*
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -C "$srcdir"/TryRunResults.cmake ..
+ ${_arch}-cmake ..
make
popd
done
diff --git a/TryRunResults.cmake b/TryRunResults.cmake
deleted file mode 100644
index 575c781d6052..000000000000
--- a/TryRunResults.cmake
+++ /dev/null
@@ -1,31 +0,0 @@
-# This file was generated by CMake because it detected TRY_RUN() commands
-# in crosscompiling mode. It will be overwritten by the next CMake run.
-# Copy it to a safe location, set the variables to appropriate values
-# and use it then to preset the CMake cache (using -C).
-
-
-# run_res
-# indicates whether the executable would have been able to run on its
-# target platform. If so, set run_res to
-# the exit code (in many cases 0 for success), otherwise enter "FAILED_TO_RUN".
-# run_res__TRYRUN_OUTPUT
-# contains the text the executable would have printed on stdout and stderr.
-# If the executable would not have been able to run, set run_res__TRYRUN_OUTPUT empty.
-# Otherwise check if the output is evaluated by the calling CMake code. If so,
-# check what the source file would have printed when called with the given arguments.
-# The compile_res variable holds the build result for this TRY_RUN().
-#
-# Source file : /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/build_win32/is64.cpp
-# Executable : /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/build_win32/CMakeFiles/cmTryCompileExec75681192-run_res.exe
-# Run arguments :
-# Called from: [2] /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/cmake/EigenConfigureTesting.cmake
-# [1] /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/CMakeLists.txt
-
-SET( run_res
- 0
- CACHE STRING "Result from TRY_RUN" FORCE)
-
-SET( run_res__TRYRUN_OUTPUT
- ""
- CACHE STRING "Output from TRY_RUN" FORCE)
-