summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 22:44:56 +0200
committerxantares2015-06-08 22:44:56 +0200
commit63d66e1e7b8b5e5f6868cf7d3ca8ff552061de34 (patch)
treec2b0b71be608498cbd7206878dbb0452abf5c3bd
downloadaur-63d66e1e7b8b5e5f6868cf7d3ca8ff552061de34.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--TryRunResults.cmake31
-rw-r--r--eigen-3.1.2_osversion.patch26
-rw-r--r--eigen-3.2_gcc58087.patch12
5 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf3fcb86474
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-eigen
+ pkgdesc = Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra. (mingw-w64)
+ pkgver = 3.2.4
+ pkgrel = 1
+ url = http://eigen.tuxfamily.org
+ arch = any
+ license = MPL2
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-pkg-config
+ provides = mingw-w64-eigen3
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://bitbucket.org/eigen/eigen/get/3.2.4.tar.bz2
+ source = eigen-3.1.2_osversion.patch
+ source = eigen-3.2_gcc58087.patch
+ source = TryRunResults.cmake
+ sha1sums = 64ea809acc449adbd8fe616def7d48ff4f0776a8
+ sha1sums = 498f6f9889962e51c92b03970dc483103dc6590c
+ sha1sums = 1930d287bf60afb8d2900dbab2e21d7e1dd9f0f7
+ sha1sums = 9af853e136f36ec364dd814942a542ea5cbdcd39
+
+pkgname = mingw-w64-eigen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..663b08e4baff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: jellysheep <max.mail@dameweb.de>
+
+pkgname=mingw-w64-eigen
+pkgver=3.2.4
+pkgrel=1
+pkgdesc="Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra. (mingw-w64)"
+arch=('any')
+url='http://eigen.tuxfamily.org'
+license=('MPL2')
+makedepends=('mingw-w64-cmake' 'mingw-w64-pkg-config')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("http://bitbucket.org/eigen/eigen/get/${pkgver}.tar.bz2"
+ 'eigen-3.1.2_osversion.patch'
+ 'eigen-3.2_gcc58087.patch'
+ 'TryRunResults.cmake')
+sha1sums=('64ea809acc449adbd8fe616def7d48ff4f0776a8'
+ '498f6f9889962e51c92b03970dc483103dc6590c'
+ '1930d287bf60afb8d2900dbab2e21d7e1dd9f0f7'
+ '9af853e136f36ec364dd814942a542ea5cbdcd39')
+provides=('mingw-w64-eigen3')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir"/eigen-eigen-*
+ patch -p2 -i "$srcdir"/eigen-3.1.2_osversion.patch
+ patch -p1 -i "$srcdir"/eigen-3.2_gcc58087.patch
+}
+
+build() {
+ cd "$srcdir"/eigen-eigen-*
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -C "$srcdir"/TryRunResults.cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/eigen-eigen-*/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ done
+}
+
diff --git a/TryRunResults.cmake b/TryRunResults.cmake
new file mode 100644
index 000000000000..575c781d6052
--- /dev/null
+++ b/TryRunResults.cmake
@@ -0,0 +1,31 @@
+# This file was generated by CMake because it detected TRY_RUN() commands
+# in crosscompiling mode. It will be overwritten by the next CMake run.
+# Copy it to a safe location, set the variables to appropriate values
+# and use it then to preset the CMake cache (using -C).
+
+
+# run_res
+# indicates whether the executable would have been able to run on its
+# target platform. If so, set run_res to
+# the exit code (in many cases 0 for success), otherwise enter "FAILED_TO_RUN".
+# run_res__TRYRUN_OUTPUT
+# contains the text the executable would have printed on stdout and stderr.
+# If the executable would not have been able to run, set run_res__TRYRUN_OUTPUT empty.
+# Otherwise check if the output is evaluated by the calling CMake code. If so,
+# check what the source file would have printed when called with the given arguments.
+# The compile_res variable holds the build result for this TRY_RUN().
+#
+# Source file : /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/build_win32/is64.cpp
+# Executable : /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/build_win32/CMakeFiles/cmTryCompileExec75681192-run_res.exe
+# Run arguments :
+# Called from: [2] /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/cmake/EigenConfigureTesting.cmake
+# [1] /home/sandro/rpmbuild/BUILD/eigen-eigen-5097c01bcdc4/CMakeLists.txt
+
+SET( run_res
+ 0
+ CACHE STRING "Result from TRY_RUN" FORCE)
+
+SET( run_res__TRYRUN_OUTPUT
+ ""
+ CACHE STRING "Output from TRY_RUN" FORCE)
+
diff --git a/eigen-3.1.2_osversion.patch b/eigen-3.1.2_osversion.patch
new file mode 100644
index 000000000000..e392f5bde84a
--- /dev/null
+++ b/eigen-3.1.2_osversion.patch
@@ -0,0 +1,26 @@
+diff -rupN eigen-3.1.2/eigen-eigen-ffa86ffb5570/cmake/EigenDetermineOSVersion.cmake eigen-3.1.2-new/eigen-eigen-ffa86ffb5570/cmake/EigenDetermineOSVersion.cmake
+--- eigen-3.1.2/eigen-eigen-ffa86ffb5570/cmake/EigenDetermineOSVersion.cmake 2012-11-05 22:22:49.000000000 +0100
++++ eigen-3.1.2-new/eigen-eigen-ffa86ffb5570/cmake/EigenDetermineOSVersion.cmake 2013-03-01 23:03:26.732533050 +0100
+@@ -26,21 +26,5 @@ function(DetermineShortWindowsName WIN_V
+ endfunction()
+
+ function(DetermineOSVersion OS_VERSION)
+- if (WIN32)
+- file (TO_NATIVE_PATH "$ENV{COMSPEC}" SHELL)
+- exec_program( ${SHELL} ARGS "/c" "ver" OUTPUT_VARIABLE ver_output)
+-
+- string(REGEX MATCHALL "[0-9]+"
+- ver_list "${ver_output}")
+- list(GET ver_list 0 _major)
+- list(GET ver_list 1 _minor)
+-
+- set(win_num_version ${_major}.${_minor})
+- DetermineShortWindowsName(win_version "${win_num_version}")
+- if(win_version)
+- set(${OS_VERSION} ${win_version} PARENT_SCOPE)
+- endif()
+- else()
+- set(${OS_VERSION} ${CMAKE_SYSTEM} PARENT_SCOPE)
+- endif()
++ set(${OS_VERSION} ${CMAKE_SYSTEM} PARENT_SCOPE)
+ endfunction()
diff --git a/eigen-3.2_gcc58087.patch b/eigen-3.2_gcc58087.patch
new file mode 100644
index 000000000000..9e16e2f79f3c
--- /dev/null
+++ b/eigen-3.2_gcc58087.patch
@@ -0,0 +1,12 @@
+diff -rupN eigen-eigen-ffa86ffb5570/Eigen/Core eigen-eigen-ffa86ffb5570-new/Eigen/Core
+--- eigen-eigen-ffa86ffb5570/Eigen/Core 2013-07-24 03:48:35.000000000 +0200
++++ eigen-eigen-ffa86ffb5570-new/Eigen/Core 2013-08-05 22:23:54.447255489 +0200
+@@ -22,7 +22,7 @@
+ // Disable the ipa-cp-clone optimization flag with MinGW 6.x or newer (enabled by default with -O3)
+ // See http://eigen.tuxfamily.org/bz/show_bug.cgi?id=556 for details.
+ #if defined(__MINGW32__) && EIGEN_GNUC_AT_LEAST(4,6)
+- #pragma GCC optimize ("-fno-ipa-cp-clone")
++// #pragma GCC optimize ("-fno-ipa-cp-clone")
+ #endif
+
+ #include <complex>