summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-03-09 20:40:34 +0100
committerMichel Zou2016-03-09 20:40:34 +0100
commitaa9d24250712750e71bfa4c5cca684e356e5e284 (patch)
treed054bb07c2e4cd5ec98181bc6cd5032fd9c9cb15
downloadaur-aa9d24250712750e71bfa4c5cca684e356e5e284.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d478e8b2d35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Mar 9 19:40:34 UTC 2016
+pkgbase = mingw-w64-exprtk-git
+ pkgdesc = C++ Mathematical Expression Library
+ pkgver = r173.bc53259
+ pkgrel = 1
+ url = http://www.partow.net/programming/exprtk/index.html
+ arch = any
+ license = CPL
+ makedepends = git
+ depends = mingw-w64-crt
+ provides = mingw-w64-exprtk
+ conflicts = mingw-w64-exprtk
+ source = git+https://github.com/ArashPartow/exprtk.git
+ md5sums = SKIP
+
+pkgname = mingw-w64-exprtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..580cba8e4701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=mingw-w64-exprtk-git
+pkgver=r173.bc53259
+pkgrel=1
+pkgdesc="C++ Mathematical Expression Library"
+arch=('any')
+url="http://www.partow.net/programming/exprtk/index.html"
+license=('CPL')
+depends=('mingw-w64-crt')
+makedepends=('git')
+provides=('mingw-w64-exprtk')
+conflicts=('mingw-w64-exprtk')
+source=('git+https://github.com/ArashPartow/exprtk.git')
+md5sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "$srcdir/exprtk"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/exprtk"
+ for _arch in ${_architectures}; do
+ install -d "${pkgdir}"/usr/${_arch}/include
+ install -D -m644 exprtk.hpp "${pkgdir}"/usr/${_arch}/include
+ done
+}