summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-12-30 15:48:28 -0800
committerSchala2016-12-30 15:48:28 -0800
commite92b0a4e07e325b8e3e3229b8fd867cdaad296f1 (patch)
treeb859368057df1a0d614c904a1ecdf5cb045008a8
parent1766fe8c165fe091eacf79aaafda9b952dee6d51 (diff)
downloadaur-e92b0a4e07e325b8e3e3229b8fd867cdaad296f1.tar.gz
amend prev. patch
-rw-r--r--.SRCINFO8
-rw-r--r--05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch68
-rw-r--r--PKGBUILD8
-rw-r--r--e4c8c735d59f813acc69194030401f67883fb427.patch25
4 files changed, 76 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff1e634a05..640b24eb98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 29 23:27:05 UTC 2016
+# Fri Dec 30 23:48:12 UTC 2016
pkgbase = mingw-w64-extra-cmake-modules
pkgdesc = Extra modules and scripts for CMake (mingw-w64)
pkgver = 5.29.0
- pkgrel = 2
+ pkgrel = 3
url = https://projects.kde.org/projects/kdesupport/extra-cmake-modules
arch = any
groups = mingw-w64-kf5
@@ -14,10 +14,10 @@ pkgbase = mingw-w64-extra-cmake-modules
options = !buildflags
source = http://download.kde.org/stable/frameworks/5.29/extra-cmake-modules-5.29.0.tar.xz
source = set-AUTOSTATICPLUGINS.patch
- source = e4c8c735d59f813acc69194030401f67883fb427.patch
+ source = 05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
md5sums = dd3e13ee27fb421a9d215fc708ae02b3
md5sums = 0d249754247382f3b8dda80d6833aac4
- md5sums = e977bbee6a68a1e27c7f9a766fc0a6ca
+ md5sums = 5dff00f63909b8aaf717d7e07bdff80d
pkgname = mingw-w64-extra-cmake-modules
diff --git a/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch b/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
new file mode 100644
index 00000000000..db35634c62c
--- /dev/null
+++ b/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
@@ -0,0 +1,68 @@
+From 05aa27dc0e14dab407379a4d22f895e9eff13cc0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 29 Dec 2016 13:31:31 +0100
+Subject: [PATCH] Fix use of Qt5::lconvert and Qt5::lrelease
+
+This workaround seems to be required
+for mingw-w64 packages, not sure what's
+the actual problem, though
+---
+ modules/ECMCreateQmFromPoFiles.cmake | 6 +++---
+ modules/ECMPoQmTools.cmake | 6 +++---
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/modules/ECMCreateQmFromPoFiles.cmake b/modules/ECMCreateQmFromPoFiles.cmake
+index 4cc1e7b..fc6634e 100644
+--- a/modules/ECMCreateQmFromPoFiles.cmake
++++ b/modules/ECMCreateQmFromPoFiles.cmake
+@@ -122,12 +122,12 @@ function(_ECM_QM_EXTRACT_LANGUAGE out_language po_file)
+ endfunction()
+
+ function(_ECM_QM_CREATE_TARGET install_destination catalog_name)
++ get_target_property(lrelease_location Qt5::lrelease LOCATION)
+ # Find lconvert
+ if(TARGET Qt5::lconvert)
+- set(lconvert_executable Qt5::lconvert)
++ get_target_property(lconvert_executable Qt5::lconvert IMPORTED_LOCATION)
+ else()
+ # Qt < 5.3.1 does not define Qt5::lconvert
+- get_target_property(lrelease_location Qt5::lrelease LOCATION)
+ get_filename_component(lrelease_path ${lrelease_location} PATH)
+ find_program(lconvert_executable
+ NAMES lconvert-qt5 lconvert
+@@ -157,7 +157,7 @@ function(_ECM_QM_CREATE_TARGET install_destination catalog_name)
+ add_custom_command(OUTPUT ${qmfile}
+ COMMAND ${lconvert_executable}
+ ARGS -i ${it} -o ${tsfile} -target-language ${language}
+- COMMAND Qt5::lrelease
++ COMMAND ${lrelease_location}
+ ARGS -removeidentical -silent ${tsfile} -qm ${qmfile}
+ DEPENDS ${it}
+ )
+diff --git a/modules/ECMPoQmTools.cmake b/modules/ECMPoQmTools.cmake
+index 5bc3b07..95a8afa 100644
+--- a/modules/ECMPoQmTools.cmake
++++ b/modules/ECMPoQmTools.cmake
+@@ -143,11 +143,11 @@ function(ecm_process_po_files_as_qm lang)
+ # Find lrelease and lconvert
+ find_package(Qt5LinguistTools CONFIG REQUIRED)
+
++ get_target_property(lrelease_location Qt5::lrelease LOCATION)
+ if(TARGET Qt5::lconvert)
+- set(lconvert_executable Qt5::lconvert)
++ get_target_property(lconvert_executable Qt5::lconvert IMPORTED_LOCATION)
+ else()
+ # Qt < 5.3.1 does not define Qt5::lconvert
+- get_target_property(lrelease_location Qt5::lrelease LOCATION)
+ get_filename_component(lrelease_path ${lrelease_location} PATH)
+ find_program(lconvert_executable
+ NAMES lconvert-qt5 lconvert
+@@ -174,7 +174,7 @@ function(ecm_process_po_files_as_qm lang)
+ add_custom_command(OUTPUT ${qm_file}
+ COMMAND ${lconvert_executable}
+ ARGS -i ${po_file} -o ${ts_file} -target-language ${lang}
+- COMMAND Qt5::lrelease
++ COMMAND ${lrelease_location}
+ ARGS -removeidentical -nounfinished -silent ${ts_file} -qm ${qm_file}
+ DEPENDS ${po_file}
+ )
diff --git a/PKGBUILD b/PKGBUILD
index 29a8c4301d2..4ae9af3d9e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-extra-cmake-modules
pkgver=5.29.0
-pkgrel=2
+pkgrel=3
arch=(any)
pkgdesc="Extra modules and scripts for CMake (mingw-w64)"
groups=(mingw-w64-kf5)
@@ -10,17 +10,17 @@ options=(staticlibs !strip !buildflags)
url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/extra-cmake-modules-${pkgver}.tar.xz"
"set-AUTOSTATICPLUGINS.patch"
-"e4c8c735d59f813acc69194030401f67883fb427.patch")
+"05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch")
md5sums=('dd3e13ee27fb421a9d215fc708ae02b3'
'0d249754247382f3b8dda80d6833aac4'
- 'e977bbee6a68a1e27c7f9a766fc0a6ca')
+ '5dff00f63909b8aaf717d7e07bdff80d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd extra-cmake-modules-$pkgver
patch -p1 -i "${srcdir}"/set-AUTOSTATICPLUGINS.patch
- patch -p1 -i "$srcdir"/e4c8c735d59f813acc69194030401f67883fb427.patch
+ patch -p1 -i "$srcdir"/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
}
build() {
diff --git a/e4c8c735d59f813acc69194030401f67883fb427.patch b/e4c8c735d59f813acc69194030401f67883fb427.patch
deleted file mode 100644
index 5192f79ff78..00000000000
--- a/e4c8c735d59f813acc69194030401f67883fb427.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From e4c8c735d59f813acc69194030401f67883fb427 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Thu, 29 Dec 2016 13:31:31 +0100
-Subject: [PATCH] Fix use of Qt::lconvert
-
-This workaround seems to be required
-for mingw-w64 packages, not sure what's
-the actual problem, though
----
- modules/ECMPoQmTools.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/modules/ECMPoQmTools.cmake b/modules/ECMPoQmTools.cmake
-index 5bc3b07..f9cc63f 100644
---- a/modules/ECMPoQmTools.cmake
-+++ b/modules/ECMPoQmTools.cmake
-@@ -144,7 +144,7 @@ function(ecm_process_po_files_as_qm lang)
- find_package(Qt5LinguistTools CONFIG REQUIRED)
-
- if(TARGET Qt5::lconvert)
-- set(lconvert_executable Qt5::lconvert)
-+ get_target_property(lconvert_executable Qt5::lconvert IMPORTED_LOCATION)
- else()
- # Qt < 5.3.1 does not define Qt5::lconvert
- get_target_property(lrelease_location Qt5::lrelease LOCATION)