summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-05-11 18:31:38 +0200
committerMichel Zou2023-05-11 18:31:38 +0200
commit72d68209a2a6c3ef55c3ce1ad49ffa053c0a295d (patch)
treebc8eec948ceaa52736c1cfaa448c875bad73e8ba
downloadaur-72d68209a2a6c3ef55c3ce1ad49ffa053c0a295d.tar.gz
4.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7871ad4da53c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-fast_float
+ pkgdesc = Fast and exact implementation of the C++ from_chars functions:4x faster than strtod (mingw-w64)
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/fastfloat/fast_float/
+ arch = any
+ license = MIT
+ license = Apache-2.0
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://github.com/fastfloat/fast_float/archive/refs/tags/v4.0.0.tar.gz
+ sha256sums = 9470f229b9ea8d116af7c92f2ab8e8ae6b3c3225d15081b859634328f28d4664
+
+pkgname = mingw-w64-fast_float
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..713cfece2143
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=mingw-w64-fast_float
+pkgver=4.0.0
+pkgrel=1
+arch=(any)
+url="https://github.com/fastfloat/fast_float/"
+license=('MIT' 'Apache-2.0')
+pkgdesc='Fast and exact implementation of the C++ from_chars functions:4x faster than strtod (mingw-w64)'
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/fastfloat/fast_float/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('9470f229b9ea8d116af7c92f2ab8e8ae6b3c3225d15081b859634328f28d4664')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd fast_float-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/fast_float-${pkgver}/build-${_arch}"
+ make install DESTDIR="${pkgdir}"
+ done
+}