summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2018-08-02 20:10:47 +0200
committerkfg2018-08-02 20:10:47 +0200
commit1aa330daf3684218ab1ea7fcf5c4a14149c2dc86 (patch)
tree3d6fc0c405db3fa33b4ec74e4cdb51c7c7f207a8
parent72de45efbc56a1a365b188a9ea4541c7d111b52c (diff)
downloadaur-1aa330daf3684218ab1ea7fcf5c4a14149c2dc86.tar.gz
upgpkg: mingw-w64-ffmpeg 1:4.0.2-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fb9ada7ecdf..8b9fbe55e35d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 19 20:21:31 UTC 2018
+# Thu Aug 2 18:09:20 UTC 2018
pkgbase = mingw-w64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 4.0.1
+ pkgver = 4.0.2
pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
@@ -10,7 +10,9 @@ pkgbase = mingw-w64-ffmpeg
license = GPL3
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
makedepends = yasm
+ depends = mingw-w64-aom
depends = mingw-w64-crt
depends = mingw-w64-bzip2
depends = mingw-w64-fontconfig
@@ -42,10 +44,8 @@ pkgbase = mingw-w64-ffmpeg
options = !strip
options = !buildflags
options = staticlibs
- source = https://ffmpeg.org/releases/ffmpeg-4.0.1.tar.xz
- source = https://ffmpeg.org/releases/ffmpeg-4.0.1.tar.xz.asc
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.0.2
source = configure.patch
- sha256sums = 605f5c01c60db35d3b617a79cabb2c7032412be243554602eeed1b628125c0ee
sha256sums = SKIP
sha256sums = 3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed
diff --git a/PKGBUILD b/PKGBUILD
index e7b3b030923f..580e74a3ba5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-ffmpeg
-pkgver=4.0.1
+pkgver=4.0.2
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
@@ -9,24 +9,22 @@ arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
depends=(
-'mingw-w64-crt' 'mingw-w64-bzip2' 'mingw-w64-fontconfig' 'mingw-w64-fribidi' 'mingw-w64-gmp' 'mingw-w64-gnutls'
+'mingw-w64-aom' 'mingw-w64-crt' 'mingw-w64-bzip2' 'mingw-w64-fontconfig' 'mingw-w64-fribidi' 'mingw-w64-gmp' 'mingw-w64-gnutls'
'mingw-w64-gsm' 'mingw-w64-lame' 'mingw-w64-libass' 'mingw-w64-libbluray' 'mingw-w64-libmodplug'
'mingw-w64-libsoxr' 'mingw-w64-libtheora' 'mingw-w64-vid.stab' 'mingw-w64-libwebp' 'mingw-w64-libxml2' 'mingw-w64-libvorbis' 'mingw-w64-libvpx'
'mingw-w64-opencore-amr' 'mingw-w64-openjpeg2' 'mingw-w64-opus' 'mingw-w64-libssh'
'mingw-w64-sdl2' 'mingw-w64-speex' 'mingw-w64-x264' 'mingw-w64-xvidcore' 'mingw-w64-zlib' 'mingw-w64-x265'
)
options=(!strip !buildflags staticlibs)
-makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'yasm')
-source=(https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz{,.asc}
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
+source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
configure.patch)
-validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('605f5c01c60db35d3b617a79cabb2c7032412be243554602eeed1b628125c0ee'
- 'SKIP'
+sha256sums=('SKIP'
'3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd ffmpeg-${pkgver}
+ cd ffmpeg
patch -Np1 -i ../configure.patch
}
@@ -35,7 +33,7 @@ build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}"/build-${_arch} && cd "${srcdir}"/build-${_arch}
- "${srcdir}"/ffmpeg-${pkgver}/configure \
+ "${srcdir}"/ffmpeg/configure \
--prefix="/usr/${_arch}" \
--enable-cross-compile \
--cross-prefix="${_arch}-" \
@@ -49,6 +47,7 @@ build() {
--enable-gmp \
--enable-gnutls \
--enable-gpl \
+ --enable-libaom \
--enable-libass \
--enable-libbluray \
--enable-libfreetype \