summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2020-07-18 00:27:41 +0200
committerkfg2020-07-18 00:31:24 +0200
commit6c3c50e3923b23d93245654b8a26ac5bc14d0020 (patch)
tree7ffbd350b8583c1c4af40f2e2d6796385c974c32
parentbe8b1a153838068bbe00c0af2460bc2d82367d25 (diff)
downloadaur-6c3c50e3923b23d93245654b8a26ac5bc14d0020.tar.gz
upgpkg: mingw-w64-ffmpeg 1:4.3.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39e3aabfeac5..4d0cb05eadeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 4.2.3
- pkgrel = 2
+ pkgver = 4.3.1
+ pkgrel = 1
epoch = 1
url = https://ffmpeg.org/
arch = any
@@ -44,7 +44,7 @@ pkgbase = mingw-w64-ffmpeg
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=d3b963cc41824a3c5b2758ac896fb23e20a87875
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=6b6b9e593dd4d3aaf75f48d40a13ef03bdef9fdb
source = vmaf-model-path.patch
source = configure.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0999ff98060d..50d01a525ac3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : Karl-Felix Glatzer <karl[dot]glatzer[at]gmx[dot]de>
pkgname=mingw-w64-ffmpeg
-pkgver=4.2.3
-pkgrel=2
+pkgver=4.3.1
+pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
arch=('any')
@@ -44,9 +44,12 @@ depends=(
# TODO: Add vmaf dependency
#'mingw-w64-vmaf'
options=(!strip !buildflags staticlibs)
+# TODO: Add avisynth dependency
+#'mingw-w64-avisynthplus'
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
+_tag=6b6b9e593dd4d3aaf75f48d40a13ef03bdef9fdb
#source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
-source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=d3b963cc41824a3c5b2758ac896fb23e20a87875
+source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
vmaf-model-path.patch
configure.patch)
sha256sums=('SKIP'
@@ -63,10 +66,6 @@ pkgver() {
prepare() {
cd ffmpeg
- # lavf/mp3dec: don't adjust start time; packets are not adjusted
- # https://crbug.com/1062037
- git cherry-pick -n 460132c9980f8a1f501a1f69477bca49e1641233
-
patch -Np1 -i ../configure.patch
# TODO: Add vmaf dependency
@@ -86,7 +85,6 @@ build() {
--disable-debug \
--enable-static \
--disable-stripping \
- --enable-avisynth \
--enable-fontconfig \
--enable-gmp \
--enable-gnutls \
@@ -104,6 +102,7 @@ build() {
--enable-libopencore_amrwb \
--enable-libopenjpeg \
--enable-libopus \
+ --enable-librav1e \
--enable-libsoxr \
--enable-libspeex \
--enable-libsrt \
@@ -123,6 +122,8 @@ build() {
--disable-doc \
--x86asmexe=yasm
+# TODO: Add avisynth dependency
+# --enable-avisynth \
# TODO: Add vmaf dependency
# --enable-libvmaf \