summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2021-04-23 18:35:06 +0200
committerkfg2021-05-11 19:31:23 +0200
commit7dbe3dc86f6e240e4d19689a46f0dad0b97af3dc (patch)
tree8a72a9b8ba586be8456c289c9e367cc3ecb416d0
parent5b031863d6aa26c2dee786f0d339284169b43bb4 (diff)
downloadaur-7dbe3dc86f6e240e4d19689a46f0dad0b97af3dc.tar.gz
upgpkg: mingw-w64-ffmpeg 1:4.4-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--windres.patch13
3 files changed, 32 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e25e566a4321..15672234298e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 4.3.2
+ pkgver = 4.4
pkgrel = 1
epoch = 1
url = https://ffmpeg.org/
@@ -36,6 +36,7 @@ pkgbase = mingw-w64-ffmpeg
depends = mingw-w64-openjpeg2
depends = mingw-w64-opus
depends = mingw-w64-rav1e
+ depends = mingw-w64-librsvg
depends = mingw-w64-libssh
depends = mingw-w64-sdl2
depends = mingw-w64-speex
@@ -48,12 +49,14 @@ pkgbase = mingw-w64-ffmpeg
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=f719f869907764e6412a6af6e178c46e5f915d25
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=dc91b913b6260e85e1304c74ff7bb3c22a8c9fb1
source = vmaf-model-path.patch
source = configure.patch
+ source = windres.patch
sha256sums = SKIP
sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
sha256sums = 3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed
+ sha256sums = c78ae2245fd1863ea495c115b24214d5692b86ff51b8899a23bc43a48c3385c0
pkgname = mingw-w64-ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 6d40a0ffc457..a24ccec583ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Karl-Felix Glatzer <karl[dot]glatzer[at]gmx[dot]de>
pkgname=mingw-w64-ffmpeg
-pkgver=4.3.2
+pkgver=4.4
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
@@ -33,6 +33,7 @@ depends=(
'mingw-w64-openjpeg2'
'mingw-w64-opus'
'mingw-w64-rav1e'
+ 'mingw-w64-librsvg'
'mingw-w64-libssh'
'mingw-w64-sdl2'
'mingw-w64-speex'
@@ -45,16 +46,19 @@ depends=(
)
# TODO: Add vmaf dependency
#'mingw-w64-vmaf'
+#'mingw-w64-svt-av1' (only 64 bit support)
options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-amf-headers' 'mingw-w64-avisynthplus' 'mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
-_tag=f719f869907764e6412a6af6e178c46e5f915d25
+_tag=dc91b913b6260e85e1304c74ff7bb3c22a8c9fb1
#source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
vmaf-model-path.patch
- configure.patch)
+ configure.patch
+ windres.patch)
sha256sums=('SKIP'
'8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d'
- '3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed')
+ '3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed'
+ 'c78ae2245fd1863ea495c115b24214d5692b86ff51b8899a23bc43a48c3385c0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgver() {
@@ -66,7 +70,9 @@ pkgver() {
prepare() {
cd ffmpeg
- patch -Np1 -i ../configure.patch
+ patch -Np1 -i "${srcdir}/configure.patch"
+
+ patch -Np1 -i "${srcdir}/windres.patch"
# TODO: Add vmaf dependency
# patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
@@ -109,6 +115,7 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--enable-librav1e \
+ --enable-librsvg \
--enable-libsoxr \
--enable-libspeex \
--enable-libsrt \
@@ -131,6 +138,8 @@ build() {
# TODO: Add vmaf dependency
# --enable-libvmaf \
+# (only 64 bit support)
+# --enable-libsvtav1 \
make
done
diff --git a/windres.patch b/windres.patch
new file mode 100644
index 000000000000..0e040f031001
--- /dev/null
+++ b/windres.patch
@@ -0,0 +1,13 @@
+diff --git a/ffbuild/common.mak b/ffbuild/common.mak
+index e070b6b5e2..ab536e157d 100644
+--- a/ffbuild/common.mak
++++ b/ffbuild/common.mak
+@@ -90,7 +90,7 @@ COMPILE_MSA = $(call COMPILE,CC,MSAFLAGS)
+ -$(if $(ASMSTRIPFLAGS), $(STRIP) $(ASMSTRIPFLAGS) $@)
+
+ %.o: %.rc
+- $(WINDRES) $(IFLAGS) --preprocessor "$(DEPWINDRES) -E -xc-header -DRC_INVOKED $(CC_DEPFLAGS)" -o $@ $<
++ $(WINDRES) $(IFLAGS) -o $@ $<
+
+ %.i: %.c
+ $(CC) $(CCFLAGS) $(CC_E) $<