summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2019-10-03 17:48:55 +0200
committerkfg2019-10-03 17:58:38 +0200
commitb07a36d567ca5e1b26c626d7ee076ebd31a9dd7a (patch)
tree67eeb8e13881be1cdedf8a8b9a22e8654551e5ca
parent82c02267550fb353182eea9018b677e23444d8c4 (diff)
downloadaur-b07a36d567ca5e1b26c626d7ee076ebd31a9dd7a.tar.gz
upgpkg: mingw-w64-ffmpeg 1:4.2.1-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8c5b473a027..0091344346df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jul 17 20:32:46 UTC 2019
+# Thu Oct 3 15:58:25 UTC 2019
pkgbase = mingw-w64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 4.1.4
+ pkgver = 4.2.1
pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
@@ -23,6 +23,7 @@ pkgbase = mingw-w64-ffmpeg
depends = mingw-w64-lame
depends = mingw-w64-libass
depends = mingw-w64-libbluray
+ depends = mingw-w64-dav1d
depends = mingw-w64-libmodplug
depends = mingw-w64-libsoxr
depends = mingw-w64-libtheora
@@ -44,7 +45,7 @@ pkgbase = mingw-w64-ffmpeg
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.1.4
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=cbb3c9497549f8856d8cd37ac63af1406a784e58
source = configure.patch
sha256sums = SKIP
sha256sums = 3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed
diff --git a/PKGBUILD b/PKGBUILD
index 38cf71014cd2..790fd4d24f7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer : Karl-Felix Glatzer <karl.glatzer@gmx.de>
+# Maintainer : Karl-Felix Glatzer <karl[dot]glatzer[at]gmx[dot]de>
pkgname=mingw-w64-ffmpeg
-pkgver=4.1.4
+pkgver=4.2.1
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
@@ -20,6 +20,7 @@ depends=(
'mingw-w64-lame'
'mingw-w64-libass'
'mingw-w64-libbluray'
+ 'mingw-w64-dav1d'
'mingw-w64-libmodplug'
'mingw-w64-libsoxr'
'mingw-w64-libtheora'
@@ -41,15 +42,24 @@ depends=(
)
options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
-source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
+#source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
+source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=cbb3c9497549f8856d8cd37ac63af1406a784e58
configure.patch)
sha256sums=('SKIP'
'3cec5d47cd190cc9cf7969b2c2c94690d7b15ffb5d7147bdd4e60eecb0991eed')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd ffmpeg
+
+ git describe --tags | sed 's/^n//'
+}
+
prepare() {
cd ffmpeg
+ git cherry-pick -n dc0806dd25882f41f6085c8356712f95fded56c7
+
patch -Np1 -i ../configure.patch
}
@@ -73,6 +83,7 @@ build() {
--enable-libaom \
--enable-libass \
--enable-libbluray \
+ --enable-libdav1d \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \