summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-04-27 21:47:56 +0200
committerNicola Murino2019-04-27 21:47:56 +0200
commit535c9dbaa54a4604934b1839c2b96e7d4582a021 (patch)
treee65928ef39030a0222df28856f4162ba0cdf8b28
downloadaur-535c9dbaa54a4604934b1839c2b96e7d4582a021.tar.gz
Initial version
This package is mainly needed to build gst-libav and preserving LGPL license
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD58
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfb2331d4cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-ffmpeg-minimal
+ pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
+ pkgver = 4.1.3
+ pkgrel = 1
+ epoch = 1
+ url = http://ffmpeg.org/
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ makedepends = git
+ makedepends = yasm
+ depends = mingw-w64-crt
+ depends = mingw-w64-bzip2
+ depends = mingw-w64-zlib
+ provides = mingw-w64-ffmpeg
+ conflicts = mingw-w64-ffmpeg
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.1.3
+ sha256sums = SKIP
+
+pkgname = mingw-w64-ffmpeg-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6a7ed054fa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+pkgname=mingw-w64-ffmpeg-minimal
+pkgver=4.1.3
+pkgrel=1
+epoch=1
+pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
+arch=('any')
+url="http://ffmpeg.org/"
+license=('LGPL')
+depends=(
+ 'mingw-w64-crt'
+ 'mingw-w64-bzip2'
+ 'mingw-w64-zlib'
+)
+options=(!strip !buildflags staticlibs)
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
+provides=('mingw-w64-ffmpeg')
+conflicts=('mingw-w64-ffmpeg')
+source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}")
+sha256sums=('SKIP')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}"/build-${_arch} && cd "${srcdir}"/build-${_arch}
+
+ "${srcdir}"/ffmpeg/configure \
+ --prefix="/usr/${_arch}" \
+ --enable-cross-compile \
+ --cross-prefix="${_arch}-" \
+ --target-os=mingw32 \
+ --arch=${_arch%%-*} \
+ --disable-debug \
+ --disable-stripping \
+ --enable-zlib \
+ --enable-shared \
+ --disable-doc \
+ --disable-encoder=flac \
+ --x86asmexe=yasm
+
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/build-${_arch}
+ make DESTDIR="$pkgdir" install
+
+ ${_arch}-strip -s "${pkgdir}"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+
+ mv "${pkgdir}"/usr/${_arch}/bin/*.lib "${pkgdir}"/usr/${_arch}/lib/
+ done
+}
+
+# vim:set ts=2 sw=2 et: