summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2022-08-20 21:25:27 +0200
committerNicola Murino2022-08-20 21:25:27 +0200
commit77e0a3ab43b772a185e42d5cd4ad925bd4e5e60b (patch)
tree7d92a88fb602b35030c2904b45d392ffcb2b5c49
parent651109f9154e83a0ca4b8ed1c7560b7f579053e5 (diff)
downloadaur-77e0a3ab43b772a185e42d5cd4ad925bd4e5e60b.tar.gz
Update to 5.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a45dc7dc72c2..febb20b1792c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-ffmpeg-minimal
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 5.0.1
+ pkgver = 5.1
pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
@@ -18,7 +18,7 @@ pkgbase = mingw-w64-ffmpeg-minimal
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n5.0.1
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=e0723b7e4e22492275d476fcd30d759e1198bc5b
sha256sums = SKIP
pkgname = mingw-w64-ffmpeg-minimal
diff --git a/PKGBUILD b/PKGBUILD
index d0758640d0a8..e59e88a2241d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-ffmpeg-minimal
-pkgver=5.0.1
+pkgver=5.1
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
@@ -16,10 +16,16 @@ options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
provides=('mingw-w64-ffmpeg')
conflicts=('mingw-w64-ffmpeg')
-source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}")
+_tag=e0723b7e4e22492275d476fcd30d759e1198bc5b
+source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}")
sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd ffmpeg
+ git describe --tags | sed 's/^n//'
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}"/build-${_arch} && cd "${srcdir}"/build-${_arch}