summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-01-13 20:02:07 +0100
committerMartchus2016-01-13 20:02:07 +0100
commitdf02955ddc4fabd90b84bbd5691b69cf42185991 (patch)
tree63f08cdb0ceba40309904c5eda2498da7ec1fb55
downloadaur-df02955ddc4fabd90b84bbd5691b69cf42185991.tar.gz
initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a38e12ac9ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 19:01:46 UTC 2016
+pkgbase = mingw-w64-filezilla-svn
+ pkgdesc = Fast and reliable FTP, FTPS and SFTP client (mingw-w64, svn version)
+ pkgver = r7253
+ pkgrel = 1
+ url = https://filezilla-project.org/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ makedepends = wxgtk
+ makedepends = subversion
+ depends = mingw-w64-crt
+ depends = mingw-w64-libidn
+ depends = mingw-w64-sqlite
+ depends = mingw-w64-gnutls
+ depends = mingw-w64-wxmsw
+ depends = mingw-w64-libfilezilla-svn
+ provides = mingw-w64-filezilla
+ conflicts = mingw-w64-filezilla
+ source = filezilla::svn+https://svn.filezilla-project.org/svn/FileZilla3/trunk
+ md5sums = SKIP
+
+pkgname = mingw-w64-filezilla-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91369c695f12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+_name=filezilla
+pkgname=mingw-w64-filezilla-svn
+pkgver=r7253
+pkgrel=1
+pkgdesc="Fast and reliable FTP, FTPS and SFTP client (mingw-w64, svn version)"
+arch=('any')
+url="https://filezilla-project.org/"
+license=('GPL')
+depends=('mingw-w64-crt' 'mingw-w64-libidn' 'mingw-w64-sqlite' 'mingw-w64-gnutls' 'mingw-w64-wxmsw' 'mingw-w64-libfilezilla-svn')
+makedepends=('mingw-w64-gcc' 'mingw-w64-configure' 'wxgtk' 'subversion')
+provides=(${pkgname%-svn})
+conflicts=(${pkgname%-svn})
+install=
+source=("${_name}::svn+https://svn.filezilla-project.org/svn/FileZilla3/trunk")
+md5sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "${_name}"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd "${_name}"
+ autoreconf -i
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/${_name}/build-${_arch}" && cd "${srcdir}/${_name}/build-${_arch}"
+ export PATH="/usr/${_arch}/bin:${PATH}"
+ ${_arch}-configure \
+ --disable-manualupdatecheck \
+ --disable-autoupdatecheck \
+ --with-pugixml=builtin \
+ --with-wx-config="${_arch}-wx-config --static=no"
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_name}/build-${_arch}"
+ export PATH="/usr/${_arch}/bin:${PATH}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-all "${pkgdir}"/usr/${_arch}/bin/*.exe
+ #${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ #${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ rm -r "${pkgdir}/usr/${_arch}/share/"{icons,man,appdata,applications,pixmaps}
+ done
+}