summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2022-07-18 00:10:10 +1200
committerVaporeon2022-07-18 00:10:10 +1200
commit5e210e62e3df7f9b87775b2295f753a8f5cf5a5f (patch)
tree3ef7bfaa3105a2cc3346d1cfd334ab45e7ebaabb
parent1a90225bca8195fcb3a244a1724fd041f5e484ea (diff)
downloadaur-5e210e62e3df7f9b87775b2295f753a8f5cf5a5f.tar.gz
Update package to match other cmake mingw packages. No bump as output has not changed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d6384984820..a0fc9e2e26ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,9 @@ pkgbase = mingw-w64-flac
makedepends = ninja
depends = mingw-w64-libogg
depends = mingw-w64-crt
- options = !strip
- options = !buildflags
options = staticlibs
+ options = !buildflags
+ options = !strip
source = https://github.com/xiph/flac/releases/download/1.3.4/flac-1.3.4.tar.xz
sha256sums = 8ff0607e75a322dd7cd6ec48f4f225471404ae2730d0ea945127b1355155e737
diff --git a/PKGBUILD b/PKGBUILD
index f3a669ce2e03..cad0647fd180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ pkgname=mingw-w64-flac
pkgver=1.3.4
pkgrel=1
pkgdesc="Free Lossless Audio Codec (mingw-w64)"
-arch=('any')
url="http://flac.sourceforge.net/"
+arch=('any')
license=('BSD' 'GPL')
depends=('mingw-w64-libogg' 'mingw-w64-crt')
makedepends=('mingw-w64-cmake' 'ninja')
-options=(!strip !buildflags staticlibs)
+options=('staticlibs' '!buildflags' '!strip')
source=("https://github.com/xiph/flac/releases/download/${pkgver}/flac-${pkgver}.tar.xz")
sha256sums=('8ff0607e75a322dd7cd6ec48f4f225471404ae2730d0ea945127b1355155e737')
@@ -19,7 +19,7 @@ _pkgname="flac"
build() {
for _arch in ${_architectures}; do
- ${_arch}-cmake -S flac-${pkgver} -B ${_arch}-static -G Ninja \
+ ${_arch}-cmake -S ${_pkgname}-${pkgver} -B build/${_arch}-static -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
-DBUILD_SHARED_LIBS=OFF \
@@ -32,7 +32,7 @@ build() {
-DINSTALL_MANPAGES=OFF \
-DNDEBUG=ON
- ${_arch}-cmake -S flac-${pkgver} -B ${_arch} -G Ninja \
+ ${_arch}-cmake -S ${_pkgname}-${pkgver} -B build/${_arch} -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
-DBUILD_SHARED_LIBS=ON \
@@ -45,18 +45,16 @@ build() {
-DINSTALL_MANPAGES=OFF \
-DNDEBUG=ON
- cmake --build ${_arch}-static
- cmake --build ${_arch}
+ cmake --build build/${_arch}-static
+ cmake --build build/${_arch}
done
}
package() {
for _arch in ${_architectures}; do
- # Rather than do a separate static install, we install the shared libs over top of the static libs in the same prefix.
- # This is bad, but most AUR mingw packages do this and this is how 'mingw-w64-flac' was previously packaged.
- DESTDIR="${pkgdir}" cmake --install ${_arch}-static
- DESTDIR="${pkgdir}" cmake --install ${_arch}
- install -Dm644 flac-${pkgver}/src/*/*.m4 -t "${pkgdir}/usr/${_arch}/share/aclocal"
+ DESTDIR="${pkgdir}" cmake --install build/${_arch}-static
+ DESTDIR="${pkgdir}" cmake --install build/${_arch}
+ install -Dm644 ${_pkgname}-${pkgver}/src/*/*.m4 -t "${pkgdir}/usr/${_arch}/share/aclocal"
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done