summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-05-31 15:48:26 -0700
committerSchala2017-05-31 15:48:26 -0700
commit2aeb8755b447b400cc8f9484e88311a01919ef7c (patch)
treec6bbeed8455eb8a4916f5dcff6e20e7d7778d89a
parent446b3e7b5844e90c56cb4d2cd3556e70ed4ead7c (diff)
downloadaur-2aeb8755b447b400cc8f9484e88311a01919ef7c.tar.gz
2.12.3
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD29
3 files changed, 31 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0de5c80b362d..bac71f544378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,27 @@
# Generated by mksrcinfo v8
-# Thu Aug 18 01:37:01 UTC 2016
+# Wed May 31 22:48:06 UTC 2017
pkgbase = mingw-w64-fontconfig
pkgdesc = A library for configuring and customizing font access (mingw-w64)
- pkgver = 2.12.1
- pkgrel = 2
- url = http://www.fontconfig.org/release
+ pkgver = 2.12.3
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
arch = any
license = custom
makedepends = mingw-w64-configure
+ makedepends = git
+ makedepends = autoconf-archive
+ makedepends = gperf
+ makedepends = python-lxml
+ makedepends = python-six
depends = mingw-w64-expat
depends = mingw-w64-freetype2
options = staticlibs
options = !strip
options = !buildflags
- source = http://www.fontconfig.org/release/fontconfig-2.12.1.tar.bz2
+ source = git+https://anongit.freedesktop.org/git/fontconfig#commit=690f822a1b26b089d86e9843746cab80f3c07fe3
source = 0001-fix-config-linking.all.patch
source = 0007-pkgconfig.mingw.patch
- sha256sums = b449a3e10c47e1d1c7a6ec6e2016cca73d3bd68fbbd4f0ae5cc6b573f7d6c7f3
+ sha256sums = SKIP
sha256sums = 1266d4bbd8270f013fee2401c890f0251babf50a175a69d681d3a6af5003c899
sha256sums = af373531873da46d0356305da5444c1ec74f443cd2635ea2db6b7dadd1561f5b
diff --git a/.gitignore b/.gitignore
index 886033bef767..e64be69b789d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+fontconfig/
pkg/
src/
*.bz2
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 76599ceb8bd4..d11641afbbd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,43 @@
pkgname=mingw-w64-fontconfig
-pkgver=2.12.1
-pkgrel=2
+pkgver=2.12.3
+pkgrel=1
+_commit=690f822a1b26b089d86e9843746cab80f3c07fe3 # tags/2.12.3^0
pkgdesc="A library for configuring and customizing font access (mingw-w64)"
arch=(any)
-url="http://www.fontconfig.org/release"
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
license=("custom")
-makedepends=(mingw-w64-configure)
+makedepends=(mingw-w64-configure git autoconf-archive gperf python-lxml python-six)
depends=(mingw-w64-expat mingw-w64-freetype2)
options=(staticlibs !strip !buildflags)
-source=("http://www.fontconfig.org/release/fontconfig-$pkgver.tar.bz2"
+source=("git+https://anongit.freedesktop.org/git/fontconfig#commit=$_commit"
"0001-fix-config-linking.all.patch"
"0007-pkgconfig.mingw.patch")
-sha256sums=('b449a3e10c47e1d1c7a6ec6e2016cca73d3bd68fbbd4f0ae5cc6b573f7d6c7f3'
+sha256sums=('SKIP'
'1266d4bbd8270f013fee2401c890f0251babf50a175a69d681d3a6af5003c899'
'af373531873da46d0356305da5444c1ec74f443cd2635ea2db6b7dadd1561f5b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd fontconfig
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
- cd fontconfig-$pkgver
+ cd fontconfig
patch -p1 -i ${srcdir}/0001-fix-config-linking.all.patch
patch -p1 -i ${srcdir}/0007-pkgconfig.mingw.patch
- autoreconf -fi
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd fontconfig-$pkgver
+ cd fontconfig
for _arch in ${_architectures}; do
unset LDFLAGS
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
- --with-arch=${_arch%-w64-mingw32}
+ --with-arch=${_arch%-w64-mingw32} \
+ --disable-docs
make
popd
done
@@ -38,7 +45,7 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/fontconfig-${pkgver}/build-${_arch}"
+ cd "${srcdir}/fontconfig/build-${_arch}"
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;