summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-08-31 14:39:34 +0800
committerpingplug2018-08-31 14:39:34 +0800
commitc0c6d105c9fa367e58b887869f878b56554a4e2d (patch)
treee4111469d5ad609e422f2cfbef74ab24aac448c5
parent5b432a6f3f661d3e08e9191bcd0047e14fa91de4 (diff)
downloadaur-c0c6d105c9fa367e58b887869f878b56554a4e2d.tar.gz
Updated to 2.13.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d81278029c..686bdc549242 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-fontconfig
pkgdesc = A library for configuring and customizing font access (mingw-w64)
- pkgver = 2.13.0+17+gc78afa9
+ pkgver = 2.13.1
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fontconfig/
arch = any
@@ -10,13 +10,14 @@ pkgbase = mingw-w64-fontconfig
makedepends = autoconf-archive
makedepends = gperf
makedepends = python-lxml
+ makedepends = json-c
makedepends = python-six
depends = mingw-w64-expat
depends = mingw-w64-freetype2
options = !strip
options = staticlibs
options = !buildflags
- source = git+https://anongit.freedesktop.org/git/fontconfig#commit=c78afa906699933e87889895ca2039887943b639
+ source = git+https://anongit.freedesktop.org/git/fontconfig#commit=844d8709a1f3ecab45015b24b72dd775c13b2421
source = 0007-pkgconfig.mingw.patch
sha256sums = SKIP
sha256sums = af373531873da46d0356305da5444c1ec74f443cd2635ea2db6b7dadd1561f5b
diff --git a/PKGBUILD b/PKGBUILD
index 2a7de56d5f7c..501f7560061f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: pingplug <pingplug@foxmail.com>
# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
-_commit=c78afa906699933e87889895ca2039887943b639 # master~43
+_commit=844d8709a1f3ecab45015b24b72dd775c13b2421 # tags/2.13.1^0
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-fontconfig
-pkgver=2.13.0+17+gc78afa9
+pkgver=2.13.1
pkgrel=1
pkgdesc="A library for configuring and customizing font access (mingw-w64)"
arch=('any')
@@ -18,6 +18,7 @@ makedepends=('mingw-w64-configure'
'autoconf-archive'
'gperf'
'python-lxml'
+ 'json-c'
'python-six')
options=('!strip' 'staticlibs' '!buildflags')
source=("git+https://anongit.freedesktop.org/git/fontconfig#commit=${_commit}"
@@ -33,6 +34,10 @@ pkgver() {
prepare() {
cd fontconfig
patch -p1 -i ${srcdir}/0007-pkgconfig.mingw.patch
+ # do not build buggy test code
+ sed -i /test\\/Makefile/d configure.ac
+ sed -i "s/po-conf test/po-conf/g" Makefile.am
+ rm -r test
NOCONFIGURE=1 ./autogen.sh
}