summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-05-18 16:49:33 -0400
committerAndrew Sun2020-05-18 16:49:33 -0400
commitcab577c506bf8eb05347f40e81d080d239a6f2ae (patch)
tree14e1acc94761a5bc87ae93ae251371070c33d3bf
parent31e6c652f046ef2cda612df1faa584bf004ef2e5 (diff)
downloadaur-cab577c506bf8eb05347f40e81d080d239a6f2ae.tar.gz
remove unnecessary patch
-rw-r--r--.SRCINFO2
-rw-r--r--003-freeglut-3.2.1-install-glut-h.patch20
-rw-r--r--PKGBUILD4
3 files changed, 1 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 602a14d001af..6cd44e3a8e03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,10 +12,8 @@ pkgbase = mingw-w64-freeglut
options = !buildflags
options = staticlibs
source = https://downloads.sourceforge.net/freeglut/freeglut-3.2.1.tar.gz
- source = 003-freeglut-3.2.1-install-glut-h.patch
source = gcc10.patch
sha256sums = d4000e02102acaf259998c870e25214739d1f16f67f99cb35e4f46841399da68
- sha256sums = 0d091fba73641bdc51d28763101452f606c26aed30c9ac1682a19ba9306de8aa
sha256sums = 2d140f9a76f16267699aeb8681da59e43345aaa1e2ff6e82032d711f72f6b66a
pkgname = mingw-w64-freeglut
diff --git a/003-freeglut-3.2.1-install-glut-h.patch b/003-freeglut-3.2.1-install-glut-h.patch
deleted file mode 100644
index 351e4583f756..000000000000
--- a/003-freeglut-3.2.1-install-glut-h.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/CMakeLists.txt 2019-09-25 23:43:34.000000000 +0300
-+++ b/CMakeLists.txt 2019-09-30 21:10:08.047600000 +0300
-@@ -67,16 +67,12 @@
-
-
- SET(FREEGLUT_HEADERS
-+ include/GL/glut.h
- include/GL/freeglut.h
- include/GL/freeglut_ucall.h
- include/GL/freeglut_ext.h
- include/GL/freeglut_std.h
- )
--IF(FREEGLUT_REPLACE_GLUT)
-- LIST(APPEND FREEGLUT_HEADERS
-- include/GL/glut.h
-- )
--ENDIF()
- SET(FREEGLUT_SRCS
- ${FREEGLUT_HEADERS}
- src/fg_callbacks.c
diff --git a/PKGBUILD b/PKGBUILD
index 6153733579c9..491f1b4b53c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,8 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
source=("https://downloads.sourceforge.net/freeglut/freeglut-${pkgver}.tar.gz"
- '003-freeglut-3.2.1-install-glut-h.patch'
'gcc10.patch')
sha256sums=('d4000e02102acaf259998c870e25214739d1f16f67f99cb35e4f46841399da68'
- '0d091fba73641bdc51d28763101452f606c26aed30c9ac1682a19ba9306de8aa'
'2d140f9a76f16267699aeb8681da59e43345aaa1e2ff6e82032d711f72f6b66a')
noextract=("freeglut-${pkgver}.tar.gz")
@@ -25,7 +23,6 @@ prepare() {
[[ -d ${srcdir}/freeglut-${pkgver} ]] && rm -rf ${srcdir}/freeglut-${pkgver}
tar -xzvf ${srcdir}/freeglut-${pkgver}.tar.gz -C ${srcdir}
cd "${srcdir}/freeglut-${pkgver}"
- patch -Np1 -i "${srcdir}/003-freeglut-3.2.1-install-glut-h.patch"
patch -Np1 -i "${srcdir}/gcc10.patch"
}
@@ -35,6 +32,7 @@ build() {
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
-DFREEGLUT_BUILD_DEMOS=OFF \
+ -FREEGLUT_REPLACE_GLUT=ON \
..
make
popd