summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-01-07 14:51:59 +0100
committerMartchus2023-01-07 14:54:09 +0100
commit5b6f5667cf36eb96b48e90f7596499ba193724d5 (patch)
treec6c01d2e7fa0a86d8c1889c3f9e816e22131c4a9
parent21f8bb336e2675064891cdd0917f1d6ee6f18ccd (diff)
downloadaur-5b6f5667cf36eb96b48e90f7596499ba193724d5.tar.gz
Improve provides/conflicts/replaces and bootstrapping
* Simplify provides/conflicts/replaces * Remove reference to mingw-w64-freetype which should be long gone * Remove "replaces"; in some use cases one might rather stick with the bootstrap version * Explicitly enable/disable harfbuzz so the bootstrap version won't accidentally depend on it if it is installed in the build environment
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16f82cdcecd6..043a3bf9f965 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-freetype2
pkgdesc = Font rasterization library (mingw-w64)
pkgver = 2.12.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.freetype.org/
arch = any
license = GPL
@@ -12,12 +12,8 @@ pkgbase = mingw-w64-freetype2
depends = mingw-w64-bzip2
depends = mingw-w64-brotli
depends = mingw-w64-harfbuzz
- provides = mingw-w64-freetype
provides = mingw-w64-freetype2-bootstrap
- conflicts = mingw-w64-freetype
conflicts = mingw-w64-freetype2-bootstrap
- replaces = mingw-w64-freetype
- replaces = mingw-w64-freetype2-bootstrap
options = !strip
options = !buildflags
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index f150a19d37eb..0ad0c7b91e3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,13 @@
pkgname=mingw-w64-freetype2
pkgver=2.12.1
-pkgrel=2
+pkgrel=3
pkgdesc='Font rasterization library (mingw-w64)'
arch=('any')
url='https://www.freetype.org/'
license=('GPL')
depends=(mingw-w64-crt mingw-w64-zlib mingw-w64-bzip2 mingw-w64-brotli)
makedepends=(mingw-w64-gcc mingw-w64-meson)
-provides=(mingw-w64-freetype)
-replaces=(mingw-w64-freetype)
-conflicts=(mingw-w64-freetype)
options=(!strip !buildflags !libtool staticlibs)
source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-$pkgver.tar.xz{,.sig}
0001-Enable-table-validation-modules.patch
@@ -30,13 +27,12 @@ sha256sums=('4766f20157cc4cf0cd292f80bf917f92d1c439b243ac3018debf6b9140c41a7f'
validpgpkeys=(E30674707856409FF1948010BE6C3AAC63AD8E3F) # Werner Lemberg <wl@gnu.org>
if [[ $pkgname = 'mingw-w64-freetype2-bootstrap' ]]; then
- _provides=${pkgname%-bootstrap}
+ _provides=(${pkgname%-bootstrap})
else
- _provides=${pkgname}-bootstrap
+ _provides=(${pkgname}-bootstrap)
# adding harfbuzz for improved OpenType features auto-hinting
# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
depends+=(mingw-w64-harfbuzz)
- replaces+=(${_provides})
fi
provides+=(${_provides})
conflicts+=(${_provides})
@@ -53,10 +49,12 @@ prepare() {
}
build() {
+ local harfbuzz_support=enabled
+ [[ $pkgname = 'mingw-w64-freetype2-bootstrap' ]] && harfbuzz_support=disabled
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/freetype-${pkgver}/build-${_arch}"
cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
- ${_arch}-meson --default-library both -D zlib=enabled -D bzip2=enabled -D png=disabled -D brotli=enabled -D b_lto=false
+ ${_arch}-meson --default-library both -D zlib=enabled -D bzip2=enabled -D png=disabled -D harfbuzz="$harfbuzz_support" -D brotli=enabled -D b_lto=false
ninja
done
}