summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-01-01 19:13:01 +0100
committerMartchus2016-01-01 19:13:01 +0100
commitdf7b9b41156781f67bfaf1c779413300b9b34a54 (patch)
tree18bd7ccaff86ca4c7b3c4bed7574ba7a46166d8c
parentcfeb8ae4162c8609804d0bba1801d743704f058a (diff)
downloadaur-df7b9b41156781f67bfaf1c779413300b9b34a54.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD50
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98ad1819569b..818873ad60f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Dec 23 23:47:43 UTC 2015
+# Fri Jan 1 18:11:23 UTC 2016
pkgbase = mingw-w64-freetype2-bootstrap
pkgdesc = TrueType font rendering library (mingw-w64 bootstrap)
pkgver = 2.6.2
diff --git a/PKGBUILD b/PKGBUILD
index 694ef37524a1..355c9d08056c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martchus <martchus@gmx.net>
pkgname=mingw-w64-freetype2-bootstrap
pkgver=2.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="TrueType font rendering library (mingw-w64 bootstrap)"
arch=('any')
url="http://www.freetype.org/"
@@ -10,8 +10,8 @@ license=('GPL')
# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
depends=(mingw-w64-crt mingw-w64-zlib mingw-w64-bzip2)
makedepends=(mingw-w64-gcc mingw-w64-configure)
-provides=(${pkgname%-bootstrap})
-conflicts=(${pkgname%-bootstrap})
+provides=(mingw-w64-freetype ${pkgname%-bootstrap})
+conflicts=(mingw-w64-freetype ${pkgname%-bootstrap})
source=(http://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.bz2{,.sig}
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
@@ -29,33 +29,33 @@ validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/freetype-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
- patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
+ cd "${srcdir}/freetype-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
+ patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
- # https://bugs.archlinux.org/task/35274
- patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
- # Provide a way to enable the above patch at runtime.
- # Hopefully just a temporary measure until fontconfig picks up
- # the necessary configurables.
- patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
+ # https://bugs.archlinux.org/task/35274
+ patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
+ # Provide a way to enable the above patch at runtime.
+ # Hopefully just a temporary measure until fontconfig picks up
+ # the necessary configurables.
+ patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
}
build() {
- for _arch in ${_architectures}; do
- mkdir -p "${srcdir}/freetype-${pkgver}/build-${_arch}"
- cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
- ${_arch}-configure --with-zlib=/usr/${_arch} --without-png
- make
- done
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ ${_arch}-configure --with-zlib=/usr/${_arch} --without-png
+ make
+ done
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/${_arch}/share/"
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- done
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/${_arch}/share/"
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
}