summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4shadoww2018-03-21 23:03:49 +0200
committer4shadoww2018-03-21 23:03:49 +0200
commit95648a32eb5766f9e53e57e119de04c06205d78f (patch)
tree1a4bfd186b08e478a80d8bdb9d63957ad84f85d7
downloadaur-95648a32eb5766f9e53e57e119de04c06205d78f.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD21
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2588b995e5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mingw-w64-gcc-bin
+ pkgdesc = Cross GCC for the MinGW-w64 cross-compiler (pre-compiled)
+ pkgver = 7.3.0
+ pkgrel = 1
+ url = https://gcc.gnu.org/
+ arch = x86_64
+ groups = mingw-w64-toolchain
+ groups = mingw-w64
+ license = GPL
+ depends = zlib
+ depends = libmpc
+ depends = mingw-w64-crt
+ depends = mingw-w64-binutils
+ depends = mingw-w64-winpthreads
+ depends = mingw-w64-headers
+ provides = mingw-w64-gcc
+ conflicts = mingw-w64-gcc
+ options = !strip
+ options = staticlibs
+ options = !emptydirs
+ options = !buildflags
+ source = https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/mingw-w64-gcc-7.3.0.tar.xz
+ md5sums = 965c28aee8cdda8b5933c5d2d0319c29
+
+pkgname = mingw-w64-gcc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14826bdf65a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Noa-Emil Nissinen <aur dot satella at spamgourmet dot org>
+
+pkgname=mingw-w64-gcc-bin
+pkgver=7.3.0
+pkgrel=1
+pkgdesc="Cross GCC for the MinGW-w64 cross-compiler (pre-compiled)"
+arch=('x86_64')
+url="https://gcc.gnu.org/"
+license=('GPL')
+groups=('mingw-w64-toolchain' 'mingw-w64')
+depends=('zlib' 'libmpc' 'mingw-w64-crt' 'mingw-w64-binutils' 'mingw-w64-winpthreads' 'mingw-w64-headers')
+provides=('mingw-w64-gcc')
+conflicts=('mingw-w64-gcc')
+options=('!strip' 'staticlibs' '!emptydirs' '!buildflags')
+source=("https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/$provides-$pkgver.tar.xz")
+md5sums=('965c28aee8cdda8b5933c5d2d0319c29')
+
+package() {
+ cd "$provides/"
+ cp -r * "$pkgdir/"
+}