summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-08-04 18:27:40 +0200
committerMichel Zou2021-08-04 18:27:40 +0200
commitf543787faf1472893a7f253a46053a1a868a8782 (patch)
tree095ce17c49d23a29f1241c06defa008db18737a4
parent90154e8e9cdd9c112820fd230831c5b256dacb4e (diff)
downloadaur-f543787faf1472893a7f253a46053a1a868a8782.tar.gz
expat
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 741a9cd116b9..d20e9b0bc4c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,6 +20,8 @@ pkgbase = mingw-w64-gdal
depends = mingw-w64-giflib
depends = mingw-w64-libfreexl
depends = mingw-w64-libheif
+ depends = mingw-w64-libwebp
+ depends = mingw-w64-expat
options = !buildflags
options = !strip
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 2ec1b66a4486..0e88d01bd751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="A translator library for raster geospatial data formats (mingw-w64)"
arch=('any')
url="http://www.gdal.org/"
license=('custom')
-depends=('mingw-w64-curl' 'mingw-w64-hdf5' 'mingw-w64-netcdf' 'mingw-w64-libgeotiff' 'mingw-w64-libjpeg' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-sqlite' 'mingw-w64-postgresql' 'mingw-w64-geos' 'mingw-w64-giflib' 'mingw-w64-libfreexl' 'mingw-w64-libheif')
+depends=('mingw-w64-curl' 'mingw-w64-hdf5' 'mingw-w64-netcdf' 'mingw-w64-libgeotiff' 'mingw-w64-libjpeg' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-sqlite' 'mingw-w64-postgresql' 'mingw-w64-geos' 'mingw-w64-giflib' 'mingw-w64-libfreexl' 'mingw-w64-libheif' 'mingw-w64-libwebp' 'mingw-w64-expat')
makedepends=('perl' 'mingw-w64-configure')
options=('!buildflags' '!strip' 'staticlibs')
source=("http://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.gz")
@@ -26,7 +26,7 @@ build() {
sed -i "s|/usr|/usr/${_arch}|g" configure.ac m4/*.m4
autoreconf -vfi
./autogen.sh
- ${_arch}-configure --with-netcdf --with-libtiff --with-sqlite3 --with-geotiff \
+ LDFLAGS="-lssp -lssl -lcrypt32" ${_arch}-configure --with-netcdf --with-libtiff --with-sqlite3 --with-geotiff \
--with-mysql --with-curl --with-hdf5 --with-perl --with-geos \
--with-png --with-poppler --with-spatialite --with-openjpeg \
--without-python --without-perl \
@@ -40,7 +40,7 @@ build() {
package () {
for _arch in ${_architectures}; do
- cd "${srcdir}/gdal-${pkgver}/build-${_arch}"
+ cd "${srcdir}/build-${_arch}"
make DESTDIR="${pkgdir}" install
rm "$pkgdir"/usr/${_arch}/bin/*.exe
rm -rf "$pkgdir"/usr/${_arch}/share