summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault Porteboeuf2015-08-13 08:29:36 +0200
committerThibault Porteboeuf2015-08-13 08:29:36 +0200
commitfffe8cf23c98a24abbea590d3ccd812c650e7ac9 (patch)
tree127b9ef3a1850d0eab4a99b4494661113834ea7b
downloadaur-fffe8cf23c98a24abbea590d3ccd812c650e7ac9.tar.gz
Re-uploaded package from aur-mirror to aur4 + upgraded from 7.7 -> 7.9.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af7c8d09de4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mingw-w64-gdb
+ pkgdesc = The GNU Debugger (mingw-w64)
+ pkgver = 7.9.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/gdb/
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = texinfo
+ makedepends = mingw-w64-expat
+ makedepends = mingw-w64-zlib
+ makedepends = mingw-w64-readline
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = http://ftp.gnu.org/gnu/gdb/gdb-7.9.1.tar.xz
+ md5sums = 35374c77a70884eb430c97061053a36e
+
+pkgname = mingw-w64-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8976656bc9cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=mingw-w64-gdb
+pkgver=7.9.1
+pkgrel=1
+pkgdesc="The GNU Debugger (mingw-w64)"
+arch=(any)
+url="http://www.gnu.org/software/gdb/"
+license=('LGPL')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'texinfo' 'mingw-w64-expat' 'mingw-w64-zlib' 'mingw-w64-readline')
+options=('staticlibs' '!buildflags' '!strip')
+source=("http://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
+md5sums=('35374c77a70884eb430c97061053a36e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/gdb-$pkgver"
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ../configure --prefix=/usr/${_arch} \
+ --host=${_arch} \
+ --target=${_arch} \
+ --enable-lto \
+ --with-system-readline \
+ --with-expat
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/gdb-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ rm -rf "$pkgdir"/usr/${_arch}/share/{man,info,locale}
+ rm -rf "$pkgdir"/usr/${_arch}/lib
+ rm -rf "$pkgdir"/usr/${_arch}/include
+ ${_arch}-strip "$pkgdir"/usr/${_arch}/bin/*.exe
+ done
+}