summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-12-26 09:20:40 -0500
committerAndrew Sun2020-12-26 09:20:40 -0500
commitf1d61e282a64ba95ab914191d28c167f50b20f5b (patch)
treeacc67ad5f1110eb8752556cc24c87ca183a466d5
parent7140f3f77dc1c4fe63ef8eb420fbff08869c1214 (diff)
downloadaur-f1d61e282a64ba95ab914191d28c167f50b20f5b.tar.gz
1.19
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--gdbm-1.15-win32.patch9
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34fcc9a2610d..aceb27cc2040 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-gdbm
pkgdesc = GNU database library (mingw-w64)
- pkgver = 1.18.1
+ pkgver = 1.19
pkgrel = 1
url = http://www.gnu.org/software/gdbm/gdbm.html
arch = any
@@ -12,12 +12,12 @@ pkgbase = mingw-w64-gdbm
options = staticlibs
options = !buildflags
options = !strip
- source = https://ftp.gnu.org/gnu/gdbm/gdbm-1.18.1.tar.gz
- source = https://ftp.gnu.org/gnu/gdbm/gdbm-1.18.1.tar.gz.sig
+ source = https://ftp.gnu.org/gnu/gdbm/gdbm-1.19.tar.gz
+ source = https://ftp.gnu.org/gnu/gdbm/gdbm-1.19.tar.gz.sig
source = gdbm-1.15-win32.patch
- sha256sums = 86e613527e5dba544e73208f42b78b7c022d4fa5a6d5498bf18c8d6f745b91dc
+ sha256sums = 37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc
sha256sums = SKIP
- sha256sums = f6398a1a00839bed53565b6fae857a94ee6d12aaccd2a1e87b35203994a6ecd0
+ sha256sums = 2c3f0ed37482fe874218f4464414b592ebffa8776cca3c20fb0660f0036f4324
pkgname = mingw-w64-gdbm
diff --git a/PKGBUILD b/PKGBUILD
index dc649cfef124..235a818d199c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
-# Contributor: Aleksey Filippov <sarum9in@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Aleksey Filippov <sarum9in at gmail dot com>
# Contributor: xantares <xantares09 at hotmail dot com>
pkgname=mingw-w64-gdbm
-pkgver=1.18.1
+pkgver=1.19
pkgrel=1
pkgdesc="GNU database library (mingw-w64)"
url="http://www.gnu.org/software/gdbm/gdbm.html"
@@ -14,9 +14,9 @@ makedepends=('mingw-w64-configure')
options=('staticlibs' '!buildflags' '!strip')
source=("https://ftp.gnu.org/gnu/gdbm/gdbm-${pkgver}.tar.gz"{,.sig}
'gdbm-1.15-win32.patch')
-sha256sums=('86e613527e5dba544e73208f42b78b7c022d4fa5a6d5498bf18c8d6f745b91dc'
+sha256sums=('37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc'
'SKIP'
- 'f6398a1a00839bed53565b6fae857a94ee6d12aaccd2a1e87b35203994a6ecd0')
+ '2c3f0ed37482fe874218f4464414b592ebffa8776cca3c20fb0660f0036f4324')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/gdbm-1.15-win32.patch b/gdbm-1.15-win32.patch
index 8057b48f675e..b1525b9d0796 100644
--- a/gdbm-1.15-win32.patch
+++ b/gdbm-1.15-win32.patch
@@ -498,15 +498,16 @@ diff -urN gdbm-1.15_orig/src/gdbmopen.c gdbm-1.15/src/gdbmopen.c
diff -urN gdbm-1.15_orig/src/gdbmtool.c gdbm-1.15/src/gdbmtool.c
--- gdbm-1.15_orig/src/gdbmtool.c 2018-06-14 14:53:35.000000000 +0300
+++ gdbm-1.15/src/gdbmtool.c 2018-06-17 20:55:52.053880600 +0300
-@@ -22,8 +22,6 @@
+@@ -22,9 +22,6 @@
#include <errno.h>
#include <ctype.h>
#include <signal.h>
-#include <pwd.h>
-#include <sys/ioctl.h>
- #ifdef HAVE_SYS_TERMIOS_H
- # include <sys/termios.h>
- #endif
+-#include <termios.h>
+ #include <stdarg.h>
+ #ifdef HAVE_LOCALE_H
+ # include <locale.h>
@@ -1993,6 +1995,7 @@
{
istr = instream_file_create (GDBMTOOLRC);