summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hill2019-01-15 11:18:55 -0500
committerDavid Hill2019-01-15 11:18:55 -0500
commitbd1d668cbac754af3755ca81810995ef899cbb16 (patch)
tree280328dad600a3ee2a8250e40914288046bd103f
downloadaur-bd1d668cbac754af3755ca81810995ef899cbb16.tar.gz
Version 0.14.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..380b75f1b59f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-gdcc
+ pkgdesc = Game Data Compiler Collection (mingw-w64)
+ pkgver = 0.14.4
+ pkgrel = 1
+ url = http://github.com/DavidPH/GDCC
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-gmp
+ options = !strip
+ options = !buildflags
+ options = !staticlibs
+ source = mingw-w64-gdcc::git+https://github.com/DavidPH/GDCC.git#tag=v0.14.4
+ sha256sums = SKIP
+
+pkgname = mingw-w64-gdcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27eb76c43e2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: David Hill <davidph55@verizon.net>
+
+pkgname=mingw-w64-gdcc
+pkgver=0.14.4
+pkgrel=1
+pkgdesc="Game Data Compiler Collection (mingw-w64)"
+arch=(any)
+url="http://github.com/DavidPH/GDCC"
+license=('GPL2')
+depends=('mingw-w64-gmp')
+makedepends=('git' 'cmake' 'mingw-w64-cmake')
+options=('!strip' '!buildflags' '!staticlibs')
+source=("${pkgname}"::git+https://github.com/DavidPH/GDCC.git#tag=v"${pkgver}")
+sha256sums=('SKIP')
+
+_arches="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ for _arch in ${_arches}
+ do
+ mkdir -p build-"${_arch}" && pushd build-"${_arch}"
+
+ "${_arch}"-cmake ../"${pkgname}"
+
+ make
+
+ popd
+ done
+}
+
+package()
+{
+ for _arch in ${_arches}
+ do
+ pushd build-"${_arch}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ "${_arch}"-strip -g "${pkgdir}"/usr/"${_arch}"/lib/*.a
+ "${_arch}"-strip --strip-unneeded "${pkgdir}"/usr/"${_arch}"/bin/*.dll
+ "${_arch}"-strip --strip-unneeded "${pkgdir}"/usr/"${_arch}"/bin/*.exe
+ popd
+ done
+}
+
+# EOF
+