summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2013-05-18 11:42:12 +0800
committerTing-Wei Lan2013-05-18 11:42:12 +0800
commit3ae029ce565a86aa349d6e354e23c434f793068c (patch)
tree14c943aca0cffc5439badc27e8f429a8b97a202d
downloadaur-3ae029ce565a86aa349d6e354e23c434f793068c.tar.gz
Initial commit - Import old files
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a84e04a9f87c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mingw-w64-gdk-pixbuf2
+ pkgdesc = An image loading library (mingw-w64)
+ pkgver = 2.28.1
+ pkgrel = 1
+ url = http://www.gtk.org
+ arch = any
+ license = GPL2
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-crt
+ depends = mingw-w64-glib2>=2.34.0
+ depends = mingw-w64-jasper
+ depends = mingw-w64-libpng
+ depends = mingw-w64-libjpeg-turbo
+ depends = mingw-w64-libtiff
+ options = !libtool
+ options = !strip
+ options = !buildflags
+ source = http://download.gnome.org/sources/gdk-pixbuf/2.28/gdk-pixbuf-2.28.1.tar.xz
+ md5sums = 5c71cce316d08c559fc5970aa60754ab
+
+pkgname = mingw-w64-gdk-pixbuf2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a317c9b51927
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mingw-w64-gdk-pixbuf2
+pkgver=2.28.1
+pkgrel=1
+pkgdesc="An image loading library (mingw-w64)"
+arch=(any)
+url="http://www.gtk.org"
+license=("GPL2")
+makedepends=(mingw-w64-gcc mingw-w64-pkg-config)
+depends=(mingw-w64-crt
+'mingw-w64-glib2>=2.34.0'
+mingw-w64-jasper
+mingw-w64-libpng
+mingw-w64-libjpeg-turbo
+mingw-w64-libtiff)
+options=(!libtool !strip !buildflags)
+source=("http://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz")
+md5sums=('5c71cce316d08c559fc5970aa60754ab')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ export CFLAGS="-O2 -pipe -mms-bitfields"
+ export CXXFLAGS="${CFLAGS}"
+ export CXX=$_arch-g++
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ ${srcdir}/gdk-pixbuf-${pkgver}/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --with-included-loaders=wbmp,png,pnm,ras,ani,xpm,xbm,tga,icns,pcx,qtif,gdip-ico,gdip-wmf,gdip-emf,gdip-bmp,gdip-gif,gdip-jpeg,gdip-tiff
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}