diff options
author | Ting-Wei Lan | 2018-04-29 21:20:32 +0800 |
---|---|---|
committer | Ting-Wei Lan | 2018-04-29 21:20:32 +0800 |
commit | f3e92f5c0f60d696c3e291c583cc1cfd8211ca48 (patch) | |
tree | 9c481aa78465c1f2ef1912c6dccc64742753f598 | |
parent | e68c5015e695c77acd0706a4ab6a0ad4b23218a6 (diff) | |
download | aur-f3e92f5c0f60d696c3e291c583cc1cfd8211ca48.tar.gz |
mingw-w64-{gdk-pixbuf2,gtk{2,3}}: Quote variables and avoid xargs
-rw-r--r-- | PKGBUILD | 18 |
1 files changed, 9 insertions, 9 deletions
@@ -2,7 +2,7 @@ pkgname=mingw-w64-gdk-pixbuf2 pkgver=2.36.12 pkgrel=1 pkgdesc='An image loading library (mingw-w64)' -arch=(any) +arch=('any') url='http://www.gtk.org' license=('LGPL') makedepends=( @@ -17,19 +17,19 @@ depends=( 'mingw-w64-libpng' 'mingw-w64-libjpeg-turbo' 'mingw-w64-libtiff') -options=(!strip !buildflags staticlibs) +options=('!strip' '!buildflags' 'staticlibs') source=( "https://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz") sha256sums=('fff85cf48223ab60e3c3c8318e2087131b590fd6f1737e42cb3759a3b427a334') -_architectures="i686-w64-mingw32 x86_64-w64-mingw32" +_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32') build() { cd "${srcdir}/gdk-pixbuf-${pkgver}" - for _arch in ${_architectures}; do + for _arch in "${_architectures[@]}"; do mkdir -p "build-${_arch}" cd "build-${_arch}" - ${_arch}-configure \ + "${_arch}-configure" \ --enable-relocations \ --with-included-loaders \ --with-libjasper @@ -42,12 +42,12 @@ build() { package() { cd "${srcdir}/gdk-pixbuf-${pkgver}" - for _arch in ${_architectures}; do + for _arch in "${_architectures[@]}"; do cd "build-${_arch}" make DESTDIR="$pkgdir" install - find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtL1 ${_arch}-strip - find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtL1 ${_arch}-strip --strip-unneeded - find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtL1 ${_arch}-strip -g + find "$pkgdir/usr/${_arch}" -name '*.exe' -exec "${_arch}-strip" '{}' ';' + find "$pkgdir/usr/${_arch}" -name '*.dll' -exec "${_arch}-strip" --strip-unneeded '{}' ';' + find "$pkgdir/usr/${_arch}" '(' -name '*.a' -o -name '*.dll' ')' -exec "${_arch}-strip" -g '{}' ';' rm -r "$pkgdir/usr/${_arch}/share/man" cd .. done |