summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2020-05-17 08:32:49 +0100
committerAlexandros Theodotou2020-05-17 08:32:49 +0100
commit403b69692cbcd6d7e6fe92eca9e015a74296c773 (patch)
tree709c112029822913b12127420893ba4b54ecf19d
downloadaur-403b69692cbcd6d7e6fe92eca9e015a74296c773.tar.gz
add package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e90ace598b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mingw-w64-gdk-pixbuf2-bin
+ pkgdesc = A text widget adding syntax highlighting and more to GNOME (mingw-w64)
+ pkgver = 4.6.0
+ pkgrel = 1
+ url = https://www.gnome.org
+ arch = any
+ license = custom
+ depends = mingw-w64-crt
+ provides = mingw-w64-gdk-pixbuf2
+ source = http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-gdk-pixbuf2-2.40.0-1-any.pkg.tar.xz
+ sha256sums = SKIP
+
+pkgname = mingw-w64-gdk-pixbuf2-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83ca5038d4dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+mingw*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6005894ce3e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=mingw-w64-gdk-pixbuf2-bin
+pkgver=4.6.0
+pkgrel=1
+pkgdesc="A text widget adding syntax highlighting and more to GNOME (mingw-w64)"
+arch=('any')
+url="https://www.gnome.org"
+license=('custom')
+depends=('mingw-w64-crt')
+provides=('mingw-w64-gdk-pixbuf2')
+source=("http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-gdk-pixbuf2-2.40.0-1-any.pkg.tar.xz")
+sha256sums=('SKIP')
+
+_architectures="x86_64-w64-mingw32"
+
+package() {
+ cd "${srcdir}/mingw64"
+ for _arch in ${_architectures}; do
+ mkdir -p ./* $pkgdir/usr/${_arch}/
+ sed -i -e "s|/mingw64|/usr/${_arch}|" ./lib/pkgconfig/*
+ cp -r ./* $pkgdir/usr/${_arch}/
+ done
+}