summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-10-24 09:25:49 -0400
committerAndrew Sun2019-10-24 09:25:49 -0400
commit086f47e54f3b42c458544f03c8a3984ec9be0fdb (patch)
tree64cd5f4b3e8e84f3e949addfa6ebab0f8665afc5
parent2488a3e949073aa503fe19a9796ffeed4041a0e3 (diff)
downloadaur-086f47e54f3b42c458544f03c8a3984ec9be0fdb.tar.gz
3.8.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--geos-3.5.0.patch101
3 files changed, 7 insertions, 117 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 027d2b01d361..0246e6302bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-geos
pkgdesc = C++ port of the Java Topology Suite (mingw-w64)
- pkgver = 3.7.2
+ pkgver = 3.8.0
pkgrel = 1
url = https://trac.osgeo.org/geos/
arch = any
@@ -11,10 +11,8 @@ pkgbase = mingw-w64-geos
options = !buildflags
options = !strip
options = staticlibs
- source = https://download.osgeo.org/geos/geos-3.7.2.tar.bz2
- source = geos-3.5.0.patch
- sha256sums = 2166e65be6d612317115bfec07827c11b403c3f303e0a7420a2106bc999d7707
- sha256sums = 206f8780b8da547d3fd1bbc3ffb827abc71ec0e5d90a217db2032fe481807992
+ source = https://download.osgeo.org/geos/geos-3.8.0.tar.bz2
+ sha256sums = 99114c3dc95df31757f44d2afde73e61b9f742f0b683fd1894cbbee05dda62d5
pkgname = mingw-w64-geos
diff --git a/PKGBUILD b/PKGBUILD
index a5ddb06b1018..4ff6686d1d97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701 at gmail dot com>
pkgname=mingw-w64-geos
-pkgver=3.7.2
+pkgver=3.8.0
pkgrel=1
pkgdesc="C++ port of the Java Topology Suite (mingw-w64)"
arch=('any')
@@ -10,24 +10,17 @@ license=('LGPL')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!emptydirs' '!buildflags' '!strip' 'staticlibs')
-source=("https://download.osgeo.org/geos/geos-${pkgver}.tar.bz2"
- "geos-3.5.0.patch")
-sha256sums=('2166e65be6d612317115bfec07827c11b403c3f303e0a7420a2106bc999d7707'
- '206f8780b8da547d3fd1bbc3ffb827abc71ec0e5d90a217db2032fe481807992')
+source=("https://download.osgeo.org/geos/geos-${pkgver}.tar.bz2")
+sha256sums=('99114c3dc95df31757f44d2afde73e61b9f742f0b683fd1894cbbee05dda62d5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/geos-${pkgver}"
- patch -Np1 -i "${srcdir}/geos-3.5.0.patch"
-}
-
build() {
cd "${srcdir}/geos-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
- -DGEOS_ENABLE_INLINE=OFF \
+ -DDISABLE_GEOS_INLINE=ON \
..
make
popd
diff --git a/geos-3.5.0.patch b/geos-3.5.0.patch
deleted file mode 100644
index c873b5a7fa63..000000000000
--- a/geos-3.5.0.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-diff -Naur geos-3.6.2.orig/CMakeLists.txt geos-3.6.2/CMakeLists.txt
---- geos-3.6.2.orig/CMakeLists.txt 2018-05-23 19:46:15.542316000 -0400
-+++ geos-3.6.2/CMakeLists.txt 2018-05-23 20:36:33.943193000 -0400
-@@ -116,7 +116,7 @@
- "Forcing IEEE 754 using flag -ffloat-store - ${GEOS_ENABLE_FLOATSTORE}")
-
- # Warnings specification
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -fno-implicit-inline-templates -Wconversion -pedantic -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
-+ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -fno-implicit-inline-templates -Wconversion -pedantic -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
-
- # Turn on Position Independent Code generation for GEOS C shared library
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC -Wall -Wconversion -pedantic -Wmissing-prototypes -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
-@@ -191,7 +191,10 @@
- include(CheckPrototypeExists)
- include(CheckSymbolExists)
-
--check_prototype_exists(isnan cmath HAVE_STD_ISNAN)
-+check_cxx_source_compiles(
-+ "#include <cmath>
-+ int main() { double x=0.1; return std::isnan(x)?1:0; }"
-+ HAVE_STD_ISNAN)
- if(NOT HAVE_STD_ISNAN)
- if(MSVC)
- check_prototype_exists(_isnan float.h HAVE_ISNAN)
-@@ -205,7 +208,10 @@
- endif()
- endif()
-
--check_prototype_exists(isfinite cmath HAVE_STD_ISFINITE)
-+check_cxx_source_compiles(
-+ "#include <cmath>
-+ int main() { double x=0.1; return std::isfinite(x)?1:0; }"
-+ HAVE_STD_ISFINITE)
-
- if(NOT HAVE_STD_ISFINITE)
- if(MSVC)
-@@ -347,7 +353,7 @@
- DESTINATION "${PROJECT_BINARY_DIR}")
- endif()
-
--include(GenerateSourceGroups)
-+#include(GenerateSourceGroups)
-
- # Enable target debugging for CMake Tools in Visual Studio Code
- # https://github.com/vector-of-bool/vscode-cmake-tools
-diff -Naur geos-3.6.2.orig/include/CMakeLists.txt geos-3.6.2/include/CMakeLists.txt
---- geos-3.6.2.orig/include/CMakeLists.txt 2018-05-23 19:46:15.521315800 -0400
-+++ geos-3.6.2/include/CMakeLists.txt 2018-05-23 20:37:32.614369700 -0400
-@@ -54,4 +54,4 @@
- #################################################################################
- # Group source files for IDE source explorers (e.g. Visual Studio)
- #################################################################################
--GenerateSourceGroups(include)
-+#GenerateSourceGroups(include)
-diff -Naur geos-3.6.2.orig/src/CMakeLists.txt geos-3.6.2/src/CMakeLists.txt
---- geos-3.6.2.orig/src/CMakeLists.txt 2018-05-23 19:46:15.848312300 -0400
-+++ geos-3.6.2/src/CMakeLists.txt 2018-05-23 20:37:52.022699800 -0400
-@@ -105,4 +105,4 @@
- #################################################################################
- # Group source files for IDE source explorers (e.g. Visual Studio)
- #################################################################################
--GenerateSourceGroups(src)
-+#GenerateSourceGroups(src)
-diff -Naur geos-3.6.2.orig/tests/unit/CMakeLists.txt geos-3.6.2/tests/unit/CMakeLists.txt
---- geos-3.6.2.orig/tests/unit/CMakeLists.txt 2018-05-23 19:46:14.736324600 -0400
-+++ geos-3.6.2/tests/unit/CMakeLists.txt 2018-05-23 20:38:21.110716300 -0400
-@@ -38,4 +38,4 @@
- #################################################################################
- # Group source files for IDE source explorers (e.g. Visual Studio)
- #################################################################################
--GenerateSourceGroups(tests/unit)
-+#GenerateSourceGroups(tests/unit)
---- geos-3.7.0/include/geos/platform.h.cmake.orig 2018-11-03 11:54:44.643131100 +0300
-+++ geos-3.7.0/include/geos/platform.h.cmake 2018-11-03 11:57:49.714716600 +0300
-@@ -31,6 +31,9 @@
-
- /* Set to 1 if you have ieeefp.h */
- #cmakedefine HAVE_IEEEFP_H 1
-+
-+#cmakedefine HAVE_STD_ISFINITE 1
-+#cmakedefine HAVE_STD_ISNAN 1
-
- #ifdef _MSC_VER
- # define _USE_MATH_DEFINES
-@@ -66,10 +66,14 @@
- # endif
- #else
- # include <ieeefp.h>
--# ifndef FINITE
-+# if defined(HAVE_STD_ISFINITE)
-+# define FINITE(x) std::isfinite(x)
-+# elif !defined(FINITE)
- # define FINITE(x) finite(x)
- # endif
--# ifndef ISNAN
-+# if defined(HAVE_STD_ISNAN)
-+# define ISNAN(x) std::isnan(x)
-+# elif !defined(ISNAN)
- # define ISNAN(x) isnan(x)
- # endif
- #endif