summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-07-31 13:49:12 -0400
committerAndrew Sun2018-07-31 13:49:12 -0400
commit2533b041cffc1a9e79f00747c8d1773a0f89c9fc (patch)
treef0ee5760c44d4f3fc08e9a027fe89303e61d134e
parent254db37e422b271e7c9dcf3250cac9303600d945 (diff)
downloadaur-2533b041cffc1a9e79f00747c8d1773a0f89c9fc.tar.gz
mingw-w64-geos: update to 3.6.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
-rw-r--r--geos-3.5.0.patch74
3 files changed, 99 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ae49e29c202..c155ac04502b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
-# Generated by mksrcinfo v8
-# Fri Apr 7 21:18:26 UTC 2017
pkgbase = mingw-w64-geos
pkgdesc = C++ port of the Java Topology Suite (mingw-w64)
- pkgver = 3.5.0
+ pkgver = 3.6.2
pkgrel = 1
url = http://trac.osgeo.org/geos/
arch = any
license = LGPL
- makedepends = mingw-w64-configure
+ makedepends = mingw-w64-cmake
depends = mingw-w64-crt
+ options = !emptydirs
options = !buildflags
options = !strip
options = staticlibs
- source = http://download.osgeo.org/geos/geos-3.5.0.tar.bz2
- sha256sums = 49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02
+ source = http://download.osgeo.org/geos/geos-3.6.2.tar.bz2
+ source = geos-3.5.0.patch
+ sha256sums = 045a13df84d605a866602f6020fc6cbf8bf4c42fb50de237a08926e1d7d7652a
+ sha256sums = 778ea9e73e343396c761e66a67c87b2054a33be629fa94a6243f7bdd7ab68346
pkgname = mingw-w64-geos
diff --git a/PKGBUILD b/PKGBUILD
index d6ede3313b75..ebe182fb090b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,34 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com
+
pkgname=mingw-w64-geos
-pkgver=3.5.0
+pkgver=3.6.2
pkgrel=1
pkgdesc="C++ port of the Java Topology Suite (mingw-w64)"
arch=('any')
url="http://trac.osgeo.org/geos/"
license=('LGPL')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-configure')
-options=('!buildflags' '!strip' 'staticlibs')
-source=("http://download.osgeo.org/geos/geos-$pkgver.tar.bz2")
-sha256sums=('49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02')
+makedepends=('mingw-w64-cmake')
+options=('!emptydirs' '!buildflags' '!strip' 'staticlibs')
+source=("http://download.osgeo.org/geos/geos-${pkgver}.tar.bz2"
+ "geos-3.5.0.patch")
+sha256sums=('045a13df84d605a866602f6020fc6cbf8bf4c42fb50de237a08926e1d7d7652a'
+ '778ea9e73e343396c761e66a67c87b2054a33be629fa94a6243f7bdd7ab68346')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/geos-${pkgver}"
+ patch -Np1 -i "${srcdir}/geos-3.5.0.patch"
+}
+
build() {
- cd ${srcdir}/geos-$pkgver
+ cd "${srcdir}/geos-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure
+ ${_arch}-cmake \
+ -DGEOS_ENABLE_INLINE=OFF \
+ ..
make
popd
done
diff --git a/geos-3.5.0.patch b/geos-3.5.0.patch
new file mode 100644
index 000000000000..fa6485ed85f1
--- /dev/null
+++ b/geos-3.5.0.patch
@@ -0,0 +1,74 @@
+diff -Naur geos-3.6.2.orig/CMakeLists.txt geos-3.6.2/CMakeLists.txt
+--- geos-3.6.2.orig/CMakeLists.txt 2018-05-23 19:46:15.542316000 -0400
++++ geos-3.6.2/CMakeLists.txt 2018-05-23 20:36:33.943193000 -0400
+@@ -116,7 +116,7 @@
+ "Forcing IEEE 754 using flag -ffloat-store - ${GEOS_ENABLE_FLOATSTORE}")
+
+ # Warnings specification
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long")
++ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long")
+
+ # Turn on Position Independent Code generation for GEOS C shared library
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+@@ -191,7 +191,10 @@
+ include(CheckPrototypeExists)
+ include(CheckSymbolExists)
+
+-check_prototype_exists(isnan cmath HAVE_STD_ISNAN)
++check_cxx_source_compiles(
++ "#include <cmath>
++ int main() { double x=0.1; return std::isnan(x)?1:0; }"
++ HAVE_STD_ISNAN)
+ if(NOT HAVE_STD_ISNAN)
+ if(MSVC)
+ check_prototype_exists(_isnan float.h HAVE_ISNAN)
+@@ -205,7 +208,10 @@
+ endif()
+ endif()
+
+-check_prototype_exists(isfinite cmath HAVE_STD_ISFINITE)
++check_cxx_source_compiles(
++ "#include <cmath>
++ int main() { double x=0.1; return std::isfinite(x)?1:0; }"
++ HAVE_STD_ISFINITE)
+
+ if(NOT HAVE_STD_ISFINITE)
+ if(MSVC)
+@@ -347,7 +353,7 @@
+ #################################################################################
+ # Configure subdirectories
+ #################################################################################
+-include(GenerateSourceGroups)
++#include(GenerateSourceGroups)
+
+ add_subdirectory(include)
+ add_subdirectory(src)
+diff -Naur geos-3.6.2.orig/include/CMakeLists.txt geos-3.6.2/include/CMakeLists.txt
+--- geos-3.6.2.orig/include/CMakeLists.txt 2018-05-23 19:46:15.521315800 -0400
++++ geos-3.6.2/include/CMakeLists.txt 2018-05-23 20:37:32.614369700 -0400
+@@ -54,4 +54,4 @@
+ #################################################################################
+ # Group source files for IDE source explorers (e.g. Visual Studio)
+ #################################################################################
+-GenerateSourceGroups(include)
++#GenerateSourceGroups(include)
+diff -Naur geos-3.6.2.orig/src/CMakeLists.txt geos-3.6.2/src/CMakeLists.txt
+--- geos-3.6.2.orig/src/CMakeLists.txt 2018-05-23 19:46:15.848312300 -0400
++++ geos-3.6.2/src/CMakeLists.txt 2018-05-23 20:37:52.022699800 -0400
+@@ -105,4 +105,4 @@
+ #################################################################################
+ # Group source files for IDE source explorers (e.g. Visual Studio)
+ #################################################################################
+-GenerateSourceGroups(src)
++#GenerateSourceGroups(src)
+diff -Naur geos-3.6.2.orig/tests/unit/CMakeLists.txt geos-3.6.2/tests/unit/CMakeLists.txt
+--- geos-3.6.2.orig/tests/unit/CMakeLists.txt 2018-05-23 19:46:14.736324600 -0400
++++ geos-3.6.2/tests/unit/CMakeLists.txt 2018-05-23 20:38:21.110716300 -0400
+@@ -38,4 +38,4 @@
+ #################################################################################
+ # Group source files for IDE source explorers (e.g. Visual Studio)
+ #################################################################################
+-GenerateSourceGroups(tests/unit)
+\ No newline at end of file
++#GenerateSourceGroups(tests/unit)
+\ No newline at end of file