summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-11-03 15:39:28 -0400
committerAndrew Sun2018-11-03 15:39:28 -0400
commit4980d99878ecf8544ffb42a0e2d21516f80ec966 (patch)
treeffa72906b67b17706449399b07b3a9446b62d8c7
parentad862e0cf0d69561d935538efed92c54ae1ba76a (diff)
downloadaur-4980d99878ecf8544ffb42a0e2d21516f80ec966.tar.gz
mingw-w64-geos: update to 3.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--geos-3.5.0.patch47
3 files changed, 44 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 137f965ed833..9271a1ee9106 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-geos
pkgdesc = C++ port of the Java Topology Suite (mingw-w64)
- pkgver = 3.6.3
+ pkgver = 3.7.0
pkgrel = 1
url = http://trac.osgeo.org/geos/
arch = any
@@ -11,10 +11,10 @@ pkgbase = mingw-w64-geos
options = !buildflags
options = !strip
options = staticlibs
- source = http://download.osgeo.org/geos/geos-3.6.3.tar.bz2
+ source = http://download.osgeo.org/geos/geos-3.7.0.tar.bz2
source = geos-3.5.0.patch
- sha256sums = ab9eaa0a67f7068866ac1e4dbf717b0c49f96254d65e9ce23ed7af1cccbe3e4b
- sha256sums = 778ea9e73e343396c761e66a67c87b2054a33be629fa94a6243f7bdd7ab68346
+ sha256sums = 4fbf41a792fd74293ab59e0a980e8654cd411a9d45416d66eaa12d53d1393fd7
+ sha256sums = 206f8780b8da547d3fd1bbc3ffb827abc71ec0e5d90a217db2032fe481807992
pkgname = mingw-w64-geos
diff --git a/PKGBUILD b/PKGBUILD
index d460dfa97c14..d7f9fa83e6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701@gmail.com
pkgname=mingw-w64-geos
-pkgver=3.6.3
+pkgver=3.7.0
pkgrel=1
pkgdesc="C++ port of the Java Topology Suite (mingw-w64)"
arch=('any')
@@ -12,8 +12,8 @@ makedepends=('mingw-w64-cmake')
options=('!emptydirs' '!buildflags' '!strip' 'staticlibs')
source=("http://download.osgeo.org/geos/geos-${pkgver}.tar.bz2"
"geos-3.5.0.patch")
-sha256sums=('ab9eaa0a67f7068866ac1e4dbf717b0c49f96254d65e9ce23ed7af1cccbe3e4b'
- '778ea9e73e343396c761e66a67c87b2054a33be629fa94a6243f7bdd7ab68346')
+sha256sums=('4fbf41a792fd74293ab59e0a980e8654cd411a9d45416d66eaa12d53d1393fd7'
+ '206f8780b8da547d3fd1bbc3ffb827abc71ec0e5d90a217db2032fe481807992')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/geos-3.5.0.patch b/geos-3.5.0.patch
index fa6485ed85f1..c873b5a7fa63 100644
--- a/geos-3.5.0.patch
+++ b/geos-3.5.0.patch
@@ -5,11 +5,11 @@ diff -Naur geos-3.6.2.orig/CMakeLists.txt geos-3.6.2/CMakeLists.txt
"Forcing IEEE 754 using flag -ffloat-store - ${GEOS_ENABLE_FLOATSTORE}")
# Warnings specification
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long")
-+ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -fno-implicit-inline-templates -Wconversion -pedantic -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
++ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -fno-implicit-inline-templates -Wconversion -pedantic -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
# Turn on Position Independent Code generation for GEOS C shared library
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC -Wall -Wconversion -pedantic -Wmissing-prototypes -W -Wunused -Wuninitialized -Wextra -Wdouble-promotion")
@@ -191,7 +191,10 @@
include(CheckPrototypeExists)
include(CheckSymbolExists)
@@ -35,14 +35,14 @@ diff -Naur geos-3.6.2.orig/CMakeLists.txt geos-3.6.2/CMakeLists.txt
if(NOT HAVE_STD_ISFINITE)
if(MSVC)
@@ -347,7 +353,7 @@
- #################################################################################
- # Configure subdirectories
- #################################################################################
+ DESTINATION "${PROJECT_BINARY_DIR}")
+ endif()
+
-include(GenerateSourceGroups)
+#include(GenerateSourceGroups)
- add_subdirectory(include)
- add_subdirectory(src)
+ # Enable target debugging for CMake Tools in Visual Studio Code
+ # https://github.com/vector-of-bool/vscode-cmake-tools
diff -Naur geos-3.6.2.orig/include/CMakeLists.txt geos-3.6.2/include/CMakeLists.txt
--- geos-3.6.2.orig/include/CMakeLists.txt 2018-05-23 19:46:15.521315800 -0400
+++ geos-3.6.2/include/CMakeLists.txt 2018-05-23 20:37:32.614369700 -0400
@@ -69,6 +69,33 @@ diff -Naur geos-3.6.2.orig/tests/unit/CMakeLists.txt geos-3.6.2/tests/unit/CMake
# Group source files for IDE source explorers (e.g. Visual Studio)
#################################################################################
-GenerateSourceGroups(tests/unit)
-\ No newline at end of file
+#GenerateSourceGroups(tests/unit)
-\ No newline at end of file
+--- geos-3.7.0/include/geos/platform.h.cmake.orig 2018-11-03 11:54:44.643131100 +0300
++++ geos-3.7.0/include/geos/platform.h.cmake 2018-11-03 11:57:49.714716600 +0300
+@@ -31,6 +31,9 @@
+
+ /* Set to 1 if you have ieeefp.h */
+ #cmakedefine HAVE_IEEEFP_H 1
++
++#cmakedefine HAVE_STD_ISFINITE 1
++#cmakedefine HAVE_STD_ISNAN 1
+
+ #ifdef _MSC_VER
+ # define _USE_MATH_DEFINES
+@@ -66,10 +66,14 @@
+ # endif
+ #else
+ # include <ieeefp.h>
+-# ifndef FINITE
++# if defined(HAVE_STD_ISFINITE)
++# define FINITE(x) std::isfinite(x)
++# elif !defined(FINITE)
+ # define FINITE(x) finite(x)
+ # endif
+-# ifndef ISNAN
++# if defined(HAVE_STD_ISNAN)
++# define ISNAN(x) std::isnan(x)
++# elif !defined(ISNAN)
+ # define ISNAN(x) isnan(x)
+ # endif
+ #endif