summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-08-13 12:59:49 +0200
committerMichel Zou2016-08-13 12:59:49 +0200
commit898cdcf8a3d47a05dcdfbb3894e482f71817b4e6 (patch)
tree61ca50c6a71c96e4306f2d361ee154b103c68f75
parent76c3903897b05f512aee3fa0155e60f95f6d9128 (diff)
downloadaur-898cdcf8a3d47a05dcdfbb3894e482f71817b4e6.tar.gz
0.19.8.1
-rw-r--r--.SRCINFO14
-rw-r--r--00-relocatex-libintl-0.18.3.1.patch81
-rw-r--r--09-gnulib-fix-underscore-cond.patch11
-rw-r--r--PKGBUILD32
4 files changed, 96 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38001bb75e7c..ffb0a03a4440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 16 17:51:40 UTC 2016
+# Sat Aug 13 10:59:49 UTC 2016
pkgbase = mingw-w64-gettext
pkgdesc = GNU internationalization library (mingw-w64)
- pkgver = 0.19.7
+ pkgver = 0.19.8.1
pkgrel = 1
url = http://www.gnu.org/software/gettext/
arch = any
@@ -14,20 +14,22 @@ pkgbase = mingw-w64-gettext
options = !strip
options = !buildflags
options = staticlibs
- source = http://ftp.gnu.org/pub/gnu/gettext/gettext-0.19.7.tar.gz
- source = http://ftp.gnu.org/pub/gnu/gettext/gettext-0.19.7.tar.gz.sig
+ source = http://ftp.gnu.org/pub/gnu/gettext/gettext-0.19.8.1.tar.gz
+ source = http://ftp.gnu.org/pub/gnu/gettext/gettext-0.19.8.1.tar.gz.sig
source = 00-relocatex-libintl-0.18.3.1.patch
source = 05-always-use-libintl-vsnprintf.mingw.patch
source = 06-dont-include-ctype-after-gnulibs-wctype.mingw.patch
source = 07-fix-asprintf-conflict.mingw.patch
source = 08-vs-compatible.patch
- md5sums = 87c4ab267c4dce8a75db5d057bb3c92f
+ source = 09-gnulib-fix-underscore-cond.patch
+ md5sums = 97e034cf8ce5ba73a28ff6c3c0638092
md5sums = SKIP
- md5sums = 397d7d6d4abd15a70edb3c9f2bab4cd2
+ md5sums = 6f43ea4763a0cd461f60c71197832fba
md5sums = 27852a388b8cf38188dc392c244230ff
md5sums = f69747f43f279b8a81286cfe5916b82f
md5sums = 3ebccf730ec3377b068027eb2283afb2
md5sums = f5b611172ae58f1e4589a8d0c1d53414
+ md5sums = bed0da63d251975a21ca830f2f156766
pkgname = mingw-w64-gettext
diff --git a/00-relocatex-libintl-0.18.3.1.patch b/00-relocatex-libintl-0.18.3.1.patch
index ef372f9068de..a601fa259377 100644
--- a/00-relocatex-libintl-0.18.3.1.patch
+++ b/00-relocatex-libintl-0.18.3.1.patch
@@ -1,9 +1,9 @@
-diff -crBN gettext-0.18.3.1.orig/gettext-runtime/intl/bindtextdom.c gettext-0.18.3.1/gettext-runtime/intl/bindtextdom.c
-*** gettext-0.18.3.1.orig/gettext-runtime/intl/bindtextdom.c 2012-12-10 02:59:06.000000000 +0100
---- gettext-0.18.3.1/gettext-runtime/intl/bindtextdom.c 2014-01-08 21:50:51.057941500 +0100
+diff -crBN gettext-0.19.8.1/gettext-runtime/intl/bindtextdom.c{.orig,}
+*** gettext-0.19.8.1/gettext-runtime/intl/bindtextdom.c.orig 2016-03-20 08:37:53.000000000 +0100
+--- gettext-0.19.8.1/gettext-runtime/intl/bindtextdom.c 2016-08-12 19:01:05.714025915 +0200
***************
-*** 22,27 ****
---- 22,28 ----
+*** 21,26 ****
+--- 21,27 ----
#include <stddef.h>
#include <stdlib.h>
#include <string.h>
@@ -12,8 +12,8 @@ diff -crBN gettext-0.18.3.1.orig/gettext-runtime/intl/bindtextdom.c gettext-0.18
#include "gettextP.h"
#ifdef _LIBC
***************
-*** 66,71 ****
---- 67,78 ----
+*** 65,70 ****
+--- 66,77 ----
# define BIND_TEXTDOMAIN_CODESET libintl_bind_textdomain_codeset
#endif
@@ -27,28 +27,57 @@ diff -crBN gettext-0.18.3.1.orig/gettext-runtime/intl/bindtextdom.c gettext-0.18
to be used for the DOMAINNAME message catalog.
If *DIRNAMEP or *CODESETP is NULL, the corresponding attribute is not
***************
-*** 318,325 ****
---- 325,347 ----
+*** 317,350 ****
char *
BINDTEXTDOMAIN (const char *domainname, const char *dirname)
{
-+ /*
- set_binding_values (domainname, &dirname, NULL);
- return (char *) dirname;
-+ */
-+ if (!access (dirname, R_OK)) {
-+ set_binding_values (domainname, &dirname, NULL);
-+ return (char *) dirname;
-+ } else {
-+ char *locale_dirname, *installdir = strdup (dirname), *s;
-+ if ((s = strrchr (installdir, '/'))) *s = '\0';
-+ if ((s = strrchr (installdir, '/'))) *s = '\0';
-+ locale_dirname = relocatex (installdir, dirname);
-+ set_binding_values (domainname, (const char **) &locale_dirname, NULL);
-+ if (installdir)
-+ free (installdir);
-+ return (char *) locale_dirname;
-+ }
+! #ifdef __EMX__
+! const char *saved_dirname = dirname;
+! char dirname_with_drive[_MAX_PATH];
+!
+! /* Resolve UNIXROOT into dirname if it is not resolved by os2compat.[ch]. */
+! if (dirname && (dirname[0] == '/' || dirname[0] == '\\' ))
+! {
+! const char *unixroot = getenv ("UNIXROOT");
+! size_t len = strlen (dirname) + 1;
+!
+! if (unixroot
+! && unixroot[0] != '\0'
+! && unixroot[1] == ':'
+! && unixroot[2] == '\0'
+! && 2 + len <= _MAX_PATH)
+! {
+! memcpy (dirname_with_drive, unixroot, 2);
+! memcpy (dirname_with_drive + 2, dirname, len);
+!
+! dirname = dirname_with_drive;
+! }
+! }
+! #endif
+! set_binding_values (domainname, &dirname, NULL);
+! #ifdef __EMX__
+! dirname = saved_dirname;
+! #endif
+! return (char *) dirname;
+ }
+
+ /* Specify the character encoding in which the messages from the
+--- 324,341 ----
+ char *
+ BINDTEXTDOMAIN (const char *domainname, const char *dirname)
+ {
+! if (!access (dirname, R_OK)) {
+! set_binding_values (domainname, &dirname, NULL);
+! return (char *) dirname;
+! } else {
+! char *locale_dirname, *installdir = strdup (dirname), *s;
+! if ((s = strrchr (installdir, '/'))) *s = '\0';
+! if ((s = strrchr (installdir, '/'))) *s = '\0';
+! locale_dirname = relocatex (installdir, dirname);
+! set_binding_values (domainname, (const char **) &locale_dirname, NULL);
+! if (installdir) free (installdir);
+! return (char *) locale_dirname;
+! }
}
/* Specify the character encoding in which the messages from the
diff --git a/09-gnulib-fix-underscore-cond.patch b/09-gnulib-fix-underscore-cond.patch
new file mode 100644
index 000000000000..d1fa96022ef6
--- /dev/null
+++ b/09-gnulib-fix-underscore-cond.patch
@@ -0,0 +1,11 @@
+--- gettext-tools/gnulib-m4/asm-underscore.m4.orig 2016-08-12 19:58:41.845742375 +0200
++++ gettext-tools/gnulib-m4/asm-underscore.m4 2016-08-12 19:55:53.967056822 +0200
+@@ -29,7 +29,7 @@
+ EOF
+ # Look for the assembly language name in the .s file.
+ AC_TRY_COMMAND(${CC-cc} $CFLAGS $CPPFLAGS $gl_c_asm_opt conftest.c) >/dev/null 2>&1
+- if LC_ALL=C grep -E '(^|[^a-zA-Z0-9_])_foo([^a-zA-Z0-9_]|$)' conftest.$gl_asmext >/dev/null; then
++ if LC_ALL=C grep -E '(^|[[^a-zA-Z0-9_]])_foo([[^a-zA-Z0-9_]]|$)' conftest.$gl_asmext >/dev/null; then
+ gl_cv_prog_as_underscore=yes
+ else
+ gl_cv_prog_as_underscore=no
diff --git a/PKGBUILD b/PKGBUILD
index d4428480b1f9..3d62014b62b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Contributor: Filip Brcic <brcha@gna.org>
+# Contributor: Martchus <martchus@gmx.net>
+
pkgname=mingw-w64-gettext
-pkgver=0.19.7
+pkgver=0.19.8.1
pkgrel=1
-arch=(any)
-pkgdesc="GNU internationalization library (mingw-w64)"
-depends=(mingw-w64-termcap mingw-w64-libunistring)
-makedepends=(gettext mingw-w64-configure)
+arch=('any')
+pkgdesc='GNU internationalization library (mingw-w64)'
+depends=('mingw-w64-termcap' 'mingw-w64-libunistring')
+makedepends=('gettext' 'mingw-w64-configure')
options=(!strip !buildflags staticlibs)
license=("GPL")
url="http://www.gnu.org/software/gettext/"
@@ -14,17 +16,19 @@ source=("http://ftp.gnu.org/pub/gnu/gettext/gettext-${pkgver}.tar.gz"{,.sig}
"05-always-use-libintl-vsnprintf.mingw.patch"
"06-dont-include-ctype-after-gnulibs-wctype.mingw.patch"
"07-fix-asprintf-conflict.mingw.patch"
- "08-vs-compatible.patch")
-md5sums=('87c4ab267c4dce8a75db5d057bb3c92f'
+ "08-vs-compatible.patch"
+ "09-gnulib-fix-underscore-cond.patch")
+md5sums=('97e034cf8ce5ba73a28ff6c3c0638092'
'SKIP'
- '397d7d6d4abd15a70edb3c9f2bab4cd2'
+ '6f43ea4763a0cd461f60c71197832fba'
'27852a388b8cf38188dc392c244230ff'
'f69747f43f279b8a81286cfe5916b82f'
'3ebccf730ec3377b068027eb2283afb2'
- 'f5b611172ae58f1e4589a8d0c1d53414')
+ 'f5b611172ae58f1e4589a8d0c1d53414'
+ 'bed0da63d251975a21ca830f2f156766')
validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # Daiki Ueno
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd gettext-$pkgver
@@ -36,6 +40,8 @@ prepare() {
patch -p0 -i ${srcdir}/06-dont-include-ctype-after-gnulibs-wctype.mingw.patch
patch -p0 -i ${srcdir}/07-fix-asprintf-conflict.mingw.patch
patch -p0 -i ${srcdir}/08-vs-compatible.patch
+ # prevents "Cannot export rpl_printf: symbol not found"
+ patch -p0 -i ${srcdir}/09-gnulib-fix-underscore-cond.patch
}
build() {
@@ -43,6 +49,12 @@ build() {
unset LDFLAGS
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
+ # define USER_LABEL_PREFIX_UNDERSCORE to prevent undefined reference to `__imp_exit_failure'
+ # and similar errors
+ local underscore_flag=''
+ [[ ${_arch} == i686-w64-mingw32 ]] && underscore_flag='-DUSER_LABEL_PREFIX_UNDERSCORE'
+ export CFLAGS="$underscore_flag"
+ export CXXFLAGS="$underscore_flag"
${_arch}-configure \
--disable-java \
--disable-native-java \