summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-14 20:55:26 +0200
committerMartchus2016-08-14 20:58:12 +0200
commitc0d25d9839cfb637e9cf5168489de9b297917894 (patch)
treeeab754b653cb13d6f4eb5f37a42fa40f0355d27f
parent898cdcf8a3d47a05dcdfbb3894e482f71817b4e6 (diff)
downloadaur-c0d25d9839cfb637e9cf5168489de9b297917894.tar.gz
Add pkg-config file for intl
to fix https://github.com/Alexpux/MINGW-packages/issues/744
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--intl.pc13
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffb0a03a4440..9f0c028f0c5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Aug 13 10:59:49 UTC 2016
+# Sun Aug 14 18:58:02 UTC 2016
pkgbase = mingw-w64-gettext
pkgdesc = GNU internationalization library (mingw-w64)
pkgver = 0.19.8.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/gettext/
arch = any
license = GPL
@@ -22,6 +22,7 @@ pkgbase = mingw-w64-gettext
source = 07-fix-asprintf-conflict.mingw.patch
source = 08-vs-compatible.patch
source = 09-gnulib-fix-underscore-cond.patch
+ source = intl.pc
md5sums = 97e034cf8ce5ba73a28ff6c3c0638092
md5sums = SKIP
md5sums = 6f43ea4763a0cd461f60c71197832fba
@@ -30,6 +31,7 @@ pkgbase = mingw-w64-gettext
md5sums = 3ebccf730ec3377b068027eb2283afb2
md5sums = f5b611172ae58f1e4589a8d0c1d53414
md5sums = bed0da63d251975a21ca830f2f156766
+ md5sums = b0a123ec7ad1a345d0d712dae986a543
pkgname = mingw-w64-gettext
diff --git a/PKGBUILD b/PKGBUILD
index 3d62014b62b9..9165fe70c51a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-gettext
pkgver=0.19.8.1
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc='GNU internationalization library (mingw-w64)'
depends=('mingw-w64-termcap' 'mingw-w64-libunistring')
@@ -17,7 +17,8 @@ source=("http://ftp.gnu.org/pub/gnu/gettext/gettext-${pkgver}.tar.gz"{,.sig}
"06-dont-include-ctype-after-gnulibs-wctype.mingw.patch"
"07-fix-asprintf-conflict.mingw.patch"
"08-vs-compatible.patch"
- "09-gnulib-fix-underscore-cond.patch")
+ "09-gnulib-fix-underscore-cond.patch"
+ "intl.pc")
md5sums=('97e034cf8ce5ba73a28ff6c3c0638092'
'SKIP'
'6f43ea4763a0cd461f60c71197832fba'
@@ -25,7 +26,8 @@ md5sums=('97e034cf8ce5ba73a28ff6c3c0638092'
'f69747f43f279b8a81286cfe5916b82f'
'3ebccf730ec3377b068027eb2283afb2'
'f5b611172ae58f1e4589a8d0c1d53414'
- 'bed0da63d251975a21ca830f2f156766')
+ 'bed0da63d251975a21ca830f2f156766'
+ 'b0a123ec7ad1a345d0d712dae986a543')
validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # Daiki Ueno
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -76,5 +78,11 @@ package() {
rm "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ # provide pkgconfig file for iconv library
+ install -dm755 "$pkgdir/usr/${_arch}/lib/pkgconfig"
+ install -m644 "$srcdir/intl.pc" "$pkgdir/usr/${_arch}/lib/pkgconfig"
+ sed -i "$pkgdir/usr/${_arch}/lib/pkgconfig/intl.pc" \
+ -e "s|@PREFIX[@]|/usr/${_arch}|g" \
+ -e "s|@VERSION[@]|$pkgver|g"
done
}
diff --git a/intl.pc b/intl.pc
new file mode 100644
index 000000000000..2a37d22beb42
--- /dev/null
+++ b/intl.pc
@@ -0,0 +1,13 @@
+prefix=@PREFIX@
+exec_prefix=@PREFIX@
+libdir=@PREFIX@/lib
+includedir=@PREFIX@/include
+
+Name: intl
+Description: Provides native language support to programs
+Version: @VERSION@
+
+Libs: -L${libdir} -lintl
+Libs.private: -liconv
+Requires.private:
+Cflags: -I${includedir}