summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-10-19 11:54:41 -0700
committerBuildTools2015-10-19 11:54:41 -0700
commit5a5664d6e0a22563cb70a4dfecd4fe6f73acbe51 (patch)
treefe54bb193270f114618fa9f0e08dfb2e9b41e1ff
parent1809d742324bad809623f5dac5bc5bf9669d7fed (diff)
downloadaur-5a5664d6e0a22563cb70a4dfecd4fe6f73acbe51.tar.gz
2.46.1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Revert-list-store-Fix-a-parameter-check.patch74
-rw-r--r--0030-right-wstat-for-64bit.patch14
-rw-r--r--PKGBUILD14
4 files changed, 7 insertions, 105 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad9d37b0ccdd..8df03ec4f7d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-glib2
pkgdesc = Common C routines used by GTK+ and other libs (mingw-w64)
- pkgver = 2.46.0
+ pkgver = 2.46.1
pkgrel = 1
url = http://www.gtk.org/
arch = any
@@ -16,8 +16,7 @@ pkgbase = mingw-w64-glib2
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.0.tar.xz
- source = 0001-Revert-list-store-Fix-a-parameter-check.patch
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.1.tar.xz
source = 0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch
source = 0003-g_abort.all.patch
source = 0004-glib-prefer-constructors-over-DllMain.patch
@@ -26,10 +25,8 @@ pkgbase = mingw-w64-glib2
source = 0027-no_sys_if_nametoindex.patch
source = 0028-inode_directory.patch
source = 0029-grand.all.patch
- source = 0030-right-wstat-for-64bit.patch
source = revert-warn-glib-compile-schemas.patch
- sha256sums = b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4
- sha256sums = 261ae2d2c7b94460f33ab569540313e21c9a50af38a7ebe8412e49f5b309af35
+ sha256sums = 5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb
sha256sums = ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3
sha256sums = 1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6
sha256sums = 7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6
@@ -38,7 +35,6 @@ pkgbase = mingw-w64-glib2
sha256sums = 5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837
sha256sums = f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b
sha256sums = dd26a015cdd65ee270251a11ef4c646000b26bb435992e6c997a615c1c14602e
- sha256sums = fe5b19dbb77b22abb1e4b4771bc1f97b3fce9f3b3792b83c83e439f76aeced3e
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
pkgname = mingw-w64-glib2
diff --git a/0001-Revert-list-store-Fix-a-parameter-check.patch b/0001-Revert-list-store-Fix-a-parameter-check.patch
deleted file mode 100644
index 397ff93df0a8..000000000000
--- a/0001-Revert-list-store-Fix-a-parameter-check.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 19a560f9491c4964e7093e22cb3876fc53a442e6 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Wed, 23 Sep 2015 23:16:04 +0200
-Subject: [PATCH] Revert "list store: Fix a parameter check"
-
-This reverts commit d28639507db2029b8f184a5d93e9d8c28acc1955.
-
-Bogus commit changing the behavior of g_sequence_search in violation
-of the documentation. Breaks GStreamer test suite.
----
- glib/gsequence.c | 18 +++++++-----------
- 1 file changed, 7 insertions(+), 11 deletions(-)
-
-diff --git a/glib/gsequence.c b/glib/gsequence.c
-index 75c1f76..76e24e7 100644
---- a/glib/gsequence.c
-+++ b/glib/gsequence.c
-@@ -139,8 +139,7 @@ static GSequenceNode *node_find_closest (GSequenceNode *haystack,
- GSequenceNode *needle,
- GSequenceNode *end,
- GSequenceIterCompareFunc cmp,
-- gpointer user_data,
-- gboolean return_match);
-+ gpointer user_data);
- static gint node_get_length (GSequenceNode *node);
- static void node_free (GSequenceNode *node,
- GSequence *seq);
-@@ -1080,7 +1079,7 @@ g_sequence_search_iter (GSequence *seq,
- dummy = g_sequence_append (tmp_seq, data);
-
- node = node_find_closest (seq->end_node, dummy,
-- seq->end_node, iter_cmp, cmp_data, TRUE);
-+ seq->end_node, iter_cmp, cmp_data);
-
- g_sequence_free (tmp_seq);
-
-@@ -1734,8 +1733,7 @@ node_find_closest (GSequenceNode *haystack,
- GSequenceNode *needle,
- GSequenceNode *end,
- GSequenceIterCompareFunc iter_cmp,
-- gpointer cmp_data,
-- gboolean return_match)
-+ gpointer cmp_data)
- {
- GSequenceNode *best;
- gint c;
-@@ -1765,12 +1763,10 @@ node_find_closest (GSequenceNode *haystack,
- }
- while (haystack != NULL);
-
-- /* If the best node is smaller than the data, then move one step
-- * to the right to make sure the best one is strictly bigger than the data.
-- * We do return the last exact match or the node after it, depending on
-- * the return_match argument.
-+ /* If the best node is smaller or equal to the data, then move one step
-+ * to the right to make sure the best one is strictly bigger than the data
- */
-- if (best != end && (c < 0 || (c == 0 && !return_match)))
-+ if (best != end && c <= 0)
- best = node_get_next (best);
-
- return best;
-@@ -1992,7 +1988,7 @@ node_insert_sorted (GSequenceNode *node,
- {
- GSequenceNode *closest;
-
-- closest = node_find_closest (node, new, end, iter_cmp, cmp_data, FALSE);
-+ closest = node_find_closest (node, new, end, iter_cmp, cmp_data);
-
- node_unlink (new);
-
---
-2.5.3
-
diff --git a/0030-right-wstat-for-64bit.patch b/0030-right-wstat-for-64bit.patch
deleted file mode 100644
index a92fe9ed0932..000000000000
--- a/0030-right-wstat-for-64bit.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- glib-2.46.0/gio/glocalfile.c.orig 2015-09-22 09:21:19.504654600 +0300
-+++ glib-2.46.0/gio/glocalfile.c 2015-09-22 09:22:36.185897400 +0300
-@@ -2682,7 +2682,11 @@
- (!g_path_is_absolute (filename) || len > g_path_skip_root (filename) - filename))
- wfilename[len] = '\0';
-
-+#ifdef _WIN64
-+ retval = _wstati64 (wfilename, &buf);
-+#else
- retval = _wstat32i64 (wfilename, &buf);
-+#endif
- save_errno = errno;
-
- g_free (wfilename);
diff --git a/PKGBUILD b/PKGBUILD
index 59d85d4f288e..7e5794e60b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
-pkgver=2.46.0
+pkgver=2.46.1
pkgrel=1
arch=(any)
pkgdesc="Common C routines used by GTK+ and other libs (mingw-w64)"
@@ -12,7 +12,6 @@ license=("LGPL")
options=(!strip !buildflags staticlibs !emptydirs)
url="http://www.gtk.org/"
source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz"
-"0001-Revert-list-store-Fix-a-parameter-check.patch"
"0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
"0003-g_abort.all.patch"
"0004-glib-prefer-constructors-over-DllMain.patch"
@@ -21,10 +20,8 @@ source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.t
"0027-no_sys_if_nametoindex.patch"
"0028-inode_directory.patch"
"0029-grand.all.patch"
-"0030-right-wstat-for-64bit.patch"
"revert-warn-glib-compile-schemas.patch")
-sha256sums=('b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4'
- '261ae2d2c7b94460f33ab569540313e21c9a50af38a7ebe8412e49f5b309af35'
+sha256sums=('5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb'
'ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3'
'1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6'
'7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6'
@@ -33,14 +30,12 @@ sha256sums=('b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4'
'5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837'
'f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b'
'dd26a015cdd65ee270251a11ef4c646000b26bb435992e6c997a615c1c14602e'
- 'fe5b19dbb77b22abb1e4b4771bc1f97b3fce9f3b3792b83c83e439f76aeced3e'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd glib-$pkgver
- patch -Np1 -i ../0001-Revert-list-store-Fix-a-parameter-check.patch
patch -Np1 -i "$srcdir/0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
patch -Np1 -i "$srcdir/0003-g_abort.all.patch"
patch -Np1 -i "$srcdir/0004-glib-prefer-constructors-over-DllMain.patch"
@@ -49,7 +44,6 @@ prepare() {
patch -Np1 -i "$srcdir/0027-no_sys_if_nametoindex.patch"
patch -Np1 -i "$srcdir/0028-inode_directory.patch"
patch -Np1 -i "${srcdir}/0029-grand.all.patch"
- patch -Np1 -i "${srcdir}/0030-right-wstat-for-64bit.patch"
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
NOCONFIGURE=1 ./autogen.sh
}
@@ -79,9 +73,9 @@ package() {
make DESTDIR="$pkgdir" install
make -C "$srcdir/glib-$pkgver/build-${_arch}-static" DESTDIR="$pkgdir/static" install
mv "$pkgdir/static/usr/${_arch}/lib/"*.a "$pkgdir/usr/${_arch}/lib/"
- find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.def' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.def' | xargs rm
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
rm "$pkgdir/usr/${_arch}/bin/"{glib-{gettextize,mkenums},gdbus-codegen}
rm -r "$pkgdir/usr/${_arch}/lib/charset.alias"
rm -r "$pkgdir/static"